Closed Bug 1442419 Opened 2 years ago Closed 2 years ago

Snap fails to open downloaded files

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set

Tracking

(firefox59 fixed, firefox60 fixed)

RESOLVED FIXED
Tracking Status
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: ken.vandine, Assigned: ken.vandine)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/65.0.3325.88 Chrome/65.0.3325.88 Safari/537.36

Steps to reproduce:

After downloading a file, opening it fails.  The snap attempts to exec that process registered to handle the type by default, which is not denied by apparmor.
Comment on attachment 8955319 [details]
Bug 1442419 - Fix failure to open files after downloading with snap

https://reviewboard.mozilla.org/r/224480/#review230646

Looks right to me. Thank you very much for the detailed explanations!
Attachment #8955319 - Flags: review?(jlorenzo) → review+
Assignee: nobody → ken.vandine
Blocks: snappy
See Also: → 1441822, 1441894, 1441900
Comment on attachment 8955319 [details]
Bug 1442419 - Fix failure to open files after downloading with snap

Approval Request Comment
[Feature/Bug causing the regression]: None
[User impact if declined]: Unable to ship the first Snap release. Snaps are a new package format powered by Canonical.
[Is this code covered by automated tests?]: N/A
[Has the fix been verified in Nightly?]: N/A. Releng crafts Snap on beta. Starting Firefox 59, Snap are also built on release.
[Needs manual test from QE? If yes, steps to reproduce]: No. This has been tested by Canonical's QA.
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: This is a Snap only fix for 59. It has no impact on the regular product.
[String changes made/needed]: None.
Attachment #8955319 - Flags: approval-mozilla-release?
See Also: → 1441884
Comment on attachment 8955319 [details]
Bug 1442419 - Fix failure to open files after downloading with snap

Should help with new snap builds. OK to uplift to m-r.
Attachment #8955319 - Flags: approval-mozilla-release? → approval-mozilla-release+
Best to land this on trunk first though.
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3800cbeee1e3
Fix failure to open files after downloading with snap r=jlorenzo
This needs a rebased patch for 59 (based on mozilla-release).
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(ken.vandine)
I'll take care of the rebase once comment 6 reaches central.
Flags: needinfo?(ken.vandine)
https://hg.mozilla.org/mozilla-central/rev/3800cbeee1e3
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1441920
This needs a bit of a tweak, we can drop the mime handler override and ship a mimeapps.list for xdg-open in the snap.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 1443736
Attached patch 1442419.patchSplinter Review
Bug 1442419 - Fixed typo in the mimeapps.list bundled in the snap
Comment on attachment 8957138 [details] [diff] [review]
1442419.patch

Review of attachment 8957138 [details] [diff] [review]:
-----------------------------------------------------------------

Okay to use .desktop instead of .html
Attachment #8957138 - Flags: review+
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5d6891646adb
Fixed typo in the mimeapps.list bundled in the snap r=jlorenzo
Comment on attachment 8957138 [details] [diff] [review]
1442419.patch

See comment 3.
Attachment #8957138 - Flags: approval-mozilla-release?
https://hg.mozilla.org/mozilla-central/rev/5d6891646adb
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Comment on attachment 8957138 [details] [diff] [review]
1442419.patch

Taking for 59rc3 since it doesn't affect anything we ship and doesn't require verification from our QE people.
Attachment #8957138 - Flags: approval-mozilla-release? → approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.