Stop using gcli commands for doing node screenshots in the inspector

RESOLVED DUPLICATE of bug 1483173

Status

enhancement
P2
normal
RESOLVED DUPLICATE of bug 1483173
a year ago
7 months ago

People

(Reporter: ochameau, Assigned: yulia)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

a year ago
Inspector has a context menu entry for screenshoting a DOM element.
It currently involves a GCLI command and should instead use an actor method to do that:
https://searchfox.org/mozilla-central/source/devtools/client/inspector/inspector.js#2107-2121

This is to be coordinated with bug 1447490 which also aims to remove another usage of screenshot command.

The actual screenshot code is here:
https://searchfox.org/mozilla-central/source/devtools/shared/gcli/commands/screenshot.js#80
Depends on: 1282462
I made this depend on bug 1282462 which aims at preserving the --fullpage option, which is very useful. I also think we should consider preserving the --dpi option somehow.
Assignee: nobody → ystartsev

Updated

11 months ago
Product: Firefox → DevTools
No longer depends on: 1463129
No longer depends on: 1463131
(Assignee)

Comment 2

9 months ago
Refactor the inspector code to use the same path as the webconsole, in order to remove GCLI
(Assignee)

Updated

8 months ago
Depends on: 1483173
(Assignee)

Updated

8 months ago
No longer depends on: 1473895
(Assignee)

Updated

8 months ago
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1483173
Attachment #8998169 - Attachment is obsolete: true

Updated

7 months ago
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.