Closed Bug 1463753 Opened 2 years ago Closed 2 years ago

DnD tabs broken on today's Nightly for Linux

Categories

(Core :: Widget: Gtk, defect, P1)

All
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- fixed

People

(Reporter: ahal, Assigned: stransky)

References

Details

(Keywords: regression)

Attachments

(1 file)

I ran mozregression and this is the culprit:
https://hg.mozilla.org/integration/autoland/rev/7e4166e13b3e

Which makes a lot of sense as I'm using Fedora 28 with Wayland.

I can pick up and drag a tab just fine, but the arrows to slot it in somewhere else never appear. If I drag horizontally along the tab bar, then the tab stays put instead of displacing its neighbouring tabs.
I had surmised that starting my session with Gnome Xorg instead of the default Wayland would work, but it's broken there too.
Summary: DnD tabs broken on today's Nightly for Linux+Wayland → DnD tabs broken on today's Nightly for Linux
Component: Tabbed Browser → Widget: Gtk
Product: Firefox → Core
Duplicate of this bug: 1463661
Assignee: nobody → stransky
Duplicate of this bug: 1463632
Duplicate of this bug: 1463804
Duplicate of this bug: 1463817
I'll look at it ASAP.
Priority: -- → P1
It seems that drag-and-drop almost works when moving the cursor to the title bar on Wayland. Perhaps it's related to Firefox using XWayland and the title bar using native Wayland? GIF below if it's helpful.

https://postimg.cc/image/sle0eeyqf/
I'm also unable to move buttons etc. in customize mode on TB Daily on Ubuntu 18.4.
Duplicate of this bug: 1464009
Comment on attachment 8980227 [details]
Bug 1463753 - [DragAndDrop] Update mTarget(Wayland)DragContext unconditionally and check its validity after that,

https://reviewboard.mozilla.org/r/246374/#review252484
Attachment #8980227 - Flags: review?(jhorak) → review+
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/172827af80fa
[DragAndDrop] Update mTarget(Wayland)DragContext unconditionally and check its validity after that, r=jhorak
https://hg.mozilla.org/mozilla-central/rev/172827af80fa
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Duplicate of this bug: 1464033
Duplicate of this bug: 1464124
Duplicate of this bug: 1464023
Duplicate of this bug: 1464159
Flags: in-qa-testsuite?(cornel.ionce)
Flags: in-qa-testsuite?(cornel.ionce) → in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.