Enable Shadow DOM in release builds

RESOLVED FIXED in Firefox 63

Status

()

P2
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

(Blocks: 1 bug, {dev-doc-complete})

unspecified
mozilla63
dev-doc-complete
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63+ fixed)

Details

Attachments

(3 attachments)

Comment hidden (empty)
(Assignee)

Updated

5 months ago
Blocks: 1471948

Updated

5 months ago
Blocks: 811542

Updated

5 months ago
Priority: -- → P2
Keywords: dev-doc-needed

Updated

4 months ago
status-firefox63: --- → affected
tracking-firefox63: --- → +
Smaug, is that ready to ride the trains?
Flags: needinfo?(bugs)
As of now, it looks like so.
Flags: needinfo?(bugs)
Created attachment 9001384 [details] [diff] [review]
enable_shadow_ce.diff

remote: Follow the progress of your build on Treeherder:
remote:   https://treeherder.mozilla.org/#/jobs?repo=try&revision=90ef127fe26cb43e6d0a291b23cba4d730e2167a
remote: recorded changegroup in replication log in 0.011s
Assignee: nobody → bugs
Comment on attachment 9001384 [details] [diff] [review]
enable_shadow_ce.diff

mrbkap isn't accepting reviews atm, so perhaps you could r+.
The patch is also for bug 1471948, since either both features need to be supported or neither.
Attachment #9001384 - Flags: review?(ehsan)

Comment 5

3 months ago
Comment on attachment 9001384 [details] [diff] [review]
enable_shadow_ce.diff

Review of attachment 9001384 [details] [diff] [review]:
-----------------------------------------------------------------

Congrats!

Shouldn't you also be updating some of the interface tests, e.g. <https://searchfox.org/mozilla-central/rev/5dbfd833bbb114afe758db4d4bdbc5b13bcc33ef/dom/tests/mochitest/general/test_interfaces.js#875>?
Attachment #9001384 - Flags: review?(ehsan) → review+
aha, yes, I probably should

Comment 8

3 months ago
Yep.  r+ on these changes, unless if you felt the patch really needs my eyes.  :-)
Created attachment 9001591 [details] [diff] [review]
enable_shadow_on_release_dom.diff

getComputedStyle-detached-subtree.html.ini was reviewed by emilio
in https://bugzilla.mozilla.org/show_bug.cgi?id=1483798
Other changes are obvious. ::parts aren't supported (and one could question why such tests are in wpt at all, since the spec is in flux)
Created attachment 9001595 [details] [diff] [review]
enable_shadow_on_release_dom_2.diff

rebased

Comment 11

3 months ago
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9b17b83509fd
bug 1471948 - Enable Shadow DOM and Custom Elements in release builds, r=ehsan, emilio

Comment 12

3 months ago
Backed out changeset 9b17b83509fd (bug 1471947) for leaks on mochitest

Log:

https://treeherder.mozilla.org/logviewer.html#?job_id=194311749&repo=mozilla-inbound&lineNumber=14175

INFO - TEST-INFO | leakcheck | tab process: leaked 44 xpcJSWeakReference
[task 2018-08-16T13:43:29.646Z] 13:43:29    ERROR - TEST-UNEXPECTED-FAIL | leakcheck | tab process: 14482511 bytes leaked (APZEventState, ActiveElementManager, AsyncFreeSnowWhite, AsyncLatencyLogger, Attr, ...)
[task 2018-08-16T13:43:29.647Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.648Z] 13:43:29     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 1199
[task 2018-08-16T13:43:29.650Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.651Z] 13:43:29     INFO -      |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2018-08-16T13:43:29.652Z] 13:43:29     INFO -      |                                      | Per-Inst   Leaked|   Total      Rem|
[task 2018-08-16T13:43:29.653Z] 13:43:29     INFO -    0 |TOTAL                                 |       54        0|   36349        0|
[task 2018-08-16T13:43:29.654Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.655Z] 13:43:29     INFO - nsTraceRefcnt::DumpStatistics: 413 entries
[task 2018-08-16T13:43:29.656Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.657Z] 13:43:29     INFO - TEST-PASS | leakcheck | tab process: no leaks detected!
[task 2018-08-16T13:43:29.657Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.658Z] 13:43:29     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 1163
[task 2018-08-16T13:43:29.659Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.660Z] 13:43:29     INFO -      |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2018-08-16T13:43:29.661Z] 13:43:29     INFO -      |                                      | Per-Inst   Leaked|   Total      Rem|
[task 2018-08-16T13:43:29.662Z] 13:43:29     INFO -    0 |TOTAL                                 |       32        0|  155201        0|
[task 2018-08-16T13:43:29.663Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.664Z] 13:43:29     INFO - nsTraceRefcnt::DumpStatistics: 762 entries
[task 2018-08-16T13:43:29.665Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.666Z] 13:43:29     INFO - TEST-PASS | leakcheck | tab process: no leaks detected!
[task 2018-08-16T13:43:29.667Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.668Z] 13:43:29     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 1060
[task 2018-08-16T13:43:29.669Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.670Z] 13:43:29     INFO -      |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2018-08-16T13:43:29.671Z] 13:43:29     INFO -      |                                      | Per-Inst   Leaked|   Total      Rem|
[task 2018-08-16T13:43:29.673Z] 13:43:29     INFO -    0 |TOTAL                                 |       42        0|109424768        0|
[task 2018-08-16T13:43:29.673Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.677Z] 13:43:29     INFO - nsTraceRefcnt::DumpStatistics: 1918 entries
[task 2018-08-16T13:43:29.678Z] 13:43:29     INFO - 
[task 2018-08-16T13:43:29.680Z] 13:43:29     INFO - TEST-PASS | leakcheck | default process: no leaks detected!
[task 2018-08-16T13:43:29.680Z] 13:43:29     INFO - runtests.py | Running tests: end.
[task 2018-08-16T13:43:29.681Z] 13:43:29     INFO - Buffered messages finished
[task 2018-08-16T13:43:29.681Z] 13:43:29     INFO - Running manifest: dom/tests/mochitest/dom-level2-core/mochitest.ini
[task 2018-08-16T13:43:29.681Z] 13:43:29     INFO -  Setting pipeline to PAUSED ...
[task 2018-08-16T13:43:29.682Z] 13:43:29     INFO -  Pipeline is PREROLLING ...
[task 2018-08-16T13:43:29.682Z] 13:43:29     INFO -  Pipeline is PREROLLED ...
[task 2018-08-16T13:43:29.682Z] 13:43:29     INFO -  Setting pipeline to PLAYING ...
[task 2018-08-16T13:43:29.683Z] 13:43:29     INFO -  New clock: GstSystemClock
[task 2018-08-16T13:43:29.684Z] 13:43:29     INFO -  Got EOS from element "pipeline0".
[task 2018-08-16T13:43:29.684Z] 13:43:29     INFO -  Execution ended after 0:00:00.033526507
[task 2018-08-16T13:43:29.685Z] 13:43:29     INFO -  Setting pipeline to PAUSED ...
[task 2018-08-16T13:43:29.686Z] 13:43:29     INFO -  Setting pipeline to READY ...
[task 2018-08-16T13:43:29.687Z] 13:43:29     INFO -  (gst-launch-1.0:1250): GStreamer-CRITICAL **: gst_object_unref: assertion '((GObject *) object)->ref_count > 0' failed
[task 2018-08-16T13:43:29.688Z] 13:43:29     INFO -  Setting pipeline to NULL ...
[task 2018-08-16T13:43:29.696Z] 13:43:29     INFO -  Freeing pipeline ...
[task 2018-08-16T13:43:30.150Z] 13:43:30     INFO -  pk12util: PKCS12 IMPORT SUCCESSFUL
[task 2018-08-16T13:43:30.571Z] 13:43:30     INFO - MochitestServer : launching [u'/builds/worker/workspace/build/tests/bin/xpcshell', '-g', '/builds/worker/workspace/build/application/firefox', '-f', '/builds/worker/workspace/build/tests/bin/components/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpdNSiSF.mozrunner'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '127.0.0.1'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', '/builds/worker/workspace/build/tests/mochitest/server.js']
[task 2018-08-16T13:43:30.572Z] 13:43:30     INFO - runtests.py | Server pid: 1273
[task 2018-08-16T13:43:30.817Z] 13:43:30     INFO - runtests.py | Websocket server pid: 1286
[task 2018-08-16T13:43:30.899Z] 13:43:30     INFO -  Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2018-08-16T13:43:30.900Z] 13:43:30     INFO -  [1273, Main Thread] WARNING: Could not get the program name for a cubeb stream.: 'NS_SUCCEEDED(rv)', file /builds/worker/workspace/build/src/dom/media/CubebUtils.cpp, line 363
[task 2018-08-16T13:43:30.941Z] 13:43:30     INFO - runtests.py | SSL tunnel pid: 1289
[task 2018-08-16T13:43:30.957Z] 13:43:30     INFO - runtests.py | Running with e10s: True
[task 2018-08-16T13:43:30.958Z] 13:43:30     INFO - runtests.py | Running tests: start.

Push with failures:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=9b17b83509fdf49c722bb9956bd85730b46dc353

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3594f4889a4316af5e979631a65d9c7a9bac00d6
Flags: needinfo?(bugs)
(Assignee)

Updated

3 months ago
Depends on: 1484040
Flags: needinfo?(bugs)

Comment 13

3 months ago
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/16daef3a89a2
bug 1471948 - Enable Shadow DOM and Custom Elements in release builds, r=ehsan, emilio
(Assignee)

Updated

3 months ago
Duplicate of this bug: 1483825

Comment 15

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/16daef3a89a2
Status: NEW → RESOLVED
Last Resolved: 3 months ago
status-firefox63: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63

Updated

3 months ago
See Also: → bug 1465592
Documentation updates — see https://bugzilla.mozilla.org/show_bug.cgi?id=1471948#c4
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.