No compatible Lightning version for TB 60 available at ATN (no Lightning available for TB installations from Linux distributions that have no Lightning package or rely on ATN/AMO for providing a localized Lightning version)

RESOLVED FIXED

Status

RESOLVED FIXED
7 months ago
a month ago

People

(Reporter: fkrueger, Assigned: Fallen)

Tracking

(Blocks: 1 bug)

Lightning 6.2

Details

User Story

For a WORKAROUND see comment 11.

Attachments

(2 attachments)

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180807170231

Steps to reproduce:

Update to TB 60.0 in a German environment.


Actual results:

Lightning is only available in English.


Expected results:

German version of Lightning, which is also not available via add-ons.
(Reporter)

Updated

7 months ago
Summary: Thunderbird 60.0 - Lighting not available for German Environment → Thunderbird 60.0 - Lightning not available for German Environment
(Reporter)

Comment 1

7 months ago
FYI: openSUSE Tumbleweed/Leap 15.0
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: Thunderbird 60.0 - Lightning not available for German Environment → Thunderbird 60.0 - Lightning not Available for German Environment

Updated

7 months ago
Summary: Thunderbird 60.0 - Lightning not Available for German Environment → Thunderbird 60.0 - Lightning not Available for German locale
(Reporter)

Comment 2

7 months ago
Since there has been no progress on the above-mentioned issue, I am using the German beta version of Lightning from https://ftp.mozilla.org/pub/calendar/lightning/candidates/6.2b6-candidates/build1/linux-x86_64/ for the time being.
Comment hidden (advocacy)
Does it work using the official Mozilla packages? The German Thunderbird 60.2.1 package should include German Lightning 6.2.2.1: https://www.thunderbird.net/en-US/thunderbird/all/#de
(Reporter)

Comment 5

6 months ago
Using the official Mozilla packages works as expected. However, since there is a longstanding bug on the openSUSE side regarding Lightning and its localization (https://bugzilla.opensuse.org/show_bug.cgi?id=939153), it is important to have it available as an addon. Currently only version 5.4 is provided at https://addons.thunderbird.net/de/thunderbird/addon/lightning/. Thanks, anyway.
As a temporary workaround you could test to manually install the Lightning package by taking the .xpi from the Mozilla package, i.e. extract thunderbird-60.2.1.tar.bz2 and take thunderbird/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi.

Comment 7

5 months ago
(In reply to FK from comment #2)
> Since there has been no progress on the above-mentioned issue, I am using
> the German beta version of Lightning from
> https://ftp.mozilla.org/pub/calendar/lightning/candidates/6.2b6-candidates/
> build1/linux-x86_64/ for the time being.

Had the same problem with TB 60 on debian stretch and spanish language, can confirm this solution works.

Updated

5 months ago
Duplicate of this bug: 1491246

Updated

5 months ago
Duplicate of this bug: 1499250

Updated

5 months ago
Duplicate of this bug: 1499317

Comment 11

5 months ago
Lightning isn't currently available as downloadable multi-locale addon at ATN (formerly AMO)[1] nor is a separate official language pack available that contains Lightning localizations.

If you install Thunderbird from the official website[2], Lightning is bundled and appropriately localized.

If you have troubles on aupdate check the trouble shooting kb article at [3] first, especially if your not on Linux.

If you have installed Thunderbird from the repository of your *Linux* distribution, for the time being you can either

- switch to the Mozilla builds of Thunderbird available at [2]
- install Lightning from the distributions package manager if available (Lightning is probably not localized if you are on a not en-US locale)
- download the Mozilla Thunderbird package from [2], extract the pacakge and take the Lighting addon {e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi from the distribution/extensions sub-folder therein and install it from file via addons manager to your current TB60 installation.

[1] https://addons.thunderbird.net/de/thunderbird/addon/lightning/
[2] https://www.thunderbird.net/en-US/thunderbird/all/
[3] https://support.mozilla.org/en-US/kb/calendar-updates-issues-thunderbird#w_when-i-use-my-user-profile-from-a-previous-thunderbird-version-with-a-newer-version-of-thunderbird-lightning-is-not-updated
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Summary: Thunderbird 60.0 - Lightning not Available for German locale → No compatible Lightning version for TB 60 available at ATN (no Lightning available for TB installations from Linux distributions that have no Lightning package or rely on ATN/AMO for providing a localized a Lightning version)

Updated

5 months ago
User Story: (updated)
This now hit all Ubuntu users as well.
Could we add a notice or link to this bug or workaround on the ATN/ATMO page? There's a lot of users getting frustrated there, it's hard to find this bug, etc.

Fixing it on Ubuntu was simply installing the xul-ext-lightning package, but unless you find this bug the situation is very confusing.

Updated

5 months ago
Summary: No compatible Lightning version for TB 60 available at ATN (no Lightning available for TB installations from Linux distributions that have no Lightning package or rely on ATN/AMO for providing a localized a Lightning version) → No compatible Lightning version for TB 60 available at ATN (no Lightning available for TB installations from Linux distributions that have no Lightning package or rely on ATN/AMO for providing a localized Lightning version)

Comment 14

5 months ago
No, installing xul-ext-lightning is not the solution as it doesn't provide localization. :-/

This ubuntu/linux problem persists for nearly one decade now but all ubuntu bug reports Ifound have been closed with the hint, users should install lightning from AddOns to have a translated calendar. :-/

Comment 15

5 months ago
Found many people complaining about this in various forums. To make it clear. I think, this problem should be solved on the linux package side but as this wasn't solved for so many years I don't think we will see any progress soon. And providing the current Lightning via Thunderbird-AddOns doesn't hurt anyone. Lightning is shown as the most installed AddOn by the way. But no compatible version available ... m(
Comment hidden (advocacy)

Comment 17

5 months ago
For those using Ubuntu 16.04, temporary fix from "https://ubuntuforums.org/search.php?searchid=18412438":

"Remove lightning the add-on which you probably got from the T'Bird add-on site and install the xul-ext-lightning package in the usual way for installing software.

It's the same add-on but this repository version is updated when the ubuntu repos are, and it will work with the T'Bird version you have."

Comment 18

5 months ago
While the xul-ext-lightning solution isn't a solution for locales, I ran into the same issue even in the English locale on Linux (Kubuntu 18.04), and had to manually tell Thunberbird to install from the version in /usr/lib/thunderbird-addons to get it to update after installing the package.

Documenting here just in case someone else runs into the same issue.

Again, this would have been resolved if Lightning was in the Thunderbird Addons so it could just update it like every other add-on.

Updated

5 months ago
Duplicate of this bug: 1499977
>this would have been resolved if Lightning was in the Thunderbird Addons

It's included with Thunderbird and automatically updates with it, so there's no point with it. This is a packaging issue, you won't get this problem with the official release.
Comment hidden (advocacy)
Comment hidden (offtopic)
Comment hidden (offtopic)
Comment hidden (offtopic)
Comment hidden (offtopic)

Comment 26

5 months ago
For Debian since Jessie (2015) the packages for Lightning localization are lightning-l10n-* (including for TB 60+). I've installed new systems recently and adding lightning-l10-fr provided proper, full localization in French for Lightning, using only my distribution packages.

See:
https://packages.debian.org/search?keywords=lightning-l10n&searchon=names&suite=all&section=all

For Ubuntu, see this (tl;dr: Invalid/unsolved):

* https://bugzilla.mozilla.org/show_bug.cgi?id=1074268
* https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/545778
Comment hidden (offtopic)
Comment hidden (offtopic)
Comment hidden (offtopic)

Comment 30

5 months ago
(In reply to Martin Pecka from comment #27)
> @[:MakeMyDay]: How do I get a compatible version of gdata provider for
> lightning extracted from tb installer? I see release date of the latest
> version on ATN (Sept 16) is earlier than the release date of Lightning
> 6.2.2.1 (Oct 2 according to
> https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/
> Calendar_Versions#Stable_Releases ). Or does it mean the gdata provider does
> not need an update?
> 
> Also, there's no answer in this thread for the question why there is no (at
> least English-only) release of Lightning on ATN. Can we help it somehow?

We will provide an ATN version, but there is no eta available. You should keep pushing your distributions to provide appropriate packages (this is what you help with).

The Provider for Google 4.4.2 is the up-to-date version to work with Lightning 6.2.x - there is not a separate release of it for every Lightning version.
Comment hidden (offtopic)
Comment hidden (offtopic)

Updated

5 months ago
Duplicate of this bug: 1500855

Comment 34

5 months ago
(In reply to Stefan Sitter [:ssitter] from comment #6)
> As a temporary workaround you could test to manually install the Lightning
> package by taking the .xpi from the Mozilla package, i.e. extract
> thunderbird-60.2.1.tar.bz2 and take
> thunderbird/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.
> xpi.

Have had the same problem with Ubuntu 16.04 LTS .Thunderbird "lightning" plugin was deactivated since Update to thunderbird 60.1.2. And not available in the offical plugin store.

Thanks for the Workaround, I am installed version 6.2b6 manually. it works.
Comment hidden (advocacy)
Comment hidden (advocacy)
(Assignee)

Comment 38

4 months ago
Ok, testing a new script that unifies Lightning. I'll need folks to test this version, it is based on Thunderbird 60.3.0. I'd like feedback for someone testing en-US, and someone testing any other locale.

Please install it and do a basic smoketest (open event dialogs, do some event modifications in the view, check the options, etc) and verify that there are no loading errors.

For the non-en-US Thunderbird users, please check to see if the interface is being localized. Note that for some locales there may be some occasional English mixed in if the localizers didn't translate all strings.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
(Assignee)

Comment 39

4 months ago
Thank you everyone for the comments. I went ahead and tagged some of the comments to make reading this bug a bit easier to digest. I don't mean this personally in any way. We acknowledge this is a problem, and I am looking to upload to ATN soon. I'm sorry this hasn't occurred sooner and hope that you will soon again be able to use your localized versions.

Updated

4 months ago
Blocks: 1215828

Updated

4 months ago
Duplicate of this bug: 1499583

Updated

4 months ago
Duplicate of this bug: 1502823

Comment 42

4 months ago
Thanks, Philipp. I tried to use your XPI with my stock TB 60.2.1 on Ubuntu (I edited the manifest to allow installation). Everything works nicely, including cz_CZ locale.

The only related thing that showed in the console is the following string translation, but that may also be because I'm using it with 60.2.1:

PluralForm.jsm: Index #2 of 'Proběhne každá středa
platí od 31. 10. 18 #5 krát
od 20:15 do 22:00.;Proběhne každá středa
platí od 31. 10. 18 #5 krát
od 20:15 do 22:00.' for value 10 is invalid -- plural rule #8; called by recurrenceRule2String


System info:

$ uname -a
Linux peci1-Latitude-E6540 4.19.0-041900-generic #201810221809 SMP Mon Oct 22 22:11:45 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.5 LTS
Release:	14.04
Codename:	trusty

$ aptitude search thunderbird | grep ^i
i A thunderbird                     - Email, RSS and newsgroup client with integ
i   thunderbird-globalmenu          - Email, RSS and newsgroup client (transitio
i   thunderbird-gnome-support       - Email, RSS and newsgroup client - GNOME su
i   thunderbird-locale-cs           - Czech language pack for Thunderbird       
i A thunderbird-locale-en           - English language pack for Thunderbird     
i   thunderbird-locale-en-gb        - Transitional English language pack for Thu
i   thunderbird-locale-en-us        - Transitional English language pack for Thu

$ aptitude search xul-ext
idA xul-ext-calendar-timezones                                              - Calendar Extension for Thunderbird (transitional package)                        
p   xul-ext-calendar-timezones:i386                                         - Calendar Extension for Thunderbird (transitional package)                        
p   xul-ext-deejayd-webui                                                   - Deejayd web user interface XUL extension                                         
v   xul-ext-enigmail                                                        -                                                                                  
v   xul-ext-enigmail:i386                                                   -                                                                                  
p   xul-ext-gdata-provider                                                  - Calendar Extension for Thunderbird (transitional package)                        
p   xul-ext-gdata-provider:i386                                             - Calendar Extension for Thunderbird (transitional package)                        
p   xul-ext-https-finder                                                    - extension that detects valid HTTPS pages as you browse                           
p   xul-ext-lightning                                                       - Calendar Extension for Thunderbird                                               
p   xul-ext-lightning:i386                                                  - Calendar Extension for Thunderbird                                               
p   xul-ext-mozvoikko                                                       - Finnish spell-checker extension for Firefox                                      
i   xul-ext-ubufox                                                          - Ubuntu modifications for Firefox                                                 
i   xul-ext-unity                                                           - Firefox extension: Unity Integration                                             
i   xul-ext-webaccounts                                                     - Ubuntu Online Accounts extension for firefox                                     
p   xul-ext-webaccounts:i386                                                - Ubuntu Online Accounts extension for firefox                                     
i   xul-ext-websites-integration                                            - Firefox extension: Website Integration                                           
p   xul-ext-y-u-no-validate                                                 - browser extension to make security exceptions temporary by default  

$ LANG=C apt-cache policy thunderbird
thunderbird:
  Installed: 1:60.2.1+build1-0ubuntu0.14.04.2
  Candidate: 1:60.2.1+build1-0ubuntu0.14.04.2
  Version table:
 *** 1:60.2.1+build1-0ubuntu0.14.04.2 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1:24.4.0+build1-0ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Updated

4 months ago
See Also: → bug 1506486
(Assignee)

Updated

4 months ago
Attachment #9023766 - Attachment description: lightning.xpi → Lightning 6.2.3 (Thunderbird 60.3.0)
(Assignee)

Comment 43

4 months ago
Thanks for testing Martin! I've packaged Lightning 6.2.2.1 as well, can you test that with your Thunderbird? I want to check if this is a translation issue or an issue with the code.
Flags: needinfo?(peci1)

Comment 44

4 months ago
Hi Philipp
I just installed your posted Lightning over the existing 6.2.3.
Running openSUSE 15, fully patched, in (Swiss) German localization.

Findings:

- Installed without (notable) error messages or issues (Didn't know where to look for logs)

- After TB restart: Immediately had German translated Lightning

- Did open various edit dialogs - all looking fine so far

- Went into the options: -> One issue: Categorie - Colors
Categorie colors are gone (except Status, which seems to be same word for German and English)
(No Problem for me, since I don't use the categories colors, but only different colors for different calendars. But those using it might have a problem with that.)


Phillip: Thank you for your great work.  :-)

Comment 45

4 months ago
Found another small (cosmetic) issue.

The Lightning options dialog (pop-up window) is too small for some localizations. And it doesn't adjust automatically to the right width and doesn't keep manual adjustments.

In the reminder tab of the Lightning options, in the reminder sound "section"/area, there are 3 buttons. In the German localization, the text is longer than in English and the buttons don't fit to the dialog window.

One can change the size of the options dialog window. However, after closing and re-opening, it is back to the too small width.
(If it could remind it size, issue could be solved.)

As said: No big issue for me (nothing at all in comparison to the localization issue before), but just reporting the findings.
(= NO show stopper!)

Comment 46

4 months ago
The translation bug is still there even with the repackaged XPI for 60.2.1.

I discovered one more issue (not sure if it was there with the adapted XPI for 60.3).

When I open the "Create new calendar" dialog, this shows up in the error console:

"Handler function DebuggerProgressListener.prototype.onWindowCreated threw an exception: TypeError: window is undefined
Stack: getWindowID@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/tab.js:38:3
DebuggerProgressListener.prototype.onWindowCreated<@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/tab.js:1551:19
exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
_fireEvent@chrome://global/content/bindings/wizard.xml:427:26
set_currentPage@chrome://global/content/bindings/wizard.xml:103:11
advance@chrome://global/content/bindings/wizard.xml:290:15
wizard_XBL_Constructor@chrome://global/content/bindings/wizard.xml:205:9
Line: 38, column: 3"  ThreadSafeDevToolsUtils.js:88:5
	reportException resource://devtools/shared/ThreadSafeDevToolsUtils.js:88:5
	exports.makeInfallible/< resource://devtools/shared/ThreadSafeDevToolsUtils.js:115:7
	_fireEvent chrome://global/content/bindings/wizard.xml:427:26
	set_currentPage chrome://global/content/bindings/wizard.xml:103:11
	advance chrome://global/content/bindings/wizard.xml:290:15
	wizard_XBL_Constructor chrome://global/content/bindings/wizard.xml:205:9
Flags: needinfo?(peci1)

Comment 47

4 months ago
A) To clarify my comments 44 and 45:
I did install the Lightning Add-On 6.2.3 as Philipp has published here as Attachment #9023766 [details] (between comment 42 and 43).
I did no packaging into a TB installation file. Just manually updating the Lightning Add-On.

B) Based on Martins comment 46, I did create some new local calendars. I added some events and finally deleted the calendar. For me, it all worked without any problems.

Comment 48

4 months ago
Thunderbird updated to 60.3.1. Does there need to be a corresponding patch here?

Updated

3 months ago
See Also: → bug 1074268

Updated

3 months ago
See Also: → bug 1513321
(Reporter)

Comment 49

2 months ago

FYI: Current version of Lightning (6.2.5) is available via https://addons.thunderbird.net/addon/lightning/ again.

(Assignee)

Comment 50

2 months ago

Yeah, I pushed these through. The locale issue doesn't seem to be specific to these repacks, but could be a locale issue also happening in a stock Thunderbird. Please check with a stock Thunderbird on a new profile and file a bug accordingly if the locale issue still exists. Thanks for the patience!

Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED

Comment 51

a month ago

(In reply to Philipp Kewisch [:Fallen] [:📆] from comment #50)

Yeah, I pushed these through. The locale issue doesn't seem to be specific to these repacks, but could be a locale issue also happening in a stock Thunderbird. Please check with a stock Thunderbird on a new profile and file a bug accordingly if the locale issue still exists. Thanks for the patience!

Thank you so much for fixing this issue! Would you please have a look at this corresponding and very long lasting ubuntu lightning translation f**kup?

https://bugs.launchpad.net/ubuntu/+source/lightning-sunbird/+bug/545778

I know that this is not your fault but you are my last hope in this case. Many many people suffer from missing lightning translation and I think this is because of fatal misunderstanding between Thunderbird devs and Ubuntu packet maintainers, where the translation has to take place. In Ubuntu thunderbird and lightning are still separate packages but the lightning one without any translation.

Installing (translated) Lightning from Addrons instead from ubuntu repo has been the recommended (dirty) workaround for many years. Dirty because this led to version mismatches here and there. And now ubuntu users had no translated lightning for some months again.

Could you please try to bring this problem to the right audience so that this bug can be finally solved? Thank you!

Rolando

(Reporter)

Comment 52

a month ago

This issue is not limited to Ubuntu, but also appears in other distros like openSUSE, where the bug is open since 2015 (https://bugzilla.opensuse.org/show_bug.cgi?id=939153).

Comment hidden (offtopic)
Comment hidden (offtopic)
Comment hidden (offtopic)

Comment 56

a month ago

Please stop commenting on a fixed bug, especially when getting off topic to the scope of the bug - this is an issue tracker not a discussion forum. For discussions we have discourse [1] or the mailing lists.

Thank you.

[1] https://discourse.mozilla.org/c/thunderbird

Restrict Comments: true

Hi Folks,

this bug is already restricted to those with editbugs, yet there are still various off-topic comments, as MakeMyDay just mentioned. Please make sure you have read the bugzilla etiquette and the Mozilla Participation Guidelines. Continued discussion on restricted bugs can also lead to further consequences such as revoking your editbugs rights.

While I can certainly talk to package maintainers, this is really an issue they need to solve. It may be more difficult now since there is no clear path for getting localized Lighting xpis or building the l10n repacked versions, but the data is there so it just needs to be put together right.

You need to log in before you can comment on or make changes to this bug.