Firefox-window isn't draggable anymore on the menubar-toolbar since latest Nightly versions

VERIFIED FIXED

Status

()

defect
P1
normal
VERIFIED FIXED
9 months ago
7 months ago

People

(Reporter: jacko.smitt, Assigned: mconley)

Tracking

({regression})

65 Branch
Desktop
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65+ verified, firefox66 verified)

Details

Attachments

(1 obsolete attachment)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

1) Use latest Nightly-build. (with a new profile)
2) Enable the menubar-toolbar.
3) Try to drag the firefox-window with the mouse on the menubar-toolbar.


Actual results:

You can't drag the firefox-window on the menubar-toolbar (no-drag area).
Only the tabbar/navigationtoolbar is draggable with the mouse.


Expected results:

The menubar-toolbar should be draggable with the mouse.

Additional information:
According to mozregression the problem was caused because of the introduced change of Bug 1507536.
Keywords: regression
Blocks: 1507536
Also double-clicking there doesn't maximize/minimize the window.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1509682
Duplicate of this bug: 1509713
mconley, can you look into this? seems to have been caused by your change.
Duplicate of this bug: 1509806
Duplicate of this bug: 1509601
Can confirm the bug. See also here: http://forums.mozillazine.org/viewtopic.php?p=14816368#p14816368
Thanks folks, bug is understood and assigned. I'll take it from here.
Assignee: nobody → mconley
Originally, there was a spacer node after the menubar items that was
draggable, but this was removed to simplify the DOM. This restores the
ability to drag and change the sizemode of the window with double-clicks
when the menubar is enabled.
Duplicate of this bug: 1509935
I think this is much more painful for our users than bug 1507536. What I suggest we do is:

1. Back out the fix for bug 1507536 to close out this bug
2. Keep the spacer after the menubar items, but put skipintoolbarset="true" on it to avoid the redundant context menu items.

Does that sound acceptable, dao?
Flags: needinfo?(dao+bmo)
In the interest of getting this into tomorrow's Nightly, I'm going to go ahead with this plan.
Flags: needinfo?(dao+bmo)
Fixed now that bug 1507536 has been backed out of central.
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Attachment #9027583 - Attachment is obsolete: true
I have reproduced this bug with Nightly 65.0a1(2018-11-25) on Windows 10, 64 bit!

The Bug's fix is now verified on Latest Beta 65.0b6

Build ID 	20181220174318
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
QA Whiteboard: [testday-20181221]
I successfully reproduced the issue on Firefox Nightly 65.0a1 under Windows 10 (x64) using the STR from Comment 0.

The issue is no longer reproducible on Firefox Beta 65.0b8 and latest Nightly 66.0a1 (2019-01-06) under Windows 10 (x64).

Thanks to Md. Majedul for verifying it too.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.