Closed Bug 15116 Opened 21 years ago Closed 15 years ago

rightmost pixels of italic text don't change on hover/blink (should set overflow area of text frames)

Categories

(Core :: Layout: Text and Fonts, defect, P4, minor)

defect

Tracking

()

RESOLVED DUPLICATE of bug 79732
Future

People

(Reporter: mats, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: css1, testcase, Whiteboard: [CSS1-5.4.3][CSS1-5.2.3])

Attachments

(2 files, 1 obsolete file)

Italic text in BLINK is not rendered correctly. Load the attached
testcase and you will see either of two errors:
1. The upper-right part of the '!' is not erased when the blink is "off".
2. The upper-right part of the '!' is not drawn when the blink is "on".

Which one is in effect depends on the width of the window, try resizing
and you will see the other error.

Bug occurs in both viewer and apprunner 1999-09-25-09-M11 on Windows NT4sp5.
Attached file testcase (obsolete) —
Whiteboard: [TESTCASE]
Assignee: beard → troy
Component: Compositor → Layout
This is more likely a layout bug.
Assignee: troy → kmcclusk
No, I think it's a problem with the text measurement code. Maybe a round off
error? If I turn on visual debugging it's clear the text frame's frame bounds
aren't quite big enough.

Kevin, are you the owner of the Windows gfx code?
Status: NEW → ASSIGNED
Target Milestone: M13
Yes, I own gfx on WIN32 it. I'll look at this.
Target Milestone: M13 → M15
Moving to M15
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
Bulk moving to M16
Target Milestone: M15 → M16
Moving to M17
Target Milestone: M16 → M17
Marking FUTURE. Niceness of BLINK handling not a priority for FCS. BLINK not 
widely used and is indeed widely hated.
Target Milestone: M17 → Future
Keywords: css1
Summary: Italic text in BLINK is not rendered correctly → Italic text in text-decoration:blink is not rendered correctly
Whiteboard: [TESTCASE]
I am no longer seeing the problem in a current build on WINNT. buld id 200103904.
Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
I still see this, build 2001-03-16-04 on Windows NT4.0 sp6. Please make sure you
have <font face="Snap ITC"> installed on your system when looking at the testcase.

Erik: Yes, I most certainly agree with you on BLINK, but this bug points to a more
general problem (I think), namely that text-measurements/line-boxes are calculated
wrong for certain fonts. I have seen other bugs pointing in that direction too.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Severity: normal → minor
WFM, today's Linux CVS. Mats, do you still see this?
Build moving all existing future-P3 bugs to future-P4.
Priority: P3 → P4
Whiteboard: [CSS1-5.4.3][CSS1-5.2.3]
Attached file Testcase without BLINK
Attachment #1897 - Attachment is obsolete: true
WFM. I do not see the problem described while looking at the testcase using
mozilla 1.0 (Win98).
Attachment #75829 - Attachment mime type: application/octet-stream → image/x-bmp
Confirmed using FizzillaCFM/2002070913. The top of the exclamation point draws
slightly outside the red-background inline box. Setting All/All.

This bug doesn't necessarily have anything to do with blink. Rather, the
calculation of the width of italicized text doesn't match the inline box that
contains it, resulting in text overdrawing the background-color area.

Revising Summary.
OS: Windows NT → All
Hardware: PC → All
Summary: Italic text in text-decoration:blink is not rendered correctly → Italicized text overdraws inline box boundary
On Mac, this, like many other problems, is fixed by bug 121540.
Isn't this just due to the font metrics for italic text lying about the char
widths (or rather the fact that in italic text the glyphs will often extend
outside the nominal "box" they're supposed to live in so that the spacing
between them won't look too big)?

Perhaps, although the metrics may have information on the italic correction.
Ah, true.

ccing some people who may know about that whole text-measurement thing and font
metrics.
Assignee: kmcclusk → font
Status: REOPENED → NEW
Component: Layout → Layout: Fonts and Text
QA Contact: petersen → ian
Summary: Italicized text overdraws inline box boundary → Italicized text overdraws inline box boundary (account for italic correction?)
*** Bug 93572 has been marked as a duplicate of this bug. ***
I'm not 100% is this applies, but it seems so. The italicized text if inside a
table also bleeds over the edges. Slashdot is an easy example where to see this,
since they put borders on the left side of their main content boxes, where you
can see letters like f and g bleed over the left edge of the table
*** Bug 215572 has been marked as a duplicate of this bug. ***
*** Bug 157470 has been marked as a duplicate of this bug. ***
As I said in bug 96041, which has collected a bunch of duplicates as well, this
should be solved by giving the text frames the appropriate overflow area somehow.
Summary: Italicized text overdraws inline box boundary (account for italic correction?) → rightmost pixels of italic text don't change on hover/blink (should set overflow area of text frames)
*** Bug 257208 has been marked as a duplicate of this bug. ***
*** Bug 276548 has been marked as a duplicate of this bug. ***
Blocks: 142805
I'm marking this a duplicate of 79732 because it's really the same issue.

*** This bug has been marked as a duplicate of 79732 ***
Status: NEW → RESOLVED
Closed: 19 years ago15 years ago
Resolution: --- → DUPLICATE
I wanted to leave them separate because handling italic correction might be
simpler than handling all overhanging characters, but together is ok if you
think it's got a good chance of being fixed.
*** Bug 311999 has been marked as a duplicate of this bug. ***
*** Bug 360919 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.