Closing a Tab should add Undo option when applicable

RESOLVED FIXED in Future

Status

SeaMonkey
Tabbed Browser
--
enhancement
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: Steve Brecht, Assigned: jag (Peter Annema))

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: parity-opera)

(Reporter)

Description

16 years ago
It would be handy if when a user closes a tab (maybe window also somehow?) the
undo option should be enabled to reopen that tab with the last URL.
(Assignee)

Comment 1

16 years ago
-> future
Target Milestone: --- → Future

Comment 2

16 years ago
Please change to OS ALL Platform ALL.

Comment 3

16 years ago
do we really want this?

microsoft never let me undo closing a document window.
Keywords: helpwanted
OS: Windows 98 → All
Hardware: PC → All

Comment 4

16 years ago
Accidental closing of a tab is not terribly difficult.

Undo should be limited, as opposed to the complex options available in e.g. a
wordprocessor, but the info is there for Moz to to it. Simply have in view menu
"reopen last closed tab", which could call the URL from last closed tab easier
than could the user try and figure out from history window which history item
was in the closed tab.

Comment 5

16 years ago
Reloading via history is also not terribly difficult, but neither will solve the
real problem, which is losing a partially completed form.  This is similar to
what could always happen closing a window, and we've got by without such a
feature for 8 years.  Does any product have anything like this?
(Reporter)

Comment 6

16 years ago
As far as the requirement goes for this feature... I have wanted something like
this in a browser since Netscape 2.x  It should be a relatively simple thing to
implement and it would save myself (and I would think not only me) a lot of
hassle at times.  It would be nice if it also functioned on last closed windows
too but that gets a little more sticky logistics wise.  I had envisioned it just
being an Undo option (since in the Browser... what else do we really Undo?)  but
as a new menu item it's not a bad idea either.   Has another browser ever had
this?  I don't think so.  Has that stopped Mozilla before?   To make Mozilla my
dream browser this one would surely help.

Comment 7

16 years ago
IIRC, Lotus 1-2-3 v2.2 introduced the concept of integrated undo to spreadsheets
somewhere around 1987. I think before that there was an add-in available with
undo function. In 1-2-3 v2.x there was never more than one sheet open at a time,
and thus no tabs. File retrieve closed the current sheet/file and opened a new
one, womething undo could completely reverse, IIRC.

It seems to me that any browser has no problem going back to a previous page.
That's what the back button is for. The close tab function could be made to
emulate the behavior of leaving a page, that is, save the entire state of a page
when the close tab function is called, saving it until such time as undo is
called again or until all browser windows are exited. This really would be
little different from what Mozilla does now when a different tab is made active,
except that the tab to restore it would be hidden until undo is called. Whether
the entire history of the closed tab should be preserved is a separate issue.
Maybe it should be preserved, but limited to a fixed number of entries like done
now with typed-in URL history.

Comment 8

16 years ago
See also bug 39165.

Comment 9

16 years ago
*** Bug 162259 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
It would be nice to have an undo feature, so I don't see why not.  It can easily
be done with history session.  We should we be concern about the loss of the
data session in this case?  Why is this bug still unconfirmed?  With the click
of the mouse, I can change it to new but it doesn't change the fact.  So, why
should the undo option not be used???

Updated

16 years ago
Blocks: 162592

Comment 11

16 years ago
You can look to Crazy Browser (http://www.crazybrowser.com/) and MyIE
(http://www.ruihehang.com/myie2/index.htm) to see how other browsers implement
this. Both use a variant of Edit->Undo and features an "Undo History" whereby it
keeps track of all the tabs you have closed. MyIE extends this functionality
with an optional toolbar button.
comfirming bug, but laeving at future and helpwanted.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → pmac

Updated

16 years ago
No longer blocks: 162592

Comment 13

15 years ago
*** Bug 215230 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
Opera 7.20 (but not earlier versions) let you undo closing tabs with Ctrl+Alt+Z.

Comment 15

15 years ago
*** Bug 234527 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
*** Bug 234120 has been marked as a duplicate of this bug. ***

Comment 17

14 years ago
*** Bug 247689 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
*** Bug 254021 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
*** Bug 258004 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
*** Bug 261738 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Whiteboard: parity-opera

Comment 21

14 years ago
Or course it will be 'feature', but there is an annoying situation without
'undo'. If you choose 'Close Tab' but due a mouse miss click to 'Close OTHER
Tabs' it is very unpleasant to search for closed tabs in history.
Will be glad to see View/Undo like in 3D Studio MAX.
*** Bug 280058 has been marked as a duplicate of this bug. ***

Comment 23

14 years ago
Is this actually distinguishable from bug 39165?

Comment 24

14 years ago
Here is a fix in the form of an extension:

http://extensionroom.mozdev.org/more-info/undoclosetab

Comment 25

13 years ago
*** Bug 296549 has been marked as a duplicate of this bug. ***

Comment 26

13 years ago
This should be a focus for the 2.0 aviary release. Now that draggable tabs are
in, this one makes sense also. 

Ditto for Duplicate Tab and FocusLastSelectedTab functions.

see:
http://twanno.mozdev.org/#duplicatetab
http://gorgias.de/mfe/   (Focus Last Selected Tab)
Flags: blocking-aviary2.0?

Comment 27

13 years ago
Also TabX (puts a close button on each tab)

Comment 28

13 years ago
Why there is a X button needed on every Tab? You can close them with a middle
(mouse-)click!

Comment 29

13 years ago
(In reply to comment #28)
> Why there is a X button needed on every Tab? You can close them with a middle
> (mouse-)click!

Not everyone has a middle mouse button.

Comment 30

13 years ago
> Also TabX (puts a close button on each tab)

Hell no! Only if it's optional and/or the tab bar can be scrolled.

When browsing with LOTS of tabs it is already difficult to open the ones on the
right hand side. I don't want to see what that looks like with a close button on
EVERY tab.

That would add usability problems rather than cure them.

Comment 31

13 years ago
Close tab X on individual tabs is WONTFIX Bug 108938. Please don't further spam
this bug with that subject.

Comment 32

13 years ago
*** Bug 314044 has been marked as a duplicate of this bug. ***

Comment 33

13 years ago
Would it be possible to take a smaller steps towards this goal, by being able to preserve the ensire browser state of a single browser to disk.  Serialize it to coin Java terminology.  Preferable to a text like file that could be edited outside of mozilla.

This would be useful if this was then integrated into X11 windows session management, where a user logging out with a bunch of tabs open, could have Mozilla save and restore on login back to the exact browser state and history.

It would be presumed that a page reload of the current page needs to be performed and reloads of the back history pages needs to happen, just like it does if you scroll far enough back anyway.

It would be really cool if for non-GET pages, instead of displaying a modal dialogue asking if you really want to do the POST again, that a HTML style page was display passivly with exactly the same message in the tab concerned.  This way no annoying dialog appears on session restore, just a neat HTML page with a Click to confirm reload link.

Each tabs state, would store the immediate Back History, immediate Forward History, any form data and other contents filled in, the scroll offset into the page, etc, etc...

This might also allow a new type of bookmark to exist, that goes beyond storing your current tab-group selection.  But also the history states.  Might be useful to some people ?

There maybe some extra information that would be more useful to an undo function within the same session.  For example during accidental window/tab closure, but not much use in a later session.  These details would need to be worked out.

A number of benifits would be possible to the end users as a result of this and its surrounding work.

Just needs someone to explain how it would be possible to go about doing that from the Mozilla code base ?    "helpwanted" on that area.
nice-to-have, not a blocker.  There's some improvements to be made about protecting tabs with partially completed forms, which is the big loss if you close that page (especially with the upcoming history rewrite that makes searching much less painful).
Flags: blocking-aviary2? → blocking-aviary2-

Updated

13 years ago
Flags: blocking-firefox2-

Comment 35

13 years ago
What happened to the ? 

Not seeing a - gets confusing, and sends the wrong signal. It should be indicated that this was denied a block status, so others don't go and set it again "accidentally".

Comment 36

13 years ago
For what it's worth, the SessionSaver extension's "SnapBack Tab" feature does this in the form of a submenu of the Tools menu listing the most recently closed x tabs, and I use it constantly. See http://adblock.ethereal.net/alchemy.cgi/SessionSaver

Comment 37

12 years ago
This feature works very well in Multizilla extension. You right click on a tab, select Reopen Closed Tabs and select which tab you want to reopen or select "Reopen all previously closed tabs".

See: http://multizilla.mozdev.org/

Comment 38

12 years ago
Now using Session Manager http://sessionmanager.mozdev.org/ extension to do this. Uninstalled UndoCloseTab. Thankfully, between browser improvements and better extensions, my extension list is a bit shorter lately.

Comment 39

12 years ago
You know Seamonkey and perhap Firefox now have the warning prompt (popup dialog) that tell us we're closing the main browser (via "x" box at upper right corner) instead of the tabs to help to reduce the "once in a while" accidentically of closing the main browser.  

One thing I know for sure is no one would want that warning prompt for the closing of every one of the tab windows because it's a hassle.  

Also a suggestion here is to avoid the adding of the "Undo" tab button at the upper right corner where the "x" button (close tab) is because it add the risk of accidentally of pressing the wrong button.  Might want to have that button at the upper left corner where the "Open a new tab" button is.  Menus is another story here.

Um, someone may want to file a bug (if the bug doesn't exist) on the missing "yellow pop-up highlight" comment where the "x" button (close tab) is since the "open a new tab" button have one.  If a bug had already been filed for that then please let us know what bug # that is...  That bug is so easy to fix in my opinion and it wouldn't hurt to have both of these bugs at once.
Since Firefox 2 includes the ability to reopen closed tabs, this bug sounds very fixed to me. Do reopen it if I'm being dense.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 41

12 years ago
SeaMonkey now also includes this, so it sounds fixed to me too. :)

Comment 42

12 years ago
Incidentally, this was fixed by bug 254021 (Firefox) and bug 350416 (SeaMonkey).
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.