Closed Bug 1527500 Opened 2 years ago Closed 2 years ago

[Context Menu] Implement Save to Pocket and bookmark menu option inside pocket new tab

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.2 - Apr 1 - 14
Tracking Status
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: dholbert, Assigned: pdahiya)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

Quoting :morgan's tweet:

for some reason I can't save @pocket articles from the new tab page in @FirefoxNightly. Was this removed? (I used to see a little ellipses symbol in the upper right on mouse-over)
https://twitter.com/MorgynRae/status/1095462704267972609

I'm pretty sure this change was due to the recent switchover to the "Pocket new-tab" experience in bug 1512725.

--> Filing this bug on adding an easily-discoverable (or at least, not-harder-than-it-was-before) to save one of the suggested articles to pocket.

As mconley said in a response on Twitter, there is at least a "Save link to pocket" entry in the right-click context menu (as there is for all links), but we might want to make it extra-easy for these likely-to-be-pocketable articles.

Blocks: 1512725

(sorry, I meant to say "the recent switchover...in bug 1523703". The bug I linked & tagged this as blocking, bug 1512725, seems to be the metabug for this feature in general.)

Severity: normal → enhancement
Iteration: --- → 67.3 - Feb 25 - Mar 10
Priority: -- → P1
Keywords: uiwanted

Marking this bug as duplicate of bug 1527642, as the menu shown against a story will have options to dismiss and save articles to pocket

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1527642
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Depends on: 1527642
Summary: Not as easy to save articles to pocket, with redesigned new tab UI → Implement Save to Pocket menu option inside pocket new tab context menu

Scope of this bug is to implement 'Save to Pocket' menu option for Pocket New Tab. Once a story is Saved to Pocket, menu options should change to 'Archive in Pocket' and 'Delete from Pocket'. See https://bugzilla.mozilla.org/show_bug.cgi?id=1527642#c6

Summary: Implement Save to Pocket menu option inside pocket new tab context menu → [Context Menu] Implement Save to Pocket menu option inside pocket new tab
Iteration: 67.3 - Feb 25 - Mar 10 → 68.1 - Mar 18 - 31
Assignee: nobody → pdahiya
No longer blocks: 1512725
Keywords: uiwanted
Duplicate of this bug: 1531587
Summary: [Context Menu] Implement Save to Pocket menu option inside pocket new tab → [Context Menu] Implement Save to Pocket and bookmark menu option inside pocket new tab
Iteration: 68.1 - Mar 18 - 31 → 68.2 - Apr 1 - 14
Keywords: github-merged
Blocks: 1541502
Blocks: 1541543
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I have verified this issue with the latest Firefox Nightly (68.0a1 Build ID - 20190404215521) installed, on Windows 10 x64, Arch Linux and Mac 10.14.4. Now the "Save to Pocket" and "Bookmark" options are displayed inside the "Pocket New Tab" menu according to the specs from the comment 9.

Status: RESOLVED → VERIFIED
Blocks: 1542218
You need to log in before you can comment on or make changes to this bug.