Closed Bug 1527715 Opened 2 years ago Closed 1 year ago

dragging message to the desktop or a folder is not working

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 630512

People

(Reporter: ovari123, Unassigned)

Details

Attachments

(2 files)

Attached image Error while copying.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

  1. Click and drag message to the desktop.
  2. Press Shift so that a copy would be created.
  3. Release the left mouse button.

Linux Mint 19.1 Cinnamon

Actual results:

Dialog box

Error while copying.
There was an error getting information about "Drafts>1281".

Show more details
The specified location is not supported

Cancel Skip All Skip Retry

Is this related to:
unresolved On Windows, dragging message to the desktop or a folder is not working. This will be fixed in the next version.
https://www.thunderbird.net/en-US/thunderbird/66.0beta/releasenotes/

Expected results:

A copy of the message should created on the Desktop

Jorg, which bug is the release note referring to? "unresolved On Windows, dragging message to the desktop or a folder is not working. This will be fixed in the next version.

Flags: needinfo?(jorgk)

Well, as far as I know, drag&drop of message was always flaky on Linux and Mac, but always worked on Windows until it broke in bug 1526971. It's fixed on trunk and I'll ship the fix in TB 66 beta 2.

Flags: needinfo?(jorgk)

Ovari, so this is only broken for you (now on version 68) for Linux and/or Mac?

Flags: needinfo?(ovari123)

(In reply to Wayne Mery (:wsmwk) from comment #3)

Ovari, so this is only broken for you (now on version 68) for Linux and/or Mac?

Thunderbird 60.9.0 (64-bit) is broken on Linux Mint 19.2 Cinnamon
https://www.thunderbird.net/en-US/thunderbird/60.9.0/releasenotes/
https://blog.linuxmint.com/?p=3786

Ubuntu and hence Linux Mint only follow the ESR stable release, which is currently on the Thunderbird 60.x branch.
https://launchpad.net/~mozillateam/+archive/ubuntu/thunderbird-next

Once the Thunderbird team releases a Thunderbird version on the 68.x branch that "will provide updates from earlier versions", Ubuntu can update the Ubuntu repositories which will then become available on Linux Mint.

A future version 68.2 will provide updates from earlier versions
https://www.thunderbird.net/en-US/thunderbird/68.1.2/releasenotes/

Wayne, can you advise when Thunderbird 68.2 will be released? This will enable testing on Linux Mint.

Thank you

Flags: needinfo?(ovari123) → needinfo?(vseerror)
Attached image could-not-display.png

Using Thunderbird 68.1.2 from Thunderbird on Ubuntu 18.04.3 LTS Gnome desktop.

I can drag and drop a message to the desktop.
It is not saved as an .eml file, but as a link to the folder the message came from in the account.
Clicking the link brings up this dialog.
I tried selecting the Ubuntu Thunderbird from the application list that appeared and nothing happened.

Selecting the email and using 'Save as...' then selecting the Desktop folder in the Save dialog does save it as an email file to the desktop.

(In reply to WaltS48 [:walts48] from comment #5)

  1. On Windows:
    a) Drag and drop a message on the Desktop (or into any folder) saves the message as an .eml file.
    b) The filename is helpful for the user as it is the subject of the email.

  2. On Linux:
    a) Drag and drop a message on the Desktop (or into any folder) should also save the message as an .eml file (not a link).
    b) The filename is not very helpful for the user. An example is 'Link to INBOX>36709'

  3. Selecting 'Save As…' is a workaround; however the UX is not as efficient as drag and drop to .eml.

(In reply to WaltS48 [:walts48] from comment #5)
As you confirmed, can the Status for this bug please be changed from UNCONFIRMED to NEW? Thank you

(In reply to Óvári from comment #7)

(In reply to WaltS48 [:walts48] from comment #5)
As you confirmed, can the Status for this bug please be changed from UNCONFIRMED to NEW? Thank you

I don't think it is a Thunderbird bug, but a Ubuntu bug since the operating system doesn't save the file on the desktop with the .eml extension.

The 'Save As...' workaround would be what I would use, if I saved emails files to the desktop. That way I don't have to minimize Thunderbird to see the desktop.

Drag and drop doesn't work even if I open the File Manager and drag the email to a folder like Documents. So I would use the context menu item.

Maybe it would work if the email accounts were stored as maildir instead of mbox in Thunderbird?

Nope doesn't work with an accounts Message Storage Type set to maildir (File per message). At least not with Thunderbird 60.9.0 on my Linux Mint 19.2 Cinnamon.

Michael Webster can you please implement the requirements like you have done so for:
Bug 1442474 Add support for window progress in Linux Cinnamon desktop using libxapp
https://bugzilla.mozilla.org/show_bug.cgi?id=1442474

Thank you

(In reply to Jorg K (GMT+2) from comment #2)

Well, as far as I know, drag&drop of message was always flaky on Linux and Mac, but always worked on Windows until it broke in bug 1526971. It's fixed on trunk and I'll ship the fix in TB 66 beta 2.

Indeed, see bug 630512.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630512

I have no idea when Ubuntu will update. That is a question you need to put to the people at ubuntu.

Flags: needinfo?(vseerror)

Is this a Thunderbird bug since this doesn't work on Ubuntu, Arch and macOS?

You need to log in before you can comment on or make changes to this bug.