Closed Bug 1555012 Opened 7 months ago Closed 6 months ago

Enable HTML about:addons by default

Categories

(Toolkit :: Add-ons Manager, task, P1)

task

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox68 + verified
firefox69 --- verified

People

(Reporter: robwu, Assigned: robwu)

References

(Depends on 1 open bug, Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(4 files)

We have created a new HTML-based about:addons page, with a few new features and an updated appearance (including support for dark themes).

The primary views (extensions/themes/plugins/updates list and details view) can be activated via the extensions.htmlaboutaddons.enabled preference. There are a couple of other features that may or may not be enabled at the same time. The full list of preferences is:

Blocks: 1544212
Depends on: 1555809

(added explicit dependencies on the bugs that are associated with the prefs to make it easier to track progress)

Priority: -- → P1
Depends on: 1557369
Assignee: nobody → rob
Status: NEW → ASSIGNED

Most recent try runs on m-c with relevant tests are green:

Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/c6d9871972a4
Enable HTML about:addons by default r=rpl
https://hg.mozilla.org/integration/autoland/rev/60f7565db88b
Enable abuse reporting at about:addons by default r=rpl

Upon enabling the HTML about:addons discovery pane, about:addons page
start to send a fetch request from the default user context, instead of
a content load request with the tab's user context.

This mismatch in userContextId triggers the following debug assertion:
https://searchfox.org/mozilla-central/rev/c606cdd6d014f/netwerk/base/nsNetUtil.cpp#3021-3024

This assertion can be ignored, because the request has no credentials,
so its context should not matter.

Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/6b172dc138ee
Skip about:addons in browser_aboutURLs.js r=rpl
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Attached image Bug1555012.gif

This issue is verified as fixed on Firefox 69.0a1 (20190612214235) under Win 7 64-bit and Mac OS X 10.14.1.

The next preferences were set to true by default.

  • “extensions.htmlaboutaddons.discover.enabled”
  • “extensions.htmlaboutaddons.enabled”
  • “extensions.abuseReport.enabled”

Please see the attached video.

Status: RESOLVED → VERIFIED

Comment on attachment 9070941 [details]
Bug 1555012 - Enable HTML about:addons by default

Beta/Release Uplift Approval Request

  • User impact if declined: If this does not get enabled in 68 (and part of ESR), then we have to maintain both HTML and XUL versions of the page, which may hinder our efforts to remove XUL (bug 1558982).

HTML about:addons also has features that are not implemented in the XUL version, such as abuse reporting (bug 1543377), recommendations (bug 1550911) and full dark theme support (bug 1551202).

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): Why risky: The extensions.htmlaboutaddons.enabled pref forces about:addons to use significantly different code (HTML instead of XUL).

Why not risky: HTML about:addons has extensive test coverage (including migration of existing tests in bug 1551490). The changes have been developed over the past few months (starting in bug 1514316), and is already being used by some (sometimes with bug reports for edge cases coming in within a few days of landing a feature, e.g. bug 1557509). The remaining dependencies of bug 1533795 are minor.

The new features themselves (abuse reporting, recommendations) can be toggled via preferences, if desired.

This project is supported by three engineers, so we can quickly respond to issues if needed.

  • String changes made/needed: none
Attachment #9070941 - Flags: approval-mozilla-beta?
Attachment #9071300 - Flags: approval-mozilla-beta?
Attachment #9071564 - Flags: approval-mozilla-beta?

Green try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=4f455d51fe0adda0a0924f6e6edf8b4bbe83b628
Green try (when the abuse reports are disabled): https://treeherder.mozilla.org/#/jobs?repo=try&revision=2ebde5486033fce159c22635ba49b9c27dbdd398

Almost green try when recommendations in the list are disabled: https://treeherder.mozilla.org/#/jobs?repo=try&revision=43b051b4ba851c43f7edbdfd1212e63996885afe (orange because browser_html_list_view_recommendations.js assumes that recommendations are enabled by default; if we have to flip the pref, then we easily force the pref in the test).

Comment on attachment 9070941 [details]
Bug 1555012 - Enable HTML about:addons by default

alright let's go ahead and enable this in 68.0b10.

Attachment #9070941 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9071300 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9071564 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This issue is verified as fixed on Firefox 68.0b10 (20190613141208) under Win 7 64-bit and Mac OS X 10.14.1.

Regressions: 1559378

Rob, will the old version remain in version 68? Thunderbird will need to adapt to the new about:addons, but if we did not have to do so for Thunderbird 68, that would make things much easier.

Flags: needinfo?(rob)

(In reply to Geoff Lankow (:darktrojan) from comment #15)

Rob, will the old version remain in version 68? Thunderbird will need to adapt to the new about:addons, but if we did not have to do so for Thunderbird 68, that would make things much easier.

Yes. 68 will have both XUL and HTML about:addons, but we plan to remove the XUL code starting in 69 (bug 1558982).

Flags: needinfo?(rob)
Regressions: 1560834
Regressions: 1561827
Regressions: 1560746
Regressions: 1562451
Regressions: 1568766
Regressions: 1580151
You need to log in before you can comment on or make changes to this bug.