Closed Bug 1549450 Opened 2 years ago Closed 8 months ago

Cleanup inline options browser hacks

Categories

(Toolkit :: Add-ons Manager, task, P2)

task

Tracking

()

RESOLVED FIXED
Tracking Status
firefox68 --- affected

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Blocks 1 open bug)

Details

We've collected a series of hacks to make inline options browsers work. We should look into fixing these at the root so we don't need to keep them around.

  • content-select-dropdowns element:
    • Select box menupopup/menulist.
    • Context menu element to proxy openPopupAtScreen method.
  • inline-options-browser element:
    • frameLoader.requestUpdatePosition() in scroll handler.
    • windowUtils.flushApzRepaints() in scroll handler.
Type: defect → task
Priority: -- → P2

The flushApzRepaints thing should be removable now that bug 1548687 is in.

Now that the context menu is "Fission-aware" (Bug 1505909, and the "about:addons inline options_page context menu" regression fixed in Bug 1558506) we can also remove this part: https://searchfox.org/mozilla-central/rev/f372470e10c8cb0691681603a1d6324dee5b3b8a/toolkit/mozapps/extensions/content/aboutaddons.js#1045-1053

(basically we can remove the "contextmenu" message manager listener, as it is not sent anymore and there is no point on registering a listener for it, but we still need to keep the ProxyContextMenu custom element definition and its instance in the aboutaddons.html page, to make the context menu internals able to open the expected context menu popup)

Depends on: 1565235
Duplicate of this bug: 1601487
Duplicate of this bug: 1602289
Assignee: nobody → mstriemer
Blocks: 1610227
No longer blocks: 1610227
Depends on: 1610227
Depends on: 1610622
Status: NEW → RESOLVED
Closed: 8 months ago
Flags: qe-verify-
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.