Closed Bug 1536761 Opened 8 months ago Closed 7 months ago

the "send to" function does not work on files with Polish characters

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1531724

People

(Reporter: mkasprowicz, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

The problem appeared when updating 60.5.2. At first, I could not send files at all by "send to" and later, and you still can not send files with Polish characters in the name. There are no problems without Polish characters.

The problem is on windows 7, on windows 10 there is no problem with shipping.

Actual results:

You can not send files by send to with Polish characters. It is sent without any problems without Polish characters

Expected results:

Files with Polish characters should be sent

Your description matches bug 1530820, fixed in 60.5.3 bug 1531724

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1530820

Unfortunately, I have a 60.6.1 update and on two computers I can not send a message if there are Polish characters in the name.

Does the description in bug 1545080 comment #6 help?

Duplicate of bug: 1531724

As the description in bug 1545080 comment #6 says - Close TB, start cmd.exe as admin and run this command:

reg delete "HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird" /v "SupportUTF8" /f

and/or:

reg delete "HKLM\SOFTWARE\Wow6432Node\Clients\Mail\Mozilla Thunderbird" /v "SupportUTF8" /f

Try to send mails with attached files contains polish characters in their names - "ąśćźżęóńł ĄŻŚŹĆĘÓŁŃ".

works on TB 60.5.1, 60.5.2, 60.5.3, 60.6.0 and 60.6.1.

But because installer of TB for now cannot remove this value from registry automaticly - see bug 1545362.

You must remove this manually after TB is updated.

60.5.2 sets SupportUTFP8 to 1,
60.5.3 - 60.6.1 sets SupportUFTP8 to 0

on some machines that is enough that sets it to 0, but on my ~200 machines that i manage, i must to remove this value from registry all the time, when TB is updated.

We're working on bug 1545362 and the registry value will be removed when TB 60.7 ships in May 2019.

You need to log in before you can comment on or make changes to this bug.