MAPI not working after automatic update to 60.5.2: Sending from external progam no longer works, nor does "Send to > Mail Recipient" - Solution in comment #30

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
2 months ago
4 days ago

People

(Reporter: konce7, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression 60.5.1 -> 60.5.2], URL)

(Reporter)

Description

2 months ago

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.119 Safari/537.36

Steps to reproduce:

Tried to send file as attachment in email using the "send as email attachment" button in Nitro PDF Reader and Adober Acrobat Reader DC and Adobe Acrobat 8.1. Also right-clicked on file and selected "send to: mail recipient". Using in Windows 7 Professional.

Actual results:

The first couple of times a new dialogue box came up asking if it was okay that another program wanted to use Thunderbird (to attach the file, I presume). I said yes, and then nothing happened. The third time I tried, I ticked the box to not ask every time. So that doesn't even come up now. Nothing, no-go, nada happening. Except frustration.

Expected results:

Thunderbird should have opened a window with a new email to write with the file already attached.

Comment 1

2 months ago

Jorg, possible regression from Bug 393302 or bug 494239 (correction: bug 594239, not 494239) here I think.

I can confirm that send to mail recipient does not work in 60.5.2 here. I get a dialog asking to size the image I try and send and then nothing. Under 50.5.0 (not a mistake I missed 5.1) I had the same result followed by a silent disappearance of Thunderbird from the task list. Using the 64Bit version.

Status: UNCONFIRMED → NEW
Component: Untriaged → Simple MAPI
Ever confirmed: true
Flags: needinfo?(jorgk)
OS: Unspecified → Windows
Product: Thunderbird → MailNews Core
Hardware: Unspecified → x86_64

Comment 2

2 months ago

When sending a file the following is shown in the error console

NS_ERROR_NOT_AVAILABLE: Cannot call openModalWindow on a hidden window nsPrompter.js:340

Updated

2 months ago
Keywords: regression

Comment 3

2 months ago

I don't have access to bug 494239. Yes, bug 393302 and its friends bug 1521007 and bug 594239 were included in TB 60.5.2 after some time in TB 65 beta 3 and 4 without negative feedback.

Have to tried a reboot after upgrading? We need to know the bit-ness of your Windows (32/64 bit) and the bit-ness of your TB (32/64 bit). BTW, we had similar reports for in bug 1524762, see attachment 9042611 [details], but we thought that was related to the MAPISendMailW implementation which we did not ship in TB 60.5.2 and also withdrew from TB 66 beta 2. BTW, bug 1524762 has links to some videos that show that the functionality is working, and it also works for me on Windows 10 64bit with TB 60.5.2 64bit. But that doesn't help the reporter.

Flags: needinfo?(jorgk) → needinfo?(mikekaganski)

Comment 4

2 months ago

Inventing bug...494239 Not sure where I made that number up from but I think just a typo of 594239. I don't have access to 494239 either.

I can confirm I have Thunderbird 64 60.5.2 installed on Windows 10 64bit. Installed it to test from the FTP releases using the full installer as an automated update had not occurred. The install performed an automated restart of windows. Previous version was 60.5.0. 60.5.0 simply disappeared from the windows task list when I used send to mail recipient (image file only tested).

My results with the 64 bit version are

1 I am asked for a scaling of the image I have elected to send
2. Nothing. Except the error console warning. So I assume it has some relevance.

A later test using send to > mail recipient with Thunderbird closed waited, and then launched Thunderbird daily 65 after asking if I wanted to allow my profile to be used to send mail. A check on my mail client in windows shows nothing daily related.

The version starting is Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Thunderbird/65.0a1 (2018-11-21) (64bit)I assume that was the last daily build I installed.

If I send an image file I see a size request and nothing. If I select an RDF file I get the daily launch and then nothing.

After three failures Thunderbird just disappeared from the task manager

Comment 5

2 months ago

TB disappearing from the task manager is simply a crash.

It's worrying that TB 65 Daily is started. That's an indication that something is screwed on the machine. This is all very brittle. TB 60.5.2 must be the last mail app installed and it must be Windows' default.

Comment 6

2 months ago

Hmm, doesn't appear to be working on my laptop where I've just installed 60.5.2. It was fine on my desktop. Sigh.

Comment 7

2 months ago

Now I also got the "Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client." message :-(

Comment 8

2 months ago

The difference between the desktop and the laptop is that the laptop as Outlook installed (pre-installed by Dell). When I uninstalled TB, Outlook fired up with messages containing the files I tried to send before using TB with "Send to > Mail recipient". So those requests got queued somewhere. Mike, I can offer you a TeamViewer session on this laptop if you want to check it out.

Neither uninstalling, restarting, re-installing TB fixed anything. Oh boy.

Oh, I checked all the registry entries, so
HKEY_CURRENT_USER\Software\Classes\mailto\DefaultIcon
HKEY_CURRENT_USER\Software\Classes\mailto\shell\open\command
HKEY_CURRENT_USER\Software\Classes\Thunderbird.Url.mailto\DefaultIcon
HKEY_CURRENT_USER\Software\Classes\Thunderbird.Url.mailto\shell\open\command
HKEY_CURRENT_USER\Software\Classes\ThunderbirdEML\DefaultIcon
HKEY_CURRENT_USER\Software\Classes\ThunderbirdEML\shell\open\command

as well as:
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{29F458BE-8866-11D5-A3DD-00B0D0F3BAA7}\LocalServer32

and they all seemed to be OK.

(Reporter)

Comment 9

2 months ago

Hey, checked the download page this morning and it said that the MAPI was fixed, so I downloaded again, installed and hey, it works again! Thanks to all who helped with the fix! Much appreciated! Is there somewhere I'm supposed to mark fixed or is that already taken care of since it says fixed on the download page? This is the first time I've submitted a bug.

~Konce

Comment 10

2 months ago

Thanks for letting us know. It still doesn't work for me, so we'll keep this bug open for further investigation.

Comment 11

2 months ago

I've the same problem, "Send to email recipient" stopped working both from desktop and external applications after upgrade to 60.5.2

Comment 12

2 months ago

OK, now on another desktop machine (which doesn't have MS Office/Outlook installed). Installed TB 60.5.2. "Send to > Mail recipient" works, sending from LibreOffice works. It's all good here. However, in the other room I have that laptop where nothing works. Go figure! :-(

Comment 13

2 months ago

I tracked down my daily load.... it came from HKEY_LOCAL_MACHINE\Software\Classes\mailto\shell\open\command Having fixed that though it still does not work.

Comment 14

2 months ago

Mystery, see comment #12. Do you have Office/Outlook installed?

Comment 15

2 months ago

Yes there is a copy of Outlook installed. Have just spend 2 hours trawling register and win.ini entries. No luck so far, but it looks like there might be another twist to this tale

https://support.mozilla.org/en-US/questions/1251573
and
https://support.mozilla.org/en-US/questions/1251581

I thought that Thunderbird never actually send MAPI mail with out a manual intervention though to click send.

Updated

2 months ago
Duplicate of this bug: 1530950

Comment 17

2 months ago

I confirm comment 2, today we have lots of our users that report a similar problem after automatic upgrade from 60.5.1 to 60.5.2. In the error console we can see the message "NS_ERROR_NOT_AVAILABLE: Cannot call openModalWindow on a hidden window nsPrompter.js:340"

Comment 18

2 months ago

Well on my computer (win 10 64bit), the bug appear in thunderbird 60.5.2 32bit, i juste installed thunderbird 64bit from http://ftp.mozilla.org/pub/thunderbird/releases/60.5.2/win64/fr/ and now everything seems working fine. So i guess there is a regression concerning 32bit / 64bit.

Comment 19

2 months ago

(In reply to Guillaume .J from comment #18)

Well on my computer (win 10 64bit), the bug appear in thunderbird 60.5.2 32bit, i juste installed thunderbird 64bit from http://ftp.mozilla.org/pub/thunderbird/releases/60.5.2/win64/fr/ and now everything seems working fine. So i guess there is a regression concerning 32bit / 64bit.

damn, it appears that it fix the right clic sent to ... but still doesn't fix a mapi call from a third part application. ¯_(ツ)_/¯

Comment 20

2 months ago

I can confirm it. I have Thunderbird 32-bit 60.5.2 installed on Windows 7 64bit, send messages from any program not work.
After I downgraded Thunderbird 32-bit version 60.5.1 messages began to be sent.
Further I tried run automatic or manual update (download from official site) to actual verssion 60.5.2 send messages from any program not work.

Comment 21

2 months ago

UPD: A clean install helped fix the error(In reply to dmitry from comment #20)

I can confirm it. I have Thunderbird 32-bit 60.5.2 installed on Windows 7 64bit, send messages from any program not work.
After I downgraded Thunderbird 32-bit version 60.5.1 messages began to be sent.
Further I tried run automatic or manual update (download from official site) to actual verssion 60.5.2 send messages from any program not work.

Comment 22

2 months ago

I can also confirm that installing 60.5.2 fresh over 60.5.2 itself, the problem seems to be fixed.
I made a note of all registry changes during the installation and it seems some traces of 60.5.1 were left behing during the autoupgrade (especially in the uninstall). It also seems that the registry sub-entries are changed from "Mozilla Thunderbird" to just "Thunderbird". I'm also missing some plugins (QuickFolders).

The changed registry entries are here: https://gist.github.com/rvk01/b9a7426360a20d6c91c98cee2f72e36e

Comment 23

2 months ago

(In reply to rvk from comment #22)

I'm also missing some plugins (QuickFolders).

Correction. The plugin seems to be ok.

Comment 24

2 months ago

I can also confirm, it's works with (re)installation of the version 60.5.2. QuickFolders runs also on my installation.

Whiteboard: [regression 60.5.1 -> 60.5.2]

Comment 25

2 months ago

I "repaired" my "sick" laptop by uninstalling the Dell-pre-installed version of M$ Office. Result: "Sent to > Mail recipient" started working immediately, sending from LibreOffice also works.

Maybe there is an issue with the automated upgrade.

Flags: needinfo?(mikekaganski)

Comment 26

2 months ago

Uninstalled the 60.5.2 I got from autoupdate,
installed 60.5.2 64bit from msi, reboot, twice,
Explorer - Send To - Mail recipient works

Beware: use file with plain ascii name for checking,
files with diacritics etc. will fail now

Comment 27

2 months ago

Right, I filed bug 1531724 for that. Strangely enough that worked before when the characters in the filename were on the code page of the Windows system locale. Somehow that must have gotten broken. It still works if you switch the system locale to UTF-8 which is a beta feature in Window 10 1803.

Comment 28

2 months ago

I think this here is the same as bug 1531328

Because, if the calling app sends a recpient, mail was sent, if no recipient was set, nothing did happen (i.e. no composer window shown)

Comment 29

2 months ago

(In reply to Matt from comment #2)

When sending a file the following is shown in the error console

NS_ERROR_NOT_AVAILABLE: Cannot call openModalWindow on a hidden window nsPrompter.js:340

I have the same problem and exactly the same message in the error console.

Windows 10, right clicking on a file on the desktop, choosing option "Send to > Email".
If Thunderbird is running and minimized then nothing happens (besides the message in dev tools console).
If Thunderbird is not running then the main windows shows up, but the expected dialog for composing a new email with the selected file attached does not.

Comment 30

2 months ago

OK, I think we're coming to then end of the tunnel here.

As various reports confirm, installing 60.5.2 from one of
https://www.thunderbird.net/en-US/thunderbird/all/
http://ftp.mozilla.org/pub/thunderbird/releases/60.5.2/win32/
http://ftp.mozilla.org/pub/thunderbird/releases/60.5.2/win64/
fixes the problem.

Sadly there is an additional problem that files with non-ASCII names can't be sent, see bug 1531724. There are two workarounds for that:

  1. On Windows 10, set the system code page (under system locale) to UTF-8, which is a beta feature.
    or
  2. Reset HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird - SupportUTF8 to 0.

We will ship a fix for bug 1531724, but I don't think we will action this bug here.

Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME

Updated

2 months ago
Duplicate of this bug: 1531727

Updated

2 months ago
Duplicate of this bug: 1531700

Updated

2 months ago
Duplicate of this bug: 1531678

Updated

2 months ago
Duplicate of this bug: 1531676

Updated

2 months ago
Duplicate of this bug: 1531519

Updated

2 months ago
Duplicate of this bug: 1531514

Updated

2 months ago
Duplicate of this bug: 1531506

Updated

2 months ago
Duplicate of this bug: 1531482

Updated

2 months ago
Duplicate of this bug: 1531465

Updated

2 months ago
Duplicate of this bug: 1531452

Updated

2 months ago
Duplicate of this bug: 1531415

Updated

2 months ago
Duplicate of this bug: 1531352

Updated

2 months ago
Duplicate of this bug: 1531328

Updated

2 months ago
Duplicate of this bug: 1531325

Updated

2 months ago
Duplicate of this bug: 1531324

Updated

2 months ago
Duplicate of this bug: 1531319

Updated

2 months ago
Duplicate of this bug: 1531284

Updated

2 months ago
Duplicate of this bug: 1531262

Updated

2 months ago
Duplicate of this bug: 1531195

Updated

2 months ago
Duplicate of this bug: 1531190

Updated

2 months ago
Duplicate of this bug: 1531023

Updated

2 months ago
Duplicate of this bug: 1531017

Updated

2 months ago
Duplicate of this bug: 1530964

Updated

2 months ago
Duplicate of this bug: 1530744

Comment 55

2 months ago

Looks like we have a few complaints here.

After following the steps from comment #30, does anyone still have the problem that the MAPI_DIALOG flag is ignored?

Sending mail from LibreOffice and the via Windows "Send to > Mail recipient" brings up the Thunderbird compose window for me.

Comment 56

2 months ago

I've tried both the official 32bit version and the unofficial 64bit version on Windows 10 64bit and they both work as expected.

Comment 57

2 months ago

If you don't want to mess with the Windows registry, paste this into a .reg file and merge it:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird]
"SupportUTF8"=dword:00000000

Comment 58

2 months ago

I downloaded and installed the 64 bit TB from the link in comment 30. Everything is again working as expected.

Thanks So Much!!

Comment 59

2 months ago

OK, meanwhile I found the cause of the problem. I installed 60.5.1 and let it update to 60.5.2. Result: The relevant MAPI DLLs were not updated :-( - I filed bug 1531869 for that.

Comment 60

2 months ago

Will there be a release 60.5.3 to fix this? Or do we have to redownload and install 60.5.2?

Comment 61

2 months ago

As detailed in comment #59, the autoupdate is broken. Since I just discovered that, we have no ETA. Your best bet is to follow comment #30 which is a sure fix.

Comment 62

2 months ago

followed Comment #30...still doesn't work.
Send to mail recipient still opens thunderbird, but not attachment or new email opens.

Gary

Comment 63

2 months ago

(In reply to Jorg K (GMT+1) from comment #61)

As detailed in comment #59, the autoupdate is broken. Since I just discovered that, we have no ETA. Your best bet is to follow comment #30 which is a sure fix.

this fix didn't do anything for me...restarted after...same issue.

Comment 64

2 months ago

Downloaded from directory listed..reinstalled and now working.
Thanks for help.

Comment 65

2 months ago

Downloaded per instructions in Comment #30, 32-bt is working again. Fixed.

Comment 66

2 months ago

Can anyone confirm the Comment 30 fix does work on Windows 7 Pro 64bits while installing 32bits version of TB?

Once the .dll issue would be fixed, would the ASCII/UTF8 issue affect such platform?

Updated

2 months ago
Duplicate of this bug: 1532029

Updated

2 months ago
Duplicate of this bug: 1531260

Updated

2 months ago
Duplicate of this bug: 1531937

Updated

2 months ago
Duplicate of this bug: 1531843

Updated

2 months ago
Duplicate of this bug: 1531807

Updated

2 months ago
Duplicate of this bug: 1531570

Updated

2 months ago
Duplicate of this bug: 1531857

Comment 74

2 months ago

Is there anyone else this has actually worked for? I have gone through the procedure several times today with out success. Before I start recommending the workaround to affected users I would like to think there was a high likely hood of success.

Comment 75

2 months ago

Yes, Matt, many people have confirmed this to be working, for example see comment #58, comment #64 and comment #65. Also comments in the 32(!) duplicated to all of which I am subscribed (sadly) and on SUMO. I have updated the release notes accordingly: https://www.thunderbird.net/en-US/thunderbird/60.5.2/releasenotes/

My analysis clearly showed that the automatic update failed to update the relevant DLLs.

That said, you setup might have a different problem. If you have Office installed, it might not work for you. My laptop only started working after uninstalling Office. Somehow the Office installation had corrupted the facility to send e-mail via MAPI. On Windows 10 I saw a bazillion fixmapi and mmgaserver processes eventually exhausting the machine's memory and bringing it to a halt. But that experience is not representative.

Comment 76

2 months ago

Downloading and installing from comment 30 worked for me on multiple Win7 computers. Thank you.

Comment 77

2 months ago

(In reply to Richard Leger from comment #66)

Can anyone confirm the Comment 30 fix does work on Windows 7 Pro 64bits while installing 32bits version of TB?

Once the .dll issue would be fixed, would the ASCII/UTF8 issue affect such platform?

I'm running 64-bit Win 7 Pro and 32-bit Thunderbird. I downloaded and installed from comment 30 and the problem is fixed.

Comment 78

2 months ago

(In reply to Matt from comment #74)

Is there anyone else this has actually worked for? I have gone through the procedure several times today with out success. Before I start recommending the workaround to affected users I would like to think there was a high likely hood of success.

Can you confirm:

  • Windows version: 7,8,10? 32bits or 64bits? Version?
  • Office version (if installed): 2010,2013,2016,2019? 32bits or 64bits?
  • Which installer (full link address path) you tried?
  • Have you rebooted after uninstall?
  • Have you rebooted after install?
  • Is Thunderbird still set to be the default email client on the machine?

Comment 79

2 months ago

(In reply to qkeon from comment #77)

(In reply to Richard Leger from comment #66)

Can anyone confirm the Comment 30 fix does work on Windows 7 Pro 64bits while installing 32bits version of TB?

Once the .dll issue would be fixed, would the ASCII/UTF8 issue affect such platform?

I'm running 64-bit Win 7 Pro and 32-bit Thunderbird. I downloaded and installed from comment 30 and the problem is fixed.

Would you be able to confirm the link address (full path) to the installer you used?

Comment 80

2 months ago

(In reply to Richard Leger from comment #79)

(In reply to qkeon from comment #77)

(In reply to Richard Leger from comment #66)

Can anyone confirm the Comment 30 fix does work on Windows 7 Pro 64bits while installing 32bits version of TB?

Once the .dll issue would be fixed, would the ASCII/UTF8 issue affect such platform?

I'm running 64-bit Win 7 Pro and 32-bit Thunderbird. I downloaded and installed from comment 30 and the problem is fixed.

Would you be able to confirm the link address (full path) to the installer you used?

Windows 7 Pro 64-bit
Downloaded Thunderbird 32-bit installer from http://ftp.mozilla.org/pub/thunderbird/releases/60.5.2/win32/en-US/
Installed update - opened TB - Closed TB - Opened again and tried attachment from send to, mail recipient - worked.
All PCs have Office 2010 Standard 64-bit.
One PC required a reboot after installation per message on screen.
TB is the default mail client.

Comment 81

2 months ago

I can confirm that fix from comment 30 works on 32 bit TB on 64 bit Windows 7 and 10. With or without Office 365 installed.

Updated

2 months ago
Duplicate of this bug: 1532111

Updated

2 months ago
Duplicate of this bug: 1532044

Comment 84

2 months ago

I installed 60.5.2 32 bits from /pub/thunderbird/releases/60.5.2/win32/es-AR/ and the problem is "almost" solved.
Now if I send a mail from another application using MAPI with MAPI_DIALOG flag, the compose window appears. But, it's not modal. The call returns immediately.

I have Windows 10 Pro.

Comment 85

2 months ago

Sure, that always been the case. Are you confusing "modal" (blocking) with synchronous/asynchronous? As I understand the COM interface between the external application and Thunderbird is synchronous, see related bug 1527450 comment #9 (quote):

The COM calls are synchronous: they end when e.g. CMapiImp::SendMailW returns (the return value is passed back to the caller).

However, TB's CMapiImp::SendMailW returns when the compose windows has been launched. Whether the user in the end sends the e-mail or not, is a different question.

All we did in 60.5.2 was to rearrange the COM interface between MAPI DLL and TB process a bit. No behaviour change at all. What caught us was the fact that the installer didn't install the new MAPI DLLs, so the old DLLs were talking to the new interface in TB with detrimental effects. See bug 1531869 for details.

Comment 86

2 months ago

(In reply to EGMM from comment #84)

Bug 865689 gives a hint that it was already working like that at least for the last 6 years. TB has never honored MAPI_DIALOG_MODELESS; and its handling of MAPI_DIALOG was changed to modeless rather long ago. Ergo: comment 84 mentions another bug.

Comment 87

2 months ago

You are right. What I am trying to say is explained in bug 865689.

'Write' window should have opened as a modal dialog; execution of calling routine should wait for closing of modal dialog. MapiSendMail function with MAPI_DIALOG flag should not return a result until user closes 'Write' window by either sending mail (Result=SUCCESS_SUCCESS) or closing without sending (Result=MAPI_E_USER_ABORT).

When I send a mail from another application, usually the compose window appears, I edit the text (or not), send the mail and then I see again the original application. As this used to work fine, I didn´t notice the application didn´t expect the mail to be sent. Now, that version 60.5.2 have this new bug (resolved with reinstallation) I noticed the bug 865689. I think it would be a good idea to solve it, so Thunderbird would worked as other e-mail clients.

Updated

2 months ago
Duplicate of this bug: 1531907

Updated

2 months ago
Summary: MAPI no longer working after update to 60.5.2 this morning. Sending PDF as email attachment from Nitro PDF reader no longer works, nor does right clicking on file and selecting "send to: Mail Recipient". → MAPI not working after automatic update to 60.5.2: Sending from external progam no longer works, nor does "Send to > Mail Recipient" - Solution in comment #30

Comment 89

2 months ago

(In reply to EGMM from comment #87)

When I send a mail from another application, usually the compose window appears, I edit the text (or not), send the mail and then I see again the original application. As this used to work fine, I didn´t notice the application didn´t expect the mail to be sent. Now, that version 60.5.2 have this new bug (resolved with reinstallation) I noticed the bug 865689. I think it would be a good idea to solve it, so Thunderbird would worked as other e-mail clients.

i agree, we dot have this issue with brother control center, after scanning a document "to email" it usually open the thunderbird compose windows and after 60.5.2 (even full install) this does not work.

Comment 90

2 months ago

Any accented characters at play? Vous êtes français ;-) Did you read comment #30 fully? Most/all people are OK after reinstalling.

Comment 91

2 months ago

Now I have seen, that wehn I will attach a link ("Sent to > Mail recipient"), the email opens. If I try the same link again ("Sent to > Mail recipient"), no email appears. I have no (more) problem with files.

Comment 92

2 months ago

(In reply to Christian Moling from comment #91)

Now I have seen, that wehn I will attach a link ("Sent to > Mail recipient"), the email opens. If I try the same link again ("Sent to > Mail recipient"), no email appears. I have no (more) problem with files.

I can attach every link only for one time.

Comment 93

2 months ago

Is there any hope for a fix via update ?
I have tens of PCs to deal with (in several small companies) + I'm in France so I would have to apply the 2 steps manual fix ...

Comment 94

2 months ago

We'll ship a fix within a week hopefully.

Comment 95

2 months ago

It works properly now after reinstalling 60.5.2 (comment #30)
Thank you for all comments and tha,ks to you Jorg K (comment #90) ... and yes I'm french ;-)

Comment 96

2 months ago

After Reinstall Works in 90%. System Windows 7 X64 gives pop up that i need to change defaults mail program in system settings.. but when i change it to default its do nothing.. and i have the same pop up always i use other programs mail function.

Updated

2 months ago
See Also: → 1531869

Updated

2 months ago
Duplicate of this bug: 1532215

Comment 98

2 months ago

I reinstall thw 60.5.2 32x in win 10 laptop hp omen but the problem remain. The "Sent to > Mail recipient" open the TB but no email with attachment appears.

Comment 99

2 months ago

Yes, because you're in Greece and the file had Greek characters in the name and you didn't apply the registry fix from comment #30?

Comment 100

2 months ago

Thanks, i Reset the HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird - SupportUTF8 to 0 and it seems to be ok now.

Comment 101

2 months ago

Notice to all the people affected by this bug: TB 60.5.3 is on the way. If you want to try it:
https://archive.mozilla.org/pub/thunderbird/candidates/60.5.3-candidates/build1/win32/
https://archive.mozilla.org/pub/thunderbird/candidates/60.5.3-candidates/build1/win64/ (unofficial 64bit).

Comment 102

2 months ago

May be better to wait for auto-update to 60.5.3 and see if it fix the issue(s), no? Just a suggestion, as it is an issue linked to the auto-update of TB, not really with the installer itself...

Updated

2 months ago
Duplicate of this bug: 1532715

Comment 104

2 months ago

I can confirm this problem also happens with POP3 since updating to TB 60.5.2 I just filed Bug #1532715 about it, after posting a comment in Bug #1339554 but unfortunately before seeing THIS bug report. (Jorg, I see you just caught that...)

FYI: TB 65.0.2 on Windows 7 Pro 32-bit - two DELL PC machines.

Comment 105

2 months ago

FYI: TB 60.5.2 on Windows 7 Pro 32-bit - two DELL PC machines.

Comment 106

2 months ago

Reloaded Version 60.5.3 from this site https://archive.mozilla.org/pub/thunderbird/candidates/60.5.3-candidates/build1/win64/ and it now works perfectly sending direct to email from an HP Color Laserjet

Comment 107

2 months ago

Yes, I can confirm, it works perfect again. (Win7 64bit, TB 60.5.3) delivered via automatic update within TB.
Many thanks to everyone!

Updated

2 months ago
Duplicate of this bug: 1532686

Comment 109

2 months ago

After downgrade TB from 60.5.2 -> 60.5.1 and then upgrade it to 60.5.3 from https://www.thunderbird.net/en-US/thunderbird/all/ [downloaded full installer, rebooted before and after upgrade, and after changed into registry] we (in our company) cannot send mails via windows 'send to -> mail recipient' when the attached filename contains our (Polish) national characters - "ś, ć, ę, ł, ó, ż, ź", Windows [Win7 Pro 64bit pl-PL; TB is 32bit] is set for Windows 1250 Code Page. When i rename the file, then i can send it as usual. Changing registry value 'SupportUTF8' to 0 is not working in my environment. Now even downgrade to TB 60.5.1 is not resolving this. Somebody has an some idea ? I have ~100 PC- affected with this :(

Comment 110

2 months ago

(In reply to Robert from comment #109)

That's strange.
Could you - just in case - check both HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird and HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Clients\Mail\Mozilla Thunderbird for SupportUTF8 value? (note the WOW6432Node in the second registry path.)

Comment 111

2 months ago

Actually, no. With the Western European code page windows-1252 I can send with äöü, and I'm sure Mike can send Cyrillic, right?

I'm very well aware of your Polish national characters, since I fixed bug 1505315.

Comment 112

2 months ago

Actually, comment #111 was an answer to comment #109:

Somebody has some idea? ... Actually, no. Sadly.

Comment 113

2 months ago

(In reply to Mike Kaganski from comment #110)

Thank you.

I totally forgot about existing of Wow6432Node tree. There was 'SupportUTF8' set to 1.
I'm made changes only for this one registry tree HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird.

Maybe (comment #30) should be updated for people like me, who forgot about Wow6432Node :)

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Clients\Mail\Mozilla Thunderbird]
"SupportUTF8"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird]
"SupportUTF8"=dword:00000000

Comment 114

2 months ago

(In reply to Robert from comment #113)

Hmm... actually I hoped that my advice would not work.
As it works, I now don't understand why would installer for 32-bit TB 60.5.3 not set the registry value itself under Wow6432Node, where 32-bit applications are expected to store their configuration? (I'd rather expect that 64-bit registry hive be not updated...) Or do we not ship the registry fix with 60.5.3?

Comment 115

2 months ago

(In reply to Robert from comment #109)

After downgrade TB from 60.5.2 -> 60.5.1 and then upgrade it to 60.5.3 from https://www.thunderbird.net/en-US/thunderbird/all/ [downloaded full installer, rebooted before and after upgrade, and after changed into registry] we (in our company) cannot send mails via windows 'send to -> mail recipient' when the attached filename contains our (Polish) national characters - "ś, ć, ę, ł, ó, ż, ź", Windows [Win7 Pro 64bit pl-PL; TB is 32bit] is set for Windows 1250 Code Page. When i rename the file, then i can send it as usual. Changing registry value 'SupportUTF8' to 0 is not working in my environment. Now even downgrade to TB 60.5.1 is not resolving this. Somebody has an some idea ? I have ~100 PC- affected with this :(

I would suggest the following...

Eventually there is a Polish language version of TB available, not that it should make any difference in theory :-)

Comment 117

2 months ago

Or http://ftp.mozilla.org/pub/thunderbird/releases/60.5.3/win32 if you wish to install 32bits version, obviously...

Comment 118

2 months ago

Source: https://www.advancedinstaller.com/user-guide/registry-wow6432-node.html

"...

Wow6432Node Registry Key

The Wow6432Node registry entry indicates that you are running a 64-bit Windows version.

The operating system uses this key to display a separate view of HKEY_LOCAL_MACHINE\SOFTWARE for 32-bit applications that run on 64-bit Windows versions. When a 32-bit application writes or reads a value under the HKEY_LOCAL_MACHINE\SOFTWARE\<company>\<product> subkey, the application reads from the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\<company>\<product> subkey.

A registry reflector copies certain values between the 32-bit and 64-bit registry views (mainly for COM registration) and resolves any conflicts using a "last-writer-wins" approach.

..."

See also https://docs.microsoft.com/en-us/windows/desktop/sysinfo/32-bit-and-64-bit-application-data-in-the-registry

Comment 119

2 months ago

(In reply to Jorg K (GMT+1) from comment #116)

Let me think aloud.
TB prior to 60.5.2 didn't set that registry value (neither in 64-bit hive, nor in 32-bit; neither 64-bit TB, nor 32-bit one).
TB 60.5.2 wrote that value - to which hive? That must be clear to someone familiar with NSIS and TB installation technology; but anyway, that must be built into the NSUS installer executable (I suppose), and so the change in bug 1521007, possibly combined with installer architecture, would fully define the registry places affected.
TB 60.5.3 has a change that is different values written into the same registry places, in the same NSIS script sites. So logically, that must ensure, that running a TB 60.5.3 installer of the same architecture over TB 60.5.2 installation should in theory write precisely to same registry places? and - I guess - for 32-bit installer, at least 32-bit registry should have been affected?

I am confused.

Comment 121

2 months ago

(In reply to Mike Kaganski from comment #119)

When i'\ try to figure it out, I'm delete whole registry path for 64-bit apps (HKLM\Software\Cilent\Mozilla.... Uninstall TB 60.5.2 completely, re-install 60.5.0, 60.5.1, 60.5.2, 60.5.3 and 66.0b2 (for tests), and this registry path was rebuild automatically after install of TB was finished. I was thinking i made changes into property registry path.

Comment 122

2 months ago

Well, looks like
https://hg.mozilla.org/releases/comm-esr60/rev/8626d03f14b3cc7b43a656f174c18cb984db3e88#l1.13
does not run for an automatic upgrade install :-( - Sigh.

Comment 123

2 months ago

(In reply to Robert from comment #121)

That was strange for me is, when TB starts is always ask for "default email client in Windows", when i agree with this (after enter admin credentials), restart TB, and it ask again and again for that.

Comment 124

2 months ago

Looks like TB 60.5.3 is now available on the public release channel. I updated both of my machines just now using the standard HELP/ABOUT update buttons in TB and I can confirm that the SEND-TO process works again as it should (that is, as it used to do) -- at least for POP3 on Windows 7 32-bit. Thanks, guys.

BTW, I think the resolution should be changed to "FIXED" (no longer "WFM"), since this seems to be an official public fix and not a workaround hack.

Comment 125

2 months ago

Well, the fix happened in two other bugs: Bug 1531724 and bug 1531869, and the former is still awaiting a follow-up to fix the issue discussed in comment #109 and below.

Comment 126

2 months ago

(In reply to Jorg K (GMT+1) from comment #122)

Well, looks like
https://hg.mozilla.org/releases/comm-esr60/rev/8626d03f14b3cc7b43a656f174c18cb984db3e88#l1.13
does not run for an automatic upgrade install :-( - Sigh.

That was wrong. Mozilla's Windows installer specialist looked at it and he pointed out what could have happened for the 1 to remain in Wow6432Node, see bug 1531724 comment #23 and below. Unless we have further insight into what happened at the Polish site from comment #109, we won't be able to action this any further.

Comment 127

2 months ago

May not be directly linked to this bug but worth mentioning I think...

Source: Bug 1531190 Comment 7 (which has been marked as duplicate of this bug)

"...

Created attachment 9047671 [details]
AnotehrAppicationisAttemptingToSendMail.png

I can confirm as well that on Windows 10 Pro 64bits [Version 10.0.17134.590] with TB 66.0b2 (32-bit) the mail recipient feature does not work as expected and simply crash the application.

While TB up and running, opened File Explorer, right click a .pdf file, selected Sent to > Mail Recipient, the attached warning appeared ("Another application is attempting to send mail using your user profile..."), clicked OK, TB application is Not Responding for a while and then crash (close by itself) without any crash reports generated.

..."

Updated

2 months ago
Duplicate of this bug: 1532928

Comment 129

2 months ago

(In reply to Jorg K (GMT+1) from comment #126)

What i've done:

Then TB 60.5.2 was published, it was downloaded Polish, 32bit version of TB from https://www.thunderbird.net/en-US/thunderbird/all/

All my machines have 60.5.1 32bit pl-PL installed on Win7/8.1/10 all is Pro and x64;

deploy this update to my users silently via psexec - e.g. "ThunderbirdInstaller.exe -ms";

On some computers TB was opened [not closed by they users] while upgrade process was started from fullinstaller.

When needed, client computers was rebooted.

next day morning i have meny phone calls, user cannot send via send to, or from Acrobat Reader DC, etc.

I start to search internet for bug info.

O one computer making downgrade to 60.5.1, and it work again.
Manually i upgrade using full installer to 60.5.2. Send to - works.

On other machines i'll try TB 66.0.b2 - send to - work.

I only test one example file, without non-ASCII chars.

Because TB 66.0b2 is not support for Enigmail, i downgraded it to 60.5.2.

Few user give me a notice that cannot send only few files - files contains with non-ASCII characters in filename.

I found registry info (comment #30) that in theory resolve my problem.
i'm add this via psexec.exe:
"reg add "HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird" /v "SupportUTF8" /t REG_DWORD /d 0 /f"

but this not resolve my problems. I totally forgot about creating Wow6432Node... I use for it 64bit cmd.exe ["%windir%\Sysnative\cmd.exe"] and 64bit of psexec.exe.

I was think, i make downgrade to 60.5.1 to all users via psexec. But this is not work to...

Then 60.5.3 was published, i deploy TB 60.5.3 in the same way. This is not resolve my issue to.

Then on test machines, i uninstall completely TB, rebooted, delet from program files Thunderbird folder and contains files, install fresh copy, but with no luck - files with non-ASCII chars in filename wont to send as before.

Do it few times, no luck. I even install for tests an old TB 52.9.1 (32bit), but with the same results - files with non-ASCII chars in filename wont to send.

That's is work for me is to deploy via psexec to all users:
"reg add "HKLM\SOFTWARE\Wow6432Node\Clients\Mail\Mozilla Thunderbird" /v "SupportUTF8" /t REG_DWORD /d 0 /f"

I see, but only once - when i'll try to send mail a littile window - that is "other program wants to send mail by using your profile".

Comment 130

2 months ago

(In reply to Robert from comment #129)

When i try to install a fresh copy of TB, i delete whole registry tree (64bit) HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird

When i install 32bit of TB, this tree was rebuild automatically - then i was thinking that i manipulate on right registry tree.

Comment 131

2 months ago

(In reply to Robert from comment #130)

Downgrade to 60.5.1 stops working when add registry value of "SupportUTF8" to 64bit tree and upgrade in place from full installer e.g. 60.5.2 -> 60.5.2. But i don't known why.

Comment 132

2 months ago

(In reply to StanoS from comment #107)

Yes, I can confirm, it works perfect again. (Win7 64bit, TB 60.5.3) delivered via automatic update within TB.
Many thanks to everyone!

It isn't true at all... It doesn't work for filenames with special characters... For example names with á,č,ť,ž etc...

Comment 133

2 months ago

(In reply to StanoS from comment #132)

You can try this from (comment #30) but add Wow6432Node to if you use 32bit of TB on 64bit of Windows.

copy and past this to notepad, save as *.reg file, double clik on it and add to registry.

after that, you should be able to send files with names contains non-ASCII characters.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Clients\Mail\Mozilla Thunderbird]
"SupportUTF8"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird]
"SupportUTF8"=dword:00000000

or you use command line as well (start it as administrator)

32bit TB on 64bit Windows:
reg add "HKLM\SOFTWARE\Wow6432Node\Clients\Mail\Mozilla Thunderbird" /v "SupportUTF8" /t REG_DWORD /d 0 /f

Win & TB is 32bit / Win & TB is 64bit.
reg add "HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird" /v "SupportUTF8" /t REG_DWORD /d 0 /f

Comment 134

2 months ago

OK, let's clarify a few things here:

The registry setting of "SupportUTF8 1" will break non-ASCII names for any version of Thunderbird.

The installer of 60.5.3 or the automatic update to 60.5.3 will reset the registry settings in HKLM\SOFTWARE\Wow6432Node\Clients\Mail\Mozilla Thunderbird and HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird if deployed in the "regular" fashion. If you deploy the installer in a "non-standard" way, it might not be able to write to the registry, see bug 1531724 comment #25.

Comment 135

2 months ago

psexec I'm running with args "-s -e -i" - this is force to using a built-in System account on remote machine to do the job. I think Installer have full access (with write) to this location %ProgramFiles%, %ProgramFiles(x86)%, %ProgramW6432% and HKLM\Software registry hive.
Tomorrow I'll try to do some tests on VM with clean Win7 on them and install/update TB via psexec with and without -s arg.

Comment 136

2 months ago

Further to my Comment 124:

Looks like TB 60.5.3 is now available on the public release channel. I updated both of my machines just now using the standard HELP/ABOUT update buttons in TB and I can confirm that the SEND-TO process works again as it should (that is, as it used to do) -- at least for POP3 on Windows 7 32-bit.

Given the discussions since then, I tested just now on a file copied to a non-ASCII-named file -- the original works as usual, the non-ASCII name fails to trigger anything (SEND-TO does nothing apparent).

So I can confirm only that, after the update to 60.5.3 on the Public Release channel, the SEND-TO process works again as it should (that is, as it used to do) ONLY FOR "NORMAL" ASCII FILE NAMES for POP3 on Windows 7 32-bit.

Comment 137

2 months ago

Which non-ASCII file names work and which ones don't depends on the Windows code page (ACP) used by your system. For example, using "Western European", that is windows-1252, I can send äöü, etc. but not any Polish characters as show in comment #109. For that to work, the machine needs to use windows-1250. If you want to send any file name, including Greek, Hebrew, Thai, Cyrillic, Japanese, Korean, Chinese, etc. you need to set your system code page to UTF-8 which is a beta feature on Windows 10.

If you claim something doesn't work, state your code page and the file name you used.

Comment 138

2 months ago

It could be that for it to work with non-ascii characters, the MAPISendMailW function (UTF8) (In reply to Richard Leger from comment #127)

Source: Bug 1531190 Comment 7 (which has been marked as duplicate of this bug)

"...

Created attachment 9047671 [details]
AnotehrAppicationisAttemptingToSendMail.png

I can confirm as well that on Windows 10 Pro 64bits [Version 10.0.17134.590] with TB 66.0b2 (32-bit) the mail recipient feature does not work as expected and simply crash the application.

While TB up and running, opened File Explorer, right click a .pdf file, selected Sent to > Mail Recipient, the attached warning appeared ("Another application is attempting to send mail using your user profile..."), clicked OK, TB application is Not Responding for a while and then crash (close by itself) without any crash reports generated.

..."

This issue was raised in a separate bug 1524762 already...

Comment 139

2 months ago

(In reply to Jorg K (GMT+1) from comment #137)

Which non-ASCII file names work and which ones don't depends on the Windows code page (ACP) used by your system. For example, using "Western European", that is windows-1252, I can send äöü, etc. but not any Polish characters as show in comment #109. For that to work, the machine needs to use windows-1250. If you want to send any file name, including Greek, Hebrew, Thai, Cyrillic, Japanese, Korean, Chinese, etc. you need to set your system code page to UTF-8 which is a beta feature on Windows 10.

If you claim something doesn't work, state your code page and the file name you used.

Jork, would the MAPISendMailW implementation (not yet shipped) you mentioned in Comment 3, help overcome this issue, or would it still require UTF8 system code page to actually be used once shipped?

Comment 140

2 months ago

MAPISendMailW was in TB 66 beta 1, I withdrew it in TB 66 beta 2 due to crashes (bug 1527450), but it's again being shipped with TB 66 beta 3 now that we corrected the installer which may have been the course of the crashes.

Once shipped, TB will offer both MAPISendMail and MAPISendMailW and it's up to the external application to chose which one to use. We know from testing that "Send to > Mail recipient" uses MAPISendMailW, as does LibreOffice. MS Word 16 uses MAPISendMail unconditionally and also transmits UTF-8 data via that interface, hence bug 1521007 where we started advertising UFT-8 support with detrimental effects and had to withdraw it again.

So yes, once MAPISendMailW has been shipped and doesn't crash, it will solve all "Send to > Mail recipient" issues.

Updated

a month ago
Duplicate of this bug: 1530819

Comment 142

a month ago

(In reply to Robert from comment #135)

I'm made some test on Win7 Pro x86/x64.

silently upgrade TB 32bit (using installer exec with -ms args) from version 60.5.0, 60.5.1 and 60.5.2 to latest 60.5.3 do changes in both registry hive HKLM\Software\Client... and HKLM\Software\Wow6432Node\ SupportUTF8 is set too 0.

Test is from command line opened as administrator and via PSEXEC with -s arg (using system account to do the job) and without -s arguments (using selected account from admin's group).

But i see strange thing.

installer always exit with exit code 0 (suppose the operation is completed successfully), add/remove programs list is updated - shows TB in current version (60.5.3), install/update date is changed - i see today date), but some users when starting form desktop, taskbar, menu start, quick launch icon is prompted for admins credentials. when i decline this, and go to help / about TB - i see current version number and active button "restart to update". But i don't known why. I see this until i enter the credentials of admin account.

Second thing that i see now is when i try to send mails with attached files with names accented with Polish characters, i cant send them.

When i downgrade to 60.5.1, i can send them, but i see regression like in: bug 1505315 - when i'll try to attach a file named "ąśćżźłóńĄŻŹĆŚĘŃÓŁ.txt" i get: email title: "WysyĹ‚anie wiadomoĹ›ci e-mail: ąśćżźłóńĄŻŹĆŚĘŃÓŁ.txt" and the body contains "Wiadomość jest gotowa do wysĹ‚ania wraz z nastÄ™pujÄ…cymi zaĹ‚Ä…cznikami (plikami lub Ĺ‚Ä…czami):
ąśćżźłóńĄŻŹĆŚĘŃÓŁ.txt", i should get: "Wysyłanie wiadomości e-mail: ąśćżźłóńĄŻŹĆŚĘŃÓŁ.txt" and body: "Wiadomość jest gotowa do wysłania wraz z następującymi załącznikami (plikami lub łączami): ąśćżźłóńĄŻŹĆŚĘŃÓŁ.txt"

What i do wrong ? or what i f***** on my machines when i'll try to do tests ?!?

My system code page is Windows 1250 (Central Europe)

both registry hive have SupportUTF8 set to 0, and TB i 60.5.3, i restart whole machines used for tests. I have no idea why previously the Wow6432Node hive tree was not updated to 0.

I'll try tonight to completely remove TB from test machines and install a fresh copy, and see whats happens.

Best regards to all, thanks for your time and attention.

Updated

a month ago
Duplicate of this bug: 1534916

Updated

a month ago
Duplicate of this bug: 1535618

Comment 145

a month ago

TB 60.5.2/60.5.3, Windows 7 with latest updates.
Send To -> Mail recipient not working for filenames with Cyrillic characters.
Setting HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird\SupportUTF8 to 0 or 1 has no effect.
But interesting thing, deleting DWORD HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird\SupportUTF8 completely fixes the problem.

For now, pushing GPO to apply at once:
reg delete "HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird" /v "SupportUTF8" /f

Comment 146

a month ago

(In reply to Robert from comment #142)

Test on: Oracle VBox 6.x, Win 7 x64 pl-PL (from official Dell DVD).

Clean Install of Win7, download TB 60.5.1 up to 60.6.0, send to is not working - TB opens, but no windows new message is shown.

I'll test both x86 and x64 version of Thunderbird.

I see in comment #145, alxdlv delete SupportUTF8, i try this and i see whats happen :)

Comment 147

a month ago

(In reply to alxdlv from comment #145)

For now, pushing GPO to apply at once:
reg delete "HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird" /v "SupportUTF8" /f

That's right. Test on 60.6.0 (32 bit). In my environment deleting this key (and if exist in Wow6432Node, i delete it too) and the new message window apper again. Thank you :)

I'm going to make an GPO rule for that :) This is exactly what i need.

Comment 148

a month ago

So "no key" and "value is 0" are different, how strange is that??

Comment 149

a month ago

(In reply to Jorg K (GMT+1) from comment #148)

well - that's really unexpected; still I suppose that it'd be better if TB erased that key instead of nullifying it as I did. I did that because of lack of knowledge in the installer technology used, sorry for that; I knew that we should not let it stay 1 - which is correct anyway. If you know how to (and actually do) change that to removal, it would be great.

Comment 150

a month ago

In reply to Jorg's Comment 148:

In generic programming/logic terms, you can explicitly set a value to zero ("value is zero") by reading a zero, but if the record is missing ("no key"), the code could set any default -- not limited to zero -- and do this deliberately or otherwise.

Deliberately set default if the record is missing...
IF RECORD : Read value
IF NOT RECORD : Nothing was read, so set value = <whatever>
Value is as read OR as deliberately set (which could be deliberately but explicitly non-zero)

Inadvertently set default to incorrect value (bug?)...
Set value = <whatever>
<perhaps do other stuff that doesn't change value>
IF RECORD : Read value
IF NOT RECORD : <do nothing>
Value is as read OR as previously set (which could be arbitrary)

For either case, <whatever> could be zero, or one, or anything (valid or otherwise).

For the inadvertent case, in a bug scenario, value could be arbitrary, which makes the bug harder to find -- the value might accidentally be correct this time and wrong the next, leading to intermittent working and not-working situations.

Duplicate of this bug: 1536761

Comment 152

4 days ago

(In reply to Mike Kaganski from comment #149)

well - that's really unexpected; still I suppose that it'd be better if TB erased
that key instead of nullifying it as I did. I did that because of lack of knowledge
in the installer technology used, sorry for that; I knew that we should not let it stay 1 -
which is correct anyway. If you know how to (and actually do) change that to removal, it would be great.

Filed bug 1545362 for it.

Comment 153

4 days ago

After aabout month of removing this value from registry (witch resolve issue in my environment on more then 200 PC's) i have 2 machines witch Windows 7 is installed from genuine (factory) image/partition recovery from HP/Lenovo/Dell/FSC, etc. - witch we select the OS language at start of installation - removing this value dont resolve this issue. Send to -> mail recipient does nothing, TB opens, but no window with new message do not appear. On one machine (only for test) i reinstall Win7 but from genuine Microsoft DVD with pl-PL and it works.
I'm wondering whats can be on the second one. What i can check...

We're working on bug 1545362 and the registry value will be removed when TB 60.7 ships in May 2019.

You need to log in before you can comment on or make changes to this bug.