Closed Bug 1544212 Opened 3 years ago Closed 3 years ago

Using In-Content Dark theme, many about:addons addons texts are unreadable.

Categories

(Toolkit :: Themes, defect, P3)

68 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: sephir, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files, 2 obsolete files)

Attached image https_darkmode.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

I enabled browser.in-content.dark-mode.
I went on an installed addon page, using about:addon.

Actual results:

Texts of several addons where too dark to be read.
Texts of several addons where readable but still too dark.

Expected results:

I would expect texts to be readable and have a better contrast when they are.

Component: Untriaged → Theme
Component: Theme → Themes
Priority: -- → P3
Product: Firefox → Toolkit
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → ntim.bugs

I have the same issue with my add-ons and I am wondering what is the plan here. After all, a white settings box inside of a black-themed about:addons is also very awkward, so can't you just provide a default text color for add-ons?
Or what is the plan here for dark-themed add-on options pages?

I've collected/opened https://discourse.mozilla.org/t/firefox-68-added-dark-version-to-about-addons-breaking-many-add-ons/38716 for a general discussion on this feature.

I mean, you could even leave it as it currently is, if you communicate that and let add-on developers some time to adjust their add-ons. But we need more information about the general roadmap…

Just heads up that this dark mode thing is Nightly only atm, and that you don’t need to take any action until it reaches release.

Yes, I know (and also said so), but at some point of time it will be in Stable, I guess, so we need to be prepared. That's why I am asking for a timeline etc.

(In reply to rugk from comment #4)

Yes, I know (and also said so), but at some point of time it will be in Stable, I guess, so we need to be prepared. That's why I am asking for a timeline etc.

As of now, there's no timeline. The dark mode will ship when it is deemed ready and when it'll get UX approval. This is literally only enabled on Nightly to get user-testing, and won't ride the trains until it's ready, see: https://searchfox.org/mozilla-central/source/browser/app/profile/firefox.js#1011-1015

Assignee: ntim.bugs → nobody

The new HTML about:addons page supports dark themes (bug 1551202).
This bug will be closed once the updated about:addons page is enabled by default (bug 1555012).

Depends on: 1555012
Duplicate of this bug: 1555186
Duplicate of this bug: 1555424

This is fixed in the HTML about:addons.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Attachment #9059871 - Attachment is obsolete: true
See Also: → 1593355

I got 75.0b1 this week and the new default theme is a complete mess. I'm not sure how black on dark grey is usable.

Attached image Untitled.png

75.0b2 that I picked up today is more usable(aka, I don't have to type my reply in notepad then paste into Thunderbird) but really distractingly ugly. When I type past the oddball color width, it increases by a single character.

Comment on attachment 9136328 [details]
Untitled.png

75.0b2

@Jason Did you mean to post on a different bug? I'm not sure how your screenshot relates to this (already fixed) bug.

Attached image Beta 85.0b2 Folder Properties.png (obsolete) —
Attachment #9195202 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.