Closed Bug 1552885 Opened 7 months ago Closed 7 months ago

Fix issues in the post-Sandstone skin including low contrast, visited links and small font size

Categories

(bugzilla.mozilla.org :: User Interface, defect, major)

Production
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: julienw, Assigned: kohei)

References

(Regression)

Details

(Keywords: access, regression)

Attachments

(2 files)

Hey,

thanks for the new interface, it looks great !

I found some contrast problems that could be a problem for accessibility, let me try to summarize these. I'm not an expert in this field but I have worked on the subject in the past.

  • the scrollbar is really not contrasted enough with 1/ the page and 2/ the scrollbar background. This is bad even for me, whereas I have no particular vision issue.
  • the quoted text is too pale compared to its background.
  • the "reporter" text next to the reporter's name in comments is not contrasted enough.

Thanks!

Assignee: ui → nobody
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production

We have a tool to check for this all at once.

Alternatively, the element picker allow checking the score for a particular element.

Duplicate of this bug: 1552899

Like I wrote in bug #1552899, I will write it here too, so it won't be omitted and forgotten.

I'm using glasses and Bugzilla in 130-150% zoomed mode with disabled modal user interface (I prefer old one),
and for me this new text font looks kinda blurry and causes me eye strain.
Looks like without sub-pixel anti-aliasing, but only gray-scale anti-aliasing (but it's not).

Any chances to reconsidering this change, please?
And use black text font color, instead of grey shades,
or at least providing option to change this.

Thank you very much in advance!

BTW - New Bugzilla look looks nice and clean. I like it. Good job!

Severity: normal → major
Keywords: access, regression
OS: Unspecified → All
Hardware: Unspecified → All
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED

I played around with the previous CSS from https://raw.githubusercontent.com/mozilla-bteam/bmo/96794c429d269d95498999e9d3d90b5c50c56b82/skins/standard/global.css.

The font was 'Fira Sans', now 'FiraGo'. The previous font had a different aspect ration, so the text was wider which no doubt made it look bigger. It was also darker. Looks like the new font is also not rendered very clearly on Windows.

FiraGO is a variant of Fira Sans, so there are no substantial differences between those two. What’s changed is the font weight: previously it was Regular and now Book, which should be readable on screen thanks to the consistent line width. By the way, did you test with the latest version of Firefox, not 60 ESR?

Looks the same (small) in Nightly.

Same font badness in chrome (beta). And not any better on desktop monitor than laptop. (I concur with the issues mentioned in bug 1552899.)
I'd also prefer to see background shading of all comments be totally removed - less eye strain

Duplicate of this bug: 1552988
Duplicate of this bug: 1552954

Once more thing: checkboxes on the modal modules (this page) look collapsed.

Summary: Some contrast problems in the new interface → Fix issues in the post-Sandstone skin including low contrast and small font size
Regressed by: bmo-jedi-theme

I've just noticed an absolutely FATAL issue: Visited links are not shown in a different colour any more. That makes bug triaging pretty much impossible. For bug triaging I get a list of recent bugs, like https://mzl.la/2Q74Pr8, and then visit the bugs I haven't looked at. I cannot possibly remember all the bugs I have already looked at, Firefox needs to tell me. So if visited links are not shown in a different colour, I'm hosed :-(

Severity: major → critical

That’s an intentional change. See Bug 1531517 and Bug 1552922 for why.

Severity: critical → major

Well, reading those bugs, I can see that some BMO professionals aren't very happy with that, see "The visited link contrast is very useful for me when I'm triaging through a long list of bugs".

Another issue: The requests box, the popup you get clicking onto the red circle with the number of requests, is too small, you can't see the requests any more.

Jorg, this bug is about contrast, please don't fork it.
If you care about the link, please comment in the bug.
If you care about the requests box, please create a new bug.

(In reply to Jorg K (GMT+2) from comment #14)

Another issue: The requests box, the popup you get clicking onto the red circle with the number of requests, is too small, you can't see the requests any more.

This bug can cover any regression but I haven't changed the font size nor font weight...

See bug 1552922 comment #10 and above to set CSS for this site to change font size and colour.

For the record, the new CSS is completely ignored in Internet Explorer 11 (the latest version on still supported Windows 7), thus it has high contrast (black text on white background), but there are no backgrounds and borders, thus no separations of comments.
Also no buttons seem to work, thus BMO is completely inoperable in the browser.

We don’t support Internet Explorer. See this wiki page for requirements.

Duplicate of this bug: 1553138

Please note that the bug suggestion table also looks like cut-off on both the left and right side.

Duplicate of this bug: 1553089

(In reply to Jorg K (GMT+2) from comment #12)

I've just noticed an absolutely FATAL issue: Visited links are not shown in a different colour any more. That makes bug triaging pretty much impossible. For bug triaging I get a list of recent bugs, like https://mzl.la/2Q74Pr8, and then visit the bugs I haven't looked at. I cannot possibly remember all the bugs I have already looked at, Firefox needs to tell me. So if visited links are not shown in a different colour, I'm hosed :-(

In particular, bug 1531517 comment #3 goes into details

  1. It’s basically broken since CSS was invented. For example, the following links are all the same page but considered as different links.
    [snip]
  2. The style will be easily reset once the browser’s history is cleared.
  3. The style could be inconsistent among multiple browsers and devices unless the user’s browsing history is completely synced.

[snip] we need a server-side solution to reliably mark visited/read bugs like an email client or feed reader.
Bugzilla is already logging the user’s last visited timestamp on bugs, so we could use the data. [snip]

So we will have visited bugs highlighted differently, but it will be server-side.

Duplicate of this bug: 1553078
Duplicate of this bug: 1553004
Duplicate of this bug: 1552922
Summary: Fix issues in the post-Sandstone skin including low contrast and small font size → Fix issues in the post-Sandstone skin including low contrast, visited links and small font size
Duplicate of this bug: 1553488
Attached file GitHub Pull Request
Duplicate of this bug: 1554108
Duplicate of this bug: 1554161

PR merged to master. Should be deployed early next week. Thank you all for your feedback! I’ll continue polishing the new skin over the course of time.

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1552936
Regressions: 1556306
No longer regressions: 1556306
Regressions: 1556725
You need to log in before you can comment on or make changes to this bug.