Closed Bug 1377977 (bmo-jedi-theme) Opened 3 years ago Closed 1 year ago

Implement initial version of post-Sandstone theme including Dark Mode

Categories

(bugzilla.mozilla.org :: User Interface, enhancement, P1)

Production
enhancement

Tracking

()

RESOLVED FIXED
Due Date:

People

(Reporter: kohei.yoshino, Assigned: kohei.yoshino)

References

(Blocks 2 open bugs)

Details

(Keywords: bmo-ux)

Attachments

(2 files)

46 bytes, text/x-github-pull-request
Details | Review
51 bytes, text/x-github-pull-request
Details | Review
The Sandstone era is over. It should be replaced with a new theme at some point in the near future. Mozilla's current developing style guides are below:

https://mozilla.ninja/
https://mozilla.github.io/styleguide/
http://design.firefox.com/photon/

Actually there are no web app guidelines here, and basically Bugzilla doesn't necessarily have to follow Mozilla guides. I think it's time to develop a neutral, business-app-like clean theme that can be used by non-BMO instances. (And I'm happy to work on it.)
It should also be mentioned that, during SF All Hands, someone asked me to create a Night Mode sub theme like Twitter or feedly so they can work comfortably at night.
As a reference, Pontoon https://pontoon.mozilla.org/projects/ uses an original dark theme for the entire project.
Note that there is currently *no* theme on BMO; all css files exist under skins/standard. We can change those first.
Assignee: nobody → kohei.yoshino
Due Date: 2018-01-31
Keywords: bmo-ux
Component: Sandstone/Mozilla Skin → User Interface
Summary: Kill Sandstone theme → Create and implement post-Sandstone style guide
This should be included in the upcoming Bugzilla 6 RC builds.
Status: NEW → ASSIGNED
Priority: -- → P1
Will work on the new style guide during this holiday season to make sure it will be part of 6.0.
Due Date: 2018-01-31 → 2019-01-31

This is a Bugzilla 6 blocker, actually.

Severity: normal → blocker

We can soon use the prefers-color-scheme media query for our new dark mode.

See Also: → 1494034

This is still a Q1 goal and Bugzilla 6 blocker...

Due Date: 2019-01-31 → 2019-03-31
Blocks: 1536679
Due Date: 2019-03-31 → 2019-05-14
Blocks: bugzilla-6

We can’t ship during a release week.

Due Date: 2019-05-14 → 2019-05-09
Blocks: 1544331
See Also: → 1330451
Blocks: 1545435
Duplicate of this bug: 1536679
Summary: Create and implement post-Sandstone style guide → Implement initial version of post-Sandstone theme including Dark Mode
Attached file GitHub Pull Request
Blocks: 1548882
Blocks: 1548883
Blocks: 1373420
Blocks: 1380277
Blocks: 1496689
Blocks: 1518216
Blocks: 1520102
Blocks: 1496083
Due Date: 2019-05-09 → 2019-05-16
Blocks: 1472316
See Also: → 1550804
Depends on: 1494034

Merged to the Jedi Master.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Regressions: 1552885
Alias: bmo-jedi-theme
Regressions: 1554521
Regressions: 1556306
Regressions: 1556671
Regressions: 1557360
Regressions: 1558494
Blocks: 344604
No longer blocks: 344604
You need to log in before you can comment on or make changes to this bug.