Closed Bug 1554251 Opened 5 months ago Closed 5 months ago

Enable WebRender on Linux with AMD hardware and Mesa drivers

Categories

(Core :: Graphics: WebRender, enhancement, P3)

Desktop
Linux
enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

Similar to bug 1543217, let's enable WebRender on Linux if the user has AMD hardware and is using recent Mesa drivers.

Assignee: nobody → aosmond
Blocks: wr-linux, wr-amd
Type: defect → enhancement
Priority: -- → P3
Pushed by aosmond@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cb677c177529
Enable WebRender on nightly for AMD hardware with Linux and Mesa drivers. r=jrmuizel
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

With my AMD RV770 (Vendor ID: 0x1002, Device ID: 0x9442, Driver Vendor: mesa/r600, Driver Version: 19.0.5.0) I still get
WEBRENDER_QUALIFIED: blocked-device-too-old by env: Device too old

Mesa Version is obviously higher than 18.0.0.0, but I don't understand the code. Why is my hardware still blocked?

(In reply to Viktor Jägersküpper from comment #4)

With my AMD RV770 (Vendor ID: 0x1002, Device ID: 0x9442, Driver Vendor: mesa/r600, Driver Version: 19.0.5.0) I still get
WEBRENDER_QUALIFIED: blocked-device-too-old by env: Device too old

Mesa Version is obviously higher than 18.0.0.0, but I don't understand the code. Why is my hardware still blocked?

We have only selectively turned on WebRender on certain AMD device IDs for the moment. So you are blocked because of your particular card, not because of the driver. The Intel and NVIDIA rollouts have been the same. We expect to add more devices over time as we gain confidence from low crash volumes and no bug reports, so I beg for patience :). You are of course welcome/encouraged to force it on via gfx.webrender.all in the meantime if your experience is good.

Regressions: 1560600
You need to log in before you can comment on or make changes to this bug.