Closed Bug 1560376 Opened 2 years ago Closed 8 months ago

Horizontal scrollbar appears on youtube when apz.allow_zooming enabled

Categories

(Core :: Panning and Zooming, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox69 --- affected

People

(Reporter: yoasif, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: apz-planning)

Attachments

(1 file)

  1. enable apz.allow_zooming;true
  2. navigate to https://www.youtube.com/
  3. Zoom out once using control -

What happens:

Horizontal scrollbar appears.

Expected result:

No horizontal scrollbar appears, page is not horizontally scroll-able.

On Linux.

Has STR: --- → yes

:yoasif, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

(In reply to Release mgmt bot [:sylvestre / :calixte / :marco for bugbug] from comment #1)

:yoasif, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

This is not a regression. Desktop zooming is a new feature that's incomplete.

Duplicate of this bug: 1622992

Just noticed this also happens on bugzilla (and reddit, per my last duplicated bug).

Whiteboard: desktop-zoom-nightly
Whiteboard: desktop-zoom-nightly → apz-planning

I tried to reproduce on youtube, reddit and bugzilla, I couldn't get a horizontal scrollbar. I'm not sure but I thought I reproduced this in the past. Can you still reproduce?

Flags: needinfo?(yoasif)

I can't reproduce this issue anymore.

Flags: needinfo?(yoasif)

It would be nice to get a fix window using mozregression to know what fixed this. But regardless we can close the bug.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WORKSFORME

I've bisected twice and gotten

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bc0932b38478abd600cae2b23c5f78381e80d0e8&tochange=fa00c3d74a98bc86e8d1bd637d17917259150996

Which seems wrong.

Before switching to autoland builds I get this range

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bc0932b38478abd600cae2b23c5f78381e80d0e8&tochange=d34716786f5b0159ca32bdfbc86fcb6c747618c8

Which includes bug 1578008, bug 1633488, bug 1633938 which seem more likely. Perhaps youtube sends different page contents to nightly builds vs autoland builds?

The autoland range above happens to be the very bottom push of mozilla-central range, ie what you get when finding a fix and every build you test is good, which is why I suspect autoland builds are different than nightly builds in some way for testing this.

You need to log in before you can comment on or make changes to this bug.