Closed Bug 1573383 Opened 1 year ago Closed 8 months ago

Remove firefox-puppeteer Python package

Categories

(Testing :: Marionette, task, P1)

Version 3
task

Tracking

(firefox75 fixed)

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 2 open bugs)

Details

Attachments

(6 files)

The firefox-puppeteer package which can be found at /testing/marionette/puppeteer is mostly unmaintained, and the only consumer are probably the in-tree firefox-ui tests.

Now that the remote agent (our endpoint for Puppeteer) is being worked on, and Marionette client is already deprecated on mozilla-central, everything related to the Marionette Python ecosystem should be removed, or a replacement been found.

Consider this a meta bug and lets file dependencies.

Depends on: 1573393
Depends on: 1573406
See Also: → 1273498
See Also: → 1127786
See Also: → 1121710
See Also: → 1548777
Depends on: 1573638, 1573641

Given that we haven't released any new version of firefox-puppeteer to PyPI during the last 3 years, we might want to simply deprecate this project on PyPI and remove it all together to have no name clashes with the upcoming (Google) Puppeteer support for Firefox. Also in the last three years has been changed so much, so I expect that most of the code from the 52 release is kinda broken on nowadays Firefox releases. If people are using it they will have to migrate to the code base in mozilla-central, which is similar to what we did with Marionette client.

Compared to Marionette I don't think it makes sense to keep this project further on PyPI, and I really would like to completely remove it. Andreas, and Maja do you have any objections for that destructive operation?

Flags: needinfo?(mjzffr)
Flags: needinfo?(ato)

No objections.

Flags: needinfo?(mjzffr)

Given that Andreas is not directly involved into the marionette firefox-puppeteer development and history, I went ahead and deleted the project on PyPI. At the same time I also removed the firefox-ui-harness package, which was dependent on it, and also hasn't been updated for more than 3 years.

Flags: needinfo?(ato)
Attachment #9104850 - Attachment description: Bug 1573383 - [firefox-puppeteer] Update docs for PyPI package deprecation. r=#webdriver a=docs → Bug 1573383 - [firefox-puppeteer] Update docs for PyPI package deprecation. r=#webdriver
Attachment #9104850 - Attachment description: Bug 1573383 - [firefox-puppeteer] Update docs for PyPI package deprecation. r=#webdriver → Bug 1573383 - [firefox-puppeteer] Update docs for PyPI package deprecation. r=#webdriver a=docs
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9650c17fd977
[firefox-puppeteer] Update docs for PyPI package deprecation. r=webdriver-reviewers,maja_zf a=docs
Depends on: 1610014
Depends on: 1369556

I'm going to convert the remaining firefox-ui tests into plain Marionette tests. With that we no longer have a dependency on firefox-puppeteer, and we can remove this whole folder.

Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Priority: -- → P1
Summary: Consider deprecation of firefox-puppeteer Python package → Remove firefox-puppeteer Python package
Duplicate of this bug: 1564411
Blocks: 1613338
Blocks: 1613386
Blocks: 1573410

Before can push the patches we will have to wait for the final review on bug 1573641. This might happen next week on the 13th.

Blocks: 1615416
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/59fc9156b2f5
[marionette] Allow to open a private browsing window. r=marionette-reviewers,maja_zf
https://hg.mozilla.org/integration/autoland/rev/c9619f114626
[fxui] Remove no longer needed keyboard shortcut test. r=marionette-reviewers,maja_zf
https://hg.mozilla.org/integration/autoland/rev/fa9eaa053015
[fxui] Remove firefox-puppeteer dependency from safebrowsing tests. r=marionette-reviewers,maja_zf
https://hg.mozilla.org/integration/autoland/rev/4e5fa5bd9742
[fxui] Remove firefox-puppeteer dependency from sessionstore tests. r=marionette-reviewers,maja_zf
https://hg.mozilla.org/integration/autoland/rev/7ff6cd9c01cd
[marionette] Remove firefox-puppeteer Python package. r=marionette-reviewers,maja_zf

https://firefox-puppeteer.readthedocs.io has also been removed now, which means that all necessary work has been done now.

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Blocks: 1289115
Blocks: 1176422
Blocks: 1470565
You need to log in before you can comment on or make changes to this bug.