Closed Bug 1581377 Opened 5 months ago Closed 5 months ago

Address bar one-off search button container doesn't hide when disabling all one-off engines after landing patch from bug #1577181

Categories

(Firefox :: Address Bar, defect, P1)

71 Branch
defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: Virtual, Assigned: dao)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: nightly-community, regression, ux-minimalism)

Attachments

(3 files)

Attached image bug.png

STR:

  1. Have only 1 active One-Click Search Engine in Search tab ( about:preferences#search ) in Options ( about:preferences )
  2. In Address Bar write "test"
    and see that there is useless empty white space below urlbar dropdown when one-off buttons are hidden.

Kinda similar to bug #1569478.

Regression caused by:
Bug #1577181 - Fix one off search button overflow layout in the urlbar. r=harry

Differential Revision:
https://phabricator.services.mozilla.com/D45826

Flags: needinfo?(dao+bmo)
Assignee: nobody → dao+bmo
Blocks: megabar
Status: NEW → ASSIGNED
Points: --- → 1
Flags: needinfo?(dao+bmo)
OS: Windows 7 → All
Priority: -- → P1
Hardware: x86_64 → All
Summary: Useless empty white space below urlbar dropdown when one-off buttons are hidden after landing patch from bug #1577181 → Address bar one-off search button container doesn't hide when disabling all one-off engines
Iteration: --- → 71.2 - Sept 16 - 29
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a7b4285cc245
Let display:flex not override the hidden attribute on the one off search button container. r=harry
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 71.0a1 (2019-09-18), so I'm marking this bug as VERIFIED.
Thank you very much for instant fix! \o/

Status: RESOLVED → VERIFIED
Summary: Address bar one-off search button container doesn't hide when disabling all one-off engines → Address bar one-off search button container doesn't hide when disabling all one-off engines after landing patch from bug #1577181

Comment on attachment 9093222 [details]
Bug 1581377 - Let display:flex not override the hidden attribute on the one off search button container. r=mak

Beta/Release Uplift Approval Request

  • User impact if declined: see comment 0
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: bug 1577181
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): trivial fix
  • String changes made/needed:
Attachment #9093222 - Flags: approval-mozilla-beta?

Comment on attachment 9093222 [details]
Bug 1581377 - Let display:flex not override the hidden attribute on the one off search button container. r=mak

Visual fixup for the one off search buttons in the urlbar. Approved for 70.0b8.

Attachment #9093222 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1581402
You need to log in before you can comment on or make changes to this bug.