Closed Bug 1585971 Opened 2 months ago Closed 2 months ago

Broken UI (mix of dark and light background colors / colours) on about:preferences (options) and about:addons manager pages

Categories

(Toolkit :: Themes, defect)

71 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: emilghitta, Assigned: bdahl)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image issue42.gif

Affected versions

  • 71.0a1 (BuildId:20191002033852)

Affected platforms

  • Windows 10 64bit
  • Ubuntu 18.04 64bit
  • macOS 10.13.6

Steps to reproduce

  1. Launch Firefox.
  2. Access the about:preferences and the about:addons page

Expected result
The about:preferences and about:addons pages are displayed without any UI issues.

Actual result
The about:preferences and about:addons pages are not being properly displayed.

Regression Range

Notes
Please observe the attached screencast for further information regarding this issue.

Hi Brendan,

It seems that the patch for Bug 1583403 may have caused this regression.

Can you please take a look?

Thank you!

Flags: needinfo?(bdahl)
Duplicate of this bug: 1585999
Duplicate of this bug: 1585996
Assignee: nobody → bdahl
Flags: needinfo?(bdahl)

Just going to make this easier to find so we don't end up with yet more dupes.

Summary: Broken UI is present for the about:preferences and about:addons pages → Broken UI (mix of dark and light background colors / colours) on about:preferences (options) and about:addons manager pages

In bug 1583403, some styling was moved from a "window,dialog,wizard"
section to ":root" which changed the specificity and overrode styles
in common.inc.css. Changing common.inc.css to also use ":root" fixes
the issue.

Duplicate of this bug: 1586074
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b58ea6f54a8b
Fix chrome root element styling. r=bgrins
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Regressions: 1587205
Flags: qe-verify+

I have reproduced this issue using Firefox with build ID: 20191002181251 on Win 10 x64.
I can confirm this issue is fixed, I verified using Firefox 71.0b7 on Win 10 x64 and macOS 10.13.6.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.