Closed Bug 1589836 Opened 2 months ago Closed 2 months ago

Add permanent search icon in front of the megabar

Categories

(Firefox :: Address Bar, enhancement, P1)

enhancement
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.1 - Oct 21 - Nov 3
Tracking Status
firefox72 --- fixed

People

(Reporter: dao, Assigned: dao)

References

(Depends on 3 open bugs, Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(2 files)

No description provided.
Iteration: 71.4 - Oct 14 - 20 → 72.1 - Oct 21 - Nov 3
Attached image Screenshot of patch

I applied the patch locally and the icon seems unnecessarily space consuming to me...

It also doesn't look very good and I suspect it would also look very weird with my separate search bar configuration. It looks out of place.

If users don't use "Flexible Space" on both sides, will this change cover nearest button ("Home" in my case) on left side of address bar or address bar will "take less" space on left making search icon look as button?

It's missing functionality yet, it won't be a dead icon, it's intended to improve the search experience of users, once all the pieces are in their place, that may also require multiple iterations.

(In reply to Virtual_ManPL [:Virtual] 🇵🇱 - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #4)

If users don't use "Flexible Space" on both sides, will this change cover nearest button ("Home" in my case) on left side of address bar or address bar will "take less" space on left making search icon look as button?

No, it doesn't cover anything.

Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fb084e1780fe
Add permanent search icon in front of the megabar. r=adw
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

(In reply to Marco Bonardo [::mak] from comment #5)

It's missing functionality yet, it won't be a dead icon, it's intended to improve the search experience of users, once all the pieces are in their place, that may also require multiple iterations.

@mak - so it is not worth filing a ticket just yet regarding the spacing (color & hover), which seeming to be off when comparing it with all other icons in and around the bar?

Flags: needinfo?(mak77)

You can very much file bugs. But note that it's not an ordinary toolbar button, and becomes part of the address bar on focus. So the goal isn't necessarily to make it look and feel exactly like a toolbar button.

Flags: needinfo?(mak77)
Depends on: 1590374
Depends on: 1590491

When the megabar is not focused, the "Search with..." text now starts very close to the left border, almost without padding. This looks strange.

(In reply to trinywiky from comment #10)

When the megabar is not focused, the "Search with..." text now starts very close to the left border, almost without padding. This looks strange.

This is probably not finished yet, but maybe you should open a new report?

@Mozilla-Team: Can you please attach a screenshot, maybe to the main Megabar meta bug, how the new update will look in its finished state? The new Search Icon looks really weird and out of place to me, which doesn't make much fun to use Nightly at the moment :(

(In reply to Mehmet from comment #11)

@Mozilla-Team: Can you please attach a screenshot, maybe to the main Megabar meta bug, how the new update will look in its finished state? The new Search Icon looks really weird and out of place to me, which doesn't make much fun to use Nightly at the moment :(

We're still actively working with UX to refine it, so it's not possible at this time, I'm sorry.
The goal for this work is very cool imo, it will long term improve discoverability and searchability, for now you'll still have to trust us for a bit.

(In reply to Marco Bonardo [::mak] from comment #12)

(In reply to Mehmet from comment #11)
We're still actively working with UX to refine it, so it's not possible at this time, I'm sorry.
The goal for this work is very cool imo, it will long term improve discoverability and searchability, for now you'll still have to trust us for a bit.

Would it be possible for you to do a post on the Nightly blog about your plan (or at least sharing some info with the Nightly community)
for what it should looks like when done. I mean it'll help us to not file bugreport for false positive.

Flags: needinfo?(mak77)

Engineering already reported your request for feature explanation upstream, whether a blog post will be published is out of our direct control.
Feel free to file bugs for things that look out of place, we can triage them, bugs are cheap.

Flags: needinfo?(mak77)
Regressions: 1590754
Depends on: 1590754
No longer regressions: 1590754
Depends on: 1590785

(In reply to Marco Bonardo [::mak] from comment #12)

(In reply to Mehmet from comment #11)

@Mozilla-Team: Can you please attach a screenshot, maybe to the main Megabar meta bug, how the new update will look in its finished state? The new Search Icon looks really weird and out of place to me, which doesn't make much fun to use Nightly at the moment :(

We're still actively working with UX to refine it, so it's not possible at this time, I'm sorry.
The goal for this work is very cool imo, it will long term improve discoverability and searchability, for now you'll still have to trust us for a bit.

Thanks for your feedback.

(In reply to Marco Bonardo [::mak] from comment #14)

Engineering already reported your request for feature explanation upstream, whether a blog post will be published is out of our direct control.

Looking forward to read about :) Thanks.

Depends on: 1591012
Regressions: 1591043
Regressions: 1591242
Regressions: 1591246
Regressions: 1591848
Depends on: 1591848
No longer regressions: 1591848
Regressions: 1592268
You need to log in before you can comment on or make changes to this bug.