Closed Bug 1597711 Opened 2 years ago Closed 2 years ago

Add conditioned profile support for GeckoView in Raptor

Categories

(Testing :: Raptor, task, P1)

Version 3
task

Tracking

(firefox73 fixed)

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: stephend, Assigned: stephend)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Need to add conditioned-profile support for mobile browsers (starting with GeckoView), in Raptor.

xref: bug 1547747

I've started working on this, but have quite a bit of platform and mobile-app detecting, etc., to go, still (hardcoded hacks ahead): https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=278154723&revision=4fd1eb04abf0fa2163b5fa88e111e85eae9ed708

Status: NEW → ASSIGNED
Priority: -- → P1

this is the code you need:

if isinstance(self, PerftestAndroid):
  platform = "%s-%s" % (self.config["device_name"], self.config["binary"].split("org.mozilla.")[-1])
else:
  platform = get_current_platform()

with a new argument --device-name to add into the raptor CLI (like how you did with --with-conditioned-profile)
then you can add --device-name=XXX mimicing what is done here : https://searchfox.org/mozilla-central/source/taskcluster/ci/condprof/kind.yml#171

Flags: needinfo?(stephen.donner)

The attached patch is as far as I've gotten for today; it's linty fresh, but unittests which download conditioned profiles fail due to device_name still being None.

To test, I've been running both ./mach raptor-test -t raptor-tp6m-1-cold --device-name --app geckoview --binary org.mozilla.geckoview_example for mobile and ./mach raptor-test -t raptor-tp6-1-cold for desktop.

Desktop runs and passes fine, but I haven't tested extensively nor pushed yet to try. I've gotten --device-name being read in from the commandline, as a test, but am hitting 07:56:53 INFO - raptor.py: error: argument --device-name: expected one argument with the patch I've just attached, here. (Didn't want to spam Phab with it yet.)

Flags: needinfo?(stephen.donner)

I imported the WIP patch and then I tried to get the second attached, but I am receiving some conflicts. Not sure if there are any other patches/changes in order to make this work. Will continue trying.

Edit: still didn't manage. If you to a rebase to central and send me a hg diff -r [latest rev on central] -r [tip of your bookmark] yould really help me.

Flags: needinfo?(stephen.donner)
Attachment #9112805 - Attachment description: Bug 1597711 - [WIP] Add conditioned profile support for GeckoView in Raptor. r?tarek,#perftest → Bug 1597711 - Add conditioned profile support for GeckoView in Raptor
Duplicate of this bug: 1604638

(In reply to Alexandru Ionescu :alexandrui from comment #5)

I imported the WIP patch and then I tried to get the second attached, but I am receiving some conflicts. Not sure if there are any other patches/changes in order to make this work. Will continue trying.

Edit: still didn't manage. If you to a rebase to central and send me a hg diff -r [latest rev on central] -r [tip of your bookmark] yould really help me.

Hey, sorry about this; Tarek's handling this patch, now, and has it well in hand.

Flags: needinfo?(stephen.donner)
Attachment #9112805 - Attachment description: Bug 1597711 - Add conditioned profile support for GeckoView in Raptor → Bug 1597711 - Add conditioned profile support for GV & Fenix in Raptor
Pushed by tziade@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cb86af33e59f
Add conditioned profile support for GV & Fenix in Raptor r=stephendonner,rwood
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
See Also: → 1606199
Duplicate of this bug: 1601017
You need to log in before you can comment on or make changes to this bug.