Closed Bug 1616937 Opened 4 years ago Closed 2 years ago

Stop using JSImpl for RTCRtpSender

Categories

(Core :: WebRTC: Signaling, task, P2)

task

Tracking

()

RESOLVED FIXED
101 Branch
Tracking Status
firefox101 --- fixed

People

(Reporter: bwc, Assigned: bwc)

References

Details

Attachments

(6 files, 1 obsolete file)

No description provided.
Depends on: 1620308
See Also: → 1620689
Depends on: 1624989

This happens to fix a failure in webrtc/RTCPeerConnection-restartIce.https.html.

Depends on D141738

Attachment #9268871 - Attachment is obsolete: true

Depends on D141740

Attachment #9268912 - Attachment description: WIP: Bug 1616937: (WIP) Move RTCRtpSender to c++ → Bug 1616937: Move RTCRtpSender to c++ r?mjf

This ability to st the main thread has never been used, and in many cases is
not possible due to things being cycle collected (and therefore
main-thread-only).

Depends on D141770

These are cycle collected, so no need to use this weakptr stuff.

Depends on D142382

Most of the errors we check for here should never happen, so crash/assert where
appropriate. Also, handle the codec negotiation failure case outside of the
conversion function, where we can log it better.

Depends on D142383

Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/31d4e8adf1dc
Move RTCRtpSender to c++ r=mjf,webidl,smaug
https://hg.mozilla.org/integration/autoland/rev/41ff3e562389
Remove main thread parameters/members. r=mjf
https://hg.mozilla.org/integration/autoland/rev/f045541b2575
Hold strong refs to the PC in Transceiver/Sender/Receiver. r=mjf
https://hg.mozilla.org/integration/autoland/rev/91a1718d9a5a
Improve error handling during conduit updates. r=mjf
https://hg.mozilla.org/integration/autoland/rev/6908b674bc94
Move some sender and receiver logic to RTCRtpSender/Receiver. r=mjf
https://hg.mozilla.org/integration/autoland/rev/f853e1e31b38
Fix some warnings from clang-tidy on pre-existing code. r=mjf
Regressions: 1763832
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: