Closed Bug 1619837 Opened 1 year ago Closed 1 year ago

Eliminate use of `fix_{linux,macosx}_stack.py` in `utils.py`

Categories

(Toolkit :: Crash Reporting, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: n.nethercote, Assigned: n.nethercote)

References

Details

Attachments

(5 files, 2 obsolete files)

utils.py uses fix_linux_stack.py and fix_macosx_stack.py. These can now be replaced with fix_stacks.py, for speed and code simplicity improvements.

Blocks: 1619840
Blocks: 1602717

This is needed for utils.py to use fix_stacks.py without getting hangs.

Because fix_stacks.py is faster and cross-platform.

Depends on D65678

Attachment #9131358 - Attachment description: Bug 1619837 - Eliminate use of `fix_{linux,macosx}_stack.py` in `utils.py`. r=gsvelto → Bug 1619837 - Eliminate use of `fix_{linux,macosx}_stack.py` in `utils.py`. r=erahm

It's currently installed on all platforms that run xpcshell tests, but some
platforms that need fix-stacks don't run xpcshell tests. This commit makes it
a direct dependency for all the platforms that need it.

First, with fix_stacks.py now being used on most test suites, those test
suites need a dependency on fix-stacks.

Second, for those few configurations that don't run xpcshell tests, we need a
fix-stacks dependency in the build job. This is because xpcshell self tests
run during the build job, but the existing xpcshell test dependency doesn't
cover that case.

Specifically:

  • handle input that doesn't end in a newline;
  • only pass lines that match the regexp to fix-stacks.

These changes are needed for utils.py to use fix_stacks.py without
problems.

Depends on D65943

Attachment #9131365 - Attachment is obsolete: true
Attachment #9131357 - Attachment is obsolete: true
Attachment #9131358 - Attachment description: Bug 1619837 - Eliminate use of `fix_{linux,macosx}_stack.py` in `utils.py`. r=erahm → Bug 1619837 - Eliminate use of `fix_{linux,macosx}_stack.py` in `utils.py`. r=gsvelto
Pushed by nnethercote@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/973cf06031df
Extend `fix-stacks` dependencies. r=glandium
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: leave-open
No longer blocks: 1596292
Pushed by nnethercote@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a6baed370a03
Make `fix_stacks.py` more like `fix_linux_stacks.py`. r=erahm
Keywords: leave-open
Pushed by nnethercote@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c6bc4817cea2
Eliminate use of `fix_{linux,macosx}_stack.py` in `utils.py`. r=gsvelto
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla76 → ---
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2aadc604b542
Backed out changeset c6bc4817cea2 for causing perma mochitest tier2 failure in testing/mochitest/tests/python/test_basic_mochitest_plain.py CLOSED TREE

EDIT: Ah, I found the problem: "Exception: cannot find fix-stacks; please run ./mach bootstrap".

I'm still not pleased about getting backed out for failure of a tier2 test job that wasn't even running on try pushes.

Flags: needinfo?(n.nethercote) → needinfo?(ahal)
Flags: needinfo?(ahal)
Pushed by nnethercote@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5cd778db960
Add a missing `fix-stacks` dependency for the `py2(mch)` test job. r=erahm
https://hg.mozilla.org/integration/autoland/rev/a780a89ed13f
Eliminate use of `fix_{linux,macosx}_stack.py` in `utils.py`. r=gsvelto
Pushed by nnethercote@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ffd615bf92dd
Add a missing `fix-stacks` dependency for the `py2(ref)` test job. r=erahm
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Regressions: 1624980
Regressions: 1626945
You need to log in before you can comment on or make changes to this bug.