Open Bug 1627479 Opened 4 years ago Updated 9 days ago

Make Minimize to tray work on Linux, too

Categories

(Thunderbird :: OS Integration, enhancement)

Unspecified
Linux
enhancement

Tracking

(Not tracked)

People

(Reporter: asdfghrbljzmkd, Unassigned)

References

()

Details

(Keywords: ux-efficiency)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

In bug 1626161 (edited), tray icon functionality was implemented in Thunderbird on Windows. As a Linux user I'd like to see this functionality in Linux, and although I don't have the Win vs. Linux user stats for TB, I suspect many others want this functionality too.

This is covered in bug 18732 (which I've now moved to Thunderbird)

Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
OS: Unspecified → Linux
Resolution: --- → DUPLICATE

I'll have to respectfully disagree with the DUP here. "minimize to tray" and "new mail notification in tray", while surely related features, are not the same feature.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

As the OP, I also expect the bugs to be fixed and new features to be introduced equally for all 3 major platforms.

For additional details about how tray could be implemented on Linux, please see this comment: https://bugzilla.mozilla.org/show_bug.cgi?id=18732#c53.

I believe that, making (via an option) the 'close window' event to be treated as a 'minimize window' event and making (again via another related option) TB start minimized, at this time would be enough for Linux (and all other Linux-related platforms like the *BSD) which is a low-hanging fruit, but also at the same time it would be something for Linux, not like it's now completely ignored for this particular feature.

See Also: → 18732

(In reply to Anatoli from comment #3)

I believe that, making (via an option) the 'close window' event to be treated as a 'minimize window' event and making (again via another related option) TB start minimized, at this time would be enough for Linux (and all other Linux-related platforms like the *BSD)

Unless I misunderstood something, this bug (and the windows implementation in bug 1626161) are only about minimizing to the tray, not about redirecting the close button.

Side note: the first part of your suggestion is available as add-on (https://addons.thunderbird.net/thunderbird/addon/minimize-on-close/). To get into the tray, a native application like KDocker can be used to automatically move Thunderbird into the tray while it is minimized.

Summary: Minimize to tray on Linux → Make Minimize to tray work on Linux, too
Depends on: 1626161

There WAS an extension, FireTray, which did the trick. Alas, it requires API that no longer exists in modern Thunderbird.

There's also an external hack, BirdTray, whose packaging for Debian I maintain. Alas, it's too unreliable for serious usage.

See also: https://bugzilla.mozilla.org/show_bug.cgi?id=1707920
I asked about this here: https://unix.stackexchange.com/q/656489/233262
Any progress on this?
Minimizing to tray is an important feature, I can't understand why it hasn't been implemented by now (not via any external hacks/tools but natively by Thunderbird itself).

(Anatoli from comment #3)

I believe that, making (via an option) the 'close window' event to be treated as a 'minimize window' event and making (again via another related option) TB start minimized, at this time would be enough for Linux (and all other Linux-related platforms like the *BSD) which is a low-hanging fruit, but also at the same time it would be something for Linux, not like it's now completely ignored for this particular feature.

(In reply to rsjtdrjgfuzkfg (Dirk Steinmetz) from comment #4)

Unless I misunderstood something, this bug (and the windows implementation in bug 1626161) are only about minimizing to the tray, not about redirecting the close button.

Still it would be nice to see the switchable "Close to tray" being implemented. It has been requested for Windows in Bug 1666638.
But just like the option to "Start Thunderbird minimized" it's not in the scope of the initial feature request indeed.

Status: REOPENED → NEW
Keywords: ux-efficiency
See Also: → 1666638

(In reply to grepper from comment #10)

I also vote for this bug.

We don't vote with comments please. Certainly CC yourself to the bug report. And there is a vote button. Thanks

Severity: normal → S3
Duplicate of this bug: 1850378
You need to log in before you can comment on or make changes to this bug.