Closed Bug 1627989 Opened 3 months ago Closed 2 months ago

Remove the browser.urlbar.openViewOnFocus pref

Categories

(Firefox :: Address Bar, task, P2)

task
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 78
Iteration:
78.2 - May 18 - May 31
Tracking Status
firefox77 --- wontfix
firefox78 --- fixed

People

(Reporter: dao, Assigned: harry)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is an internal pref that has lost its purpose now that we've enabled it by default in release. Bug 1627858 has been filed for a user-visible pref for the top sites feature.

Blocks: 1627858
No longer blocks: 1627858
Depends on: 1627858

Suggestion: remove this preference only after the new preference as per the first comment has been implemented.

Blocks: 1630275
No longer blocks: megabar
Blocks: megabar
No longer blocks: 1630275

Also, there is a comment here on another issue, that seems to suggest that a flag like this one will be added. This confuses me a little now as I thought that this is already that flag, which they are looking for https://bugzilla.mozilla.org/show_bug.cgi?id=1629303#c1 . I must be missing something.

The one removed here is an implementation flag, we use them when we develop features to disable them in case they break the release. Once a feature is released with no breakage, these prefs are removed. These are prefs only for an implementation detail, they were never intended to be user prefs.
bug 1627858 is the one to add a user pref.

Thank you for the explanation, @Marco Bonardo.

If I understand it correctly, then technically there is no difference between an "implementation flag" and a "user pref". Or is there? I also fail to see any obvious naming-scheme, or "-flag", "user." prefixes or suffixes or the like that would distinguish them based on their name.

Thus if my assumption is correct, then I suggest that this "implementation flag" would simply not be removed and henceforth be used as a "user pref", as suggested in the bug 1627858.

Or is it, that it has to be deleted and then re-created in order to conform to some formal process definition?

my understanding is that this implementation flag is a switch between old implementation and new implementation, while the user pref will control some aspect of the new implementation, but it will never behave completely identical to the old one.

(In reply to marczellm from comment #10)

my understanding is that this implementation flag is a switch between old implementation and new implementation, while the user pref will control some aspect of the new implementation, but it will never behave completely identical to the old one.

that's right.

(In reply to Patrick Pfeifer from comment #9)

If I understand it correctly, then technically there is no difference between an "implementation flag" and a "user pref". Or is there? I also fail to see any obvious naming-scheme, or "-flag", "user." prefixes or suffixes or the like that would distinguish them based on their name.

It would be pointless, the main problem is that due to technical restrictions we must use prefs, and users will discover which prefs we use anyway. We're working in a transparent environment, anyone can read bugs, patches and the code.

I'll remove this once bug 1627858 has landed.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 77.2 - Apr 20 - May 3
Points: --- → 2
Depends on: 1633492
Iteration: 77.2 - Apr 20 - May 3 → ---

(In reply to Patrick Pfeifer from comment #7)

Also, there is a comment here on another issue, that seems to suggest that a flag like this one will be added. This confuses me a little now as I thought that this is already that flag, which they are looking for https://bugzilla.mozilla.org/show_bug.cgi?id=1629303#c1 . I must be missing something.

browser.urlbar.openViewOnFocus set to false was suggested to me from Marco Bonardo in my bug report https://bugzilla.mozilla.org/show_bug.cgi?id=1629303 I now see that this will be removed in an upcoming release, why make the suggestion and then take the option away. although not a fix in itself setting browser.urlbar.openViewOnFocus to false and using CSS (userchrome) to disable the expanding/shrinking helps to a degree.

(In reply to Troy Janda from comment #16)

why make the suggestion and then take the option away.

As per comment 15, this pref will not be removed until we introduce a similar user-facing pref in about:preferences. We are adding a new pref in about:preferences instead of keeping this pref because this one also controls the address bar's "retained results" feature, which we do not intend to support a pref for. Retained results is the behaviour where if you type a query without hitting Enter, then unfocus the address bar, then refocus it, the results you were previously viewing re-open.

Bug 1627858 should be done next sprint, meaning we can remove this pref after.

Iteration: --- → 78.2 - May 18 - May 31
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/039d58aba1f0
Remove the browser.urlbar.openViewOnFocus pref. r=dao
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Blocks: 1641661
Regressions: 1642177
You need to log in before you can comment on or make changes to this bug.