Closed Bug 1634615 Opened 6 months ago Closed 5 months ago

Flip the preference to enable the new browser.storage.sync implementation

Categories

(WebExtensions :: Storage, enhancement, P2)

enhancement

Tracking

(firefox79 verified)

VERIFIED FIXED
mozilla79
Tracking Status
firefox79 --- verified

People

(Reporter: markh, Assigned: markh)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: SACI)

Attachments

(1 file)

We will be landing a new implementation of browser.storage.sync behind a preference that defaults to false. Once all bugs which block this are resolved, we can flip that pref to true and stand by with our bullet-proof glass and fire extinguishers.

Depends on: 1635348
No longer depends on: 1634191
Severity: -- → N/A
Priority: -- → P2
Blocks: 1637465
Depends on: 1641005
Depends on: 1642271
Duplicate of this bug: 1311764
Assignee: nobody → markh
Status: NEW → ASSIGNED

So it wasn't as trivial as the 1 line patch :) 3 tests also needed a pref flipped - 2 were obviously kinto-specific tests, so they had to see the pref left with kinto enabled, and the last one was a sync test which took me some time to diagnose, but I'm confident isn't related to this specific engine, but rather related to a sync paper cut that's existed for years but which this hits because addons and extension-storage are behind the same preference.

The changes are sensible and small enough I'm going to land this anyway - https://treeherder.mozilla.org/#/jobs?repo=try&revision=61861e8e3a092d37e31965b0b7f8256051905611

Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fc977a4eff9e
flip the pref to enable the rust browser.storage.sync implementation. r=lina,mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Regressions: 1645598

Release Note Request (optional, but appreciated)

[Why is this notable]:
The kinto database (for add-on preference syncing) has been seeing high loads on CPU and RAM which can lead to an increase of 500 errors when users are syncing for some time. Our team (sync) has been working closely with the Benson's team and the Ops team to mitigate the issue (ref https://bugzilla.mozilla.org/show_bug.cgi?id=1621806) but this is the long-term solution, migrating chrome.storage.sync over to use the sync15 backend in place of Kinto.
[Affects Firefox for Android]: No
[Suggested wording]: Chrome.storage.sync is now backed by Sync1.5, mitigating issues with reliability. No user-facing impacts are intended.
[Links (documentation, blog post, etc)]: This should be part of the developer release notes, preferably in the section specific to add-on developers.

relnote-firefox: --- → ?

Verified as fixed in FF79

Status: RESOLVED → VERIFIED

I don't think this should be dev-doc-needed, should it? It doesn't seem like a functional change for extension developers.

The addons team also created https://blog.mozilla.org/addons/2020/07/09/changes-to-storage-sync-in-firefox-79 as a heads-up for addon developers.

I believe that from the docs side this is taken care of by https://bugzilla.mozilla.org/show_bug.cgi?id=1637166#c7 .

Duplicate of this bug: 1393792
Duplicate of this bug: 1415222
You need to log in before you can comment on or make changes to this bug.