Closed Bug 1653119 Opened 6 months ago Closed 6 months ago

Redesign study cards

Categories

(Firefox :: Pioneer, task, P1)

task

Tracking

()

VERIFIED FIXED
81 Branch
Tracking Status
firefox80 + verified
firefox81 --- verified

People

(Reporter: marnie, Assigned: rhelmer)

References

(Blocks 2 open bugs)

Details

(Whiteboard: off-train)

Attachments

(2 files, 1 obsolete file)

Wireframes, page 9
Screen ID: S3
Annotation ID: Z1, Z2, Z3, Z4, Z5, Z6, Z7
Related to 1653109

As a user, I want to clearly understand the purpose, scope, and author of a study so I can decide whether to join.

Z1: Study Title (Rob: these requirements likely don't belong here, but in the runbook; feel free to ignore)

  • Alphanumeric
  • Max chars: 75
  • Required

Z2: Study authors

  • Max chars: 75
  • Link to authors page, external (not Mozilla/Firefox hosted)
  • Required

Z3: Study description

  • Max chars: TBD
  • Alphanumeric
  • Required

Z4: Study privacy policy

  • Link; onclick, pop the study privacy policy modal [S4]
  • Required

Z5: More info link

  • Found in the meatball menu
  • Required
  • Onclick, link to the public study URL

Z6: Data collection bullets

  • Required
  • Max number of bullets? Do we need to restrict this?

Z7: Study duration

  • Required
  • Format TBD
Priority: -- → P1

(In reply to Marnie Pasciuto-Wood [:marnie] from comment #0)

Wireframes, page 9
Screen ID: S3
Annotation ID: Z1, Z2, Z3, Z4, Z5, Z6, Z7
Related to 1653109

As a user, I want to clearly understand the purpose, scope, and author of a study so I can decide whether to join.

Z1: Study Title (Rob: these requirements likely don't belong here, but in the runbook; feel free to ignore)

  • Alphanumeric
  • Max chars: 75
  • Required

Z2: Study authors

  • Max chars: 75
  • Link to authors page, external (not Mozilla/Firefox hosted)
  • Required

Z3: Study description

  • Max chars: TBD
  • Alphanumeric
  • Required

Z4: Study privacy policy

  • Link; onclick, pop the study privacy policy modal [S4]
  • Required

Z5: More info link

  • Found in the meatball menu
  • Required
  • Onclick, link to the public study URL

Z6: Data collection bullets

  • Required
  • Max number of bullets? Do we need to restrict this?

Technically we don't need to since expanding vertically is more reasonable than horizontally, but for sanity's sake I think we should :)

Z7: Study duration

  • Required
  • Format TBD

This bug is pretty straightforward to implement except we'll need to figure out some way to support simple markup, either a whitelisted set of HTML tags or markdown.

Assignee: nobody → rhelmer
Status: NEW → ASSIGNED

This is the current schema as loaded on Remote Settings for the "pioneer-study-addons" collection.

We'll need to modify this to match the new fields outlined in this bug. Mat, once we have a new schema is it better to create a new collection, or is there some good way to modify the current collection?

Attachment #9165226 - Flags: feedback?(mathieu)
Attachment #9165226 - Flags: feedback?(mathieu)

(In reply to Robert Helmer [:rhelmer] from comment #3)

Created attachment 9165226 [details]:l
The current pioneer study add-on schema

This is the current schema as loaded on Remote Settings for the "pioneer-study-addons" collection.

We'll need to modify this to match the new fields outlined in this bug. Mat, once we have a new schema is it better to create a new collection, or is there some good way to modify the current collection?

Sorry I just meant to needinfo you, no special feedback on this schema is needed :) I've just included it for reference, we're going to move it to something more like comment 0.

Flags: needinfo?(mathieu)

[Tracking Requested - why for this release]:

Attached file Proposed Pioneer add-on study schema (obsolete) —

(In reply to Robert Helmer [:rhelmer] from comment #2)

This bug is pretty straightforward to implement except we'll need to figure out some way to support simple markup, either a whitelisted set of HTML tags or markdown.

Looking at the requirements here I'm wondering if we can just have about:pioneer do the formatting (e.g. generate bullet points as it iterates over data collection details, linkify URLs etc) so it's specified by the data model vs. trying to allow this sort of formatting, since there are security and complexity issues here.

Comment on attachment 9165484 [details]
Proposed Pioneer add-on study schema

Actually instead of doing this here, I am going to land this schema in-tree and validate it against the mock we use for the UI test. We can then keep RS in sync with this.
Attachment #9165484 - Attachment is obsolete: true

I think there are like 3 things we want (which is why i was thinking about markdown).

  1. The ability to add links to descriptions (this is the biggest scariest threat imo) for the purpose of linking out to privacy policies, or other supporting/interesting materials.
  2. We want the ability to communicate the duration of the study in a pretty way eventually. This is probably just start & end dates right now that need to be bolded / called out some how.
  3. We need to have a two column layout w/ the description on one side, and the bullets on the other side.

But like that's just what we're thinking right now. We're going to need to iterate on this, which is why flexibility around the formatting off trains would be super helpful

We'll need to modify this to match the new fields outlined in this bug. Mat, once we have a new schema is it better to create a new collection, or is there some good way to modify the current collection?

The schema can be updated as many times as you want, but you're responsible of managing data migrations on your existing clients. Records will have a schema field with the version of the schema that was in place when last edited.

If you have access to this Github repo, you can even edit it yourself and open a pull-request:
https://github.com/mozilla-services/remote-settings-permissions/blob/a1e0ea08eb0f4114f54dbd444f83959e4bc68664/kinto.prod.yaml#L835-L872
The schema will be live as soon as merged.

Flags: needinfo?(mathieu)
Component: General → Pioneer
Blocks: 1653125
Blocks: 1653145
No longer blocks: 1653125
Whiteboard: off-train
Summary: Pioneer - Study Card → Redesign study cards

(In reply to Ted Han from comment #9)

I think there are like 3 things we want (which is why i was thinking about markdown).

  1. The ability to add links to descriptions (this is the biggest scariest threat imo) for the purpose of linking out to privacy policies, or other supporting/interesting materials.
  2. We want the ability to communicate the duration of the study in a pretty way eventually. This is probably just start & end dates right now that need to be bolded / called out some how.
  3. We need to have a two column layout w/ the description on one side, and the bullets on the other side.

But like that's just what we're thinking right now. We're going to need to iterate on this, which is why flexibility around the formatting off trains would be super helpful

We considered a few options for doing this in an easily-expressable way (say, being able to use markdown for the basic structure, at least) but we don't have anything production-ready to use for this. Going with the two-column layout and with the expected values above is probably the safe way to go here - we can still support things like arbitrary number of bullet points, links, et al but need to plan for it.

Depends on: 1653125
Blocks: 1653125
No longer depends on: 1653125
Pushed by rhelmer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b41de9e8fd9a
redesign Pioneer study cards, and include new schema plus validation for mock r=fluent-reviewers,sfoster
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Blocks: 1657985

Comment on attachment 9167239 [details]
Bug 1653119 - redesign Pioneer study cards, and include new schema plus validation for mock r?mstriemer

Beta/Release Uplift Approval Request

  • User impact if declined: Sets up the user to understand individual studies. Provides additional details and links for further information. Without this, users can't effectively understand the details about specific studies. Additionally, without study cards, partners will not be able to get their studies into the Pioneer environment, negating one of the main purposes of the Pioneer program.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: After joining the Pioneer program via about:pioneer, a user shall be able to see details about individual studies.
  • List of other uplifts needed: Bug 1653125, Bug 1646203, Bug 1653136
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The about:pioneer page is not advertised to users in any way; there is no marketing support for Fx80; this is foundational work. If someone happens to find it, and something doesn't work correctly, nothing in Firefox is broken. Low risk to brand.
  • String changes made/needed: N/A
Attachment #9167239 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9167239 [details]
Bug 1653119 - redesign Pioneer study cards, and include new schema plus validation for mock r?mstriemer

approved for 80 rc1

Attachment #9167239 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified - Fixed in latest Nightly 81.0a1 (2020-08-19) and 80 RC (build id: 20200817172600). The details about individual studies are displayed, with the mention that not all the details from the description are displayed due the fact that not all of them are implemented yet.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.