Closed Bug 1653125 Opened 6 months ago Closed 5 months ago

Add consent modals for all Pioneer and Study Join/Leave interactions

Categories

(Firefox :: Pioneer, task, P1)

task

Tracking

()

VERIFIED FIXED
81 Branch
Tracking Status
firefox80 + verified
firefox81 --- verified

People

(Reporter: marnie, Assigned: rhelmer)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Wireframes, page 13
Screen ID: S4
Annotation ID: K1, K1a

User Joins Study
As a Pioneer user, I would like to enroll in a study so my data can support its goals

  • After pressing "Join study" [J1] we check for acceptance of study policy notice
  • If the user has already accepted the specific study policy notice, we do not show it to them again.
    • If policy accepted, begin study enrollment
    • Send date/time telmetry ping.

If the user has not accepted the policy notice yet

  • K1: Onclick "Cancel", the modal closed and the study is not joined. User returns to the Available Studies panel [S3], with the study still showing available.
  • Onlick "Accept and Join" begin study Enrollment. Modal closes and user returns to Available studies panel

Study Enrollment A/C:

  • Study add-on downloads in the background, data collection begins
  • Available studies panel [s3] shows study is now "Active" and there is a button to "leave"

User Reads Study Consent before clicking Join
K1a: As a Pioneer user, I want to read the privacy policy for a specific study, so I can choose whether or not to participate.

  • User clicks the privacy notice link [Z4], we pop open the Pioneer Privacy Consent modal [S2]
  • User sees the Accept (K2) and Cancel (K1/K1a) buttons
  • If user cancels (K1/K1a) the modal closes
  • If User accepts the policy, we mark them as Consented. We send the telemetry ping for their acceptance
    • This user has accepted the consent so if they click "Join/Enroll" they do not see the modal again

User Re-Reads Consent Notice after Accepting
As a user, I want to re-read the privacy consent for a study I've already joined, so I remember what I agreed to

  • User clicks the privacy notice link, we pop open the consent modal [S2]
  • The modal displays the privacy notice with a visual indicator that the user has accepted these terms
Priority: -- → P1
Duplicate of this bug: 1653096
Duplicate of this bug: 1653106

[Tracking Requested - why for this release]:

Component: General → Pioneer

(In reply to Marnie Pasciuto-Wood [:marnie] from comment #0)

Wireframes, page 13
Screen ID: S4
Annotation ID: K1, K1a

User Joins Study
As a Pioneer user, I would like to enroll in a study so my data can support its goals

  • After pressing "Join study" [J1] we check for acceptance of study policy notice
  • If the user has already accepted the specific study policy notice, we do not show it to them again.
    • If policy accepted, begin study enrollment
    • Send date/time telmetry ping.

If the user has not accepted the policy notice yet

  • K1: Onclick "Cancel", the modal closed and the study is not joined. User returns to the Available Studies panel [S3], with the study still showing available.
  • Onlick "Accept and Join" begin study Enrollment. Modal closes and user returns to Available studies panel

Study Enrollment A/C:

  • Study add-on downloads in the background, data collection begins
  • Available studies panel [s3] shows study is now "Active" and there is a button to "leave"

User Reads Study Consent before clicking Join
K1a: As a Pioneer user, I want to read the privacy policy for a specific study, so I can choose whether or not to participate.

  • User clicks the privacy notice link [Z4], we pop open the Pioneer Privacy Consent modal [S2]
  • User sees the Accept (K2) and Cancel (K1/K1a) buttons
  • If user cancels (K1/K1a) the modal closes
  • If User accepts the policy, we mark them as Consented. We send the telemetry ping for their acceptance
    • This user has accepted the consent so if they click "Join/Enroll" they do not see the modal again

This part is doable now, and I think it's worth just landing all the modal changes together and getting the behavior right instead of landing piecemeal, which will make the related bugs easier. I have a patch for this, I will add it to this bug .

User Re-Reads Consent Notice after Accepting
As a user, I want to re-read the privacy consent for a study I've already joined, so I remember what I agreed to

  • User clicks the privacy notice link, we pop open the consent modal [S2]
  • The modal displays the privacy notice with a visual indicator that the user has accepted these terms

I think we need the redesigned study cards from bug 1653119 in order to do this part.

Depends on: 1653119
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
Duplicate of this bug: 1653132
Duplicate of this bug: 1653129
Duplicate of this bug: 1653111
Summary: User Joins study and reads study consent → Add consent modals for all Pioneer and Study Join/Leave
Blocks: 1653145

(In reply to Robert Helmer [:rhelmer] from comment #4)

(In reply to Marnie Pasciuto-Wood [:marnie] from comment #0)

User Re-Reads Consent Notice after Accepting
As a user, I want to re-read the privacy consent for a study I've already joined, so I remember what I agreed to

  • User clicks the privacy notice link, we pop open the consent modal [S2]
  • The modal displays the privacy notice with a visual indicator that the user has accepted these terms

I think we need the redesigned study cards from bug 1653119 in order to do this part.

After triaging a bit, I think this is already covered in bug 1653101 so we can handle it over there.

No longer depends on: 1653119
Summary: Add consent modals for all Pioneer and Study Join/Leave → Add consent modals for all Pioneer and Study Join/Leave interactions
Blocks: 1653119

The plan to unblock this is to enabled <dialog> for chrome-only code in Firefox 80, the primary reason it's disabled with now is an a11y issue (bug 1200896). However, we can work around this issue for 80 with a JS focus hack. I'll set the bug blocking when it's filed / I find it :)

No longer blocks: 1653119
Depends on: 1653119
Blocks: 1657985

OK I think the patch is fine, sounds like we really want to be able to remotely update the text in the modals. I am going to work up an additional patch in this bug.

(In reply to Robert Helmer [:rhelmer] from comment #11)

OK I think the patch is fine, sounds like we really want to be able to remotely update the text in the modals. I am going to work up an additional patch in this bug.

Actually I take that back, I am going to land the current patch and we can continue to talk about how dynamic we want the modals to be. I think I'm going to make them totally off-train but I'd like to split that decision out from this bug and land-as is.

Pushed by rhelmer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d001eccdda1
add modal dialogs for joining and leaving studies r=fluent-reviewers,flod

Comment on attachment 9166486 [details]
Bug 1653125 - add modal dialogs for joining and leaving studies r?mstriemer

Beta/Release Uplift Approval Request

  • User impact if declined: Without these modals, users won't be able to successfully opt into any studies or the Pioneer program. Privacy policies and user consent details are contained within these modals and must be successfully read and accepted before participation.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Clicking on any of the "join" or "enroll" buttons in about:pioneer should launch a modal.
  • List of other uplifts needed: Bug 1646203, Bug 1653119, Bug 1653136
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The about:pioneer page is not advertised to users in any way; there is no marketing support for Fx80; this is foundational work. If someone happens to find it, and something doesn't work correctly, nothing in Firefox is broken. Low risk to brand.
  • String changes made/needed: N/A
Attachment #9166486 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
QA Whiteboard: [qa-triaged]

Comment on attachment 9166486 [details]
Bug 1653125 - add modal dialogs for joining and leaving studies r?mstriemer

approved for 80 rc1

Attachment #9166486 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified - Fixed in latest Nightly 81.0a1 (2020-08-19) and 80 RC (build id: 20200817172600). The modals are displayed and works properly, with the mention that the modals content is not displayed yet. Also the "User Re-Reads Consent Notice after Accepting" implementation was deprioritized.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.