Closed Bug 1678607 Opened 1 year ago Closed 2 months ago

Add dedicated tags notifications

Categories

(Toolkit :: Places, task, P3)

task

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: mak, Assigned: daisuke)

References

(Blocks 4 open bugs)

Details

Attachments

(3 files)

Instead of using onItemChanged("tags") we should have a dedicated notification for tags.

Ideally it could be a simple bookmark-tags-changed notification, passing an up-to-date list of tags, but some analysis should be done to check if the list of tags is something we get for free (or cheap), if it's something the consumer would fetch regardless, or if we'd have to fetch them.
We could also go with tags-added and tags-removed, but it seems more work for consumers if at the same time some is removed and some is added.

The notification should probably derive from the PlacesBookmark event

Blocks: 424160
Duplicate of this bug: 1607248
Assignee: nobody → daisuke
Status: NEW → ASSIGNED

Depends on D128326

Depends on D128327

Blocks: 1736250
Blocks: 1736251
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2688fa3d2bc2
Implement a mechanism to fire bookmark-tags-changed event. r=mak
https://hg.mozilla.org/integration/autoland/rev/fd3fbf15e95d
Apply bookmark-tags-changed event. r=mak
https://hg.mozilla.org/integration/autoland/rev/bf20be578758
Make BookmarkTagsChanged event have tags. r=mak

Backed out 3 changesets (Bug 1678607) for causing bc failures in browser_bookmark_add_tags.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/1b6f0e11b8bbd98662242c7f9a141c08bfce516b
Push with failures, failure log.

Flags: needinfo?(daisuke)
Flags: needinfo?(daisuke)
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7705a6b69701
Implement a mechanism to fire bookmark-tags-changed event. r=mak
https://hg.mozilla.org/integration/autoland/rev/13868a361ad3
Apply bookmark-tags-changed event. r=mak
https://hg.mozilla.org/integration/autoland/rev/63d10a00d256
Make BookmarkTagsChanged event have tags. r=mak
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.