Open Bug 168648 Opened 19 years ago Updated 1 year ago

Cannot filter (move) messages to Inbox that is busy (fetching its own mail)

Categories

(MailNews Core :: Filters, defect)

defect
Not set
normal

Tracking

(Not tracked)

People

(Reporter: mozilla, Unassigned)

References

(Depends on 3 open bugs, Blocks 3 open bugs)

Details

(Whiteboard: [also mozilla-1.9.1])

I have a large batch of message filters, to sort spam from real mail, and to
sort "work" mail from various other sorts.   All have worked fine since forever.

I just upgraded to 1.1.0, and have had two cases of "mail filter crash".  Not
sure where that should be reported, so please feel free to move it if this isn't
the right place.

Usually when I've not been at the PC for a while, when I return the screen has a
message saying;

The messages could not be filtered to folder 'Inbox' because another operation
is in progress.

Never seen that before 1.1.0 so I assume it's something in there.

It seems to give my ISP's server serious bellyache - I have to log off, shut
down the computer, restart, and wait 30 minutes before trying to download mail
again.  That may, of course, be pure coincidence - or even the cause of the
problem - but nothing else has changed in several months, and this has happened
twice in six days since changing to 1.1.0
Just had it happen again, and this time the ISP's mail server worked fine
immediately afterwards.   So no effect on the ISP.   Seems to be purely internal
Mozilla.
Assignee: asa → naving
Component: Browser-General → Filters
Product: Browser → MailNews
QA Contact: asa → laurel
browser!= Mailnews
Just updated to Moz 1.2 beta, and it still does this.
Keith Jillings: is this bug still an issue for you?  Have you tried a more 
current build of Mozilla, such as 1.3 or 1.4b?

If so, do you have any additional information?
I'm now using 1.4a.   It still does the "can't filter because another
operation..." occasionally, but hasn't caused any lasting problems.   It just
leaves mail in the original account mailboxes, unfiltered.   I've got used to
scrolling up and down to check.

Strangely, it now sometimes doesn't show "new mail" in the count for "subsidiary
accounts" until I click on the account, when the numbers promptly update.   So I
scroll up and down, and click on the "Inbox" for each account.   
OK, basic problem still occurring.  Is this for an IMAP mail server (I'm 
guessing) or POP?  Do you actually have filter rules that are explicitly moving 
messages to your inbox?  (If so, why not just remove that filter?)

The problem with the Unread count not updating for "subsidiary" accounts was 
known, and fixed; getting 1.4RC1 or waiting for the final 1.4 release should 
address that problem.
It's with POP servers.   The "not displaying new mail" in the count for separate
accounts hasn't occurred since I loaded 1.4RC1.   The "cannot filter" still happens.

Yes, I'm filtering mail from separate accounts (with different ISPs) to one set
of inboxes, by subject or sender. 
I can confirm this bug because I've added a filter that triggers it; replicated 
with 1.5 Final, Win2K.

In this case, I have two POP accounts.  Sometimes I inadvertantly send a friend 
mail from my secondary account and get a reply to that account.  I wrote the 
filter to move that mail to my primary account's Inbox.  But if Get Messages for 
All Accounts is in progress, the primary account's Inbox is inaccessible, 
because mail is being fetched for it; so, the filter can't copy the message 
over.

This is very similar to bug 139215, where a filter fails to move messages into a 
folder that's being compacted.  But this can't be solved by the same proposed 
solution there -- which is to defer fetching mail until all compactions are 
complete.  It could be solved by forcing fetches from different accounts to be 
sequential rather than parallel.  Alternately, it could be solved by some form 
of queuing up messages to be moved if the target folder is busy -- which would 
work for 139215 as well.

Updating summary
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cannot filter messages → Cannot filter messages to Inbox that is busy (fetching its own mail)
I believe theses two bugs may get a common fix:
They are two cases of the same issue: see bug 139215 comment 6.

Updating:
+(d.o.) bug 139215, for now. (I resist marking as duplicate)
Depends on: 139215
It's only a dupe if they get fixed by the same solution, and I'm not sure that 
will happen.
I find the same problems when filtering from a pop3 to an imap folder.

When fetching mail on the pop server, it either doesn't seem to execute the
filter at all (no warning, messages stay) or gives the 'another operation'
message for every mail that would be filtered.

I'm using 1.6 build "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040113".
Summary: Cannot filter messages to Inbox that is busy (fetching its own mail) → Cannot filter (move) messages to Inbox that is busy (fetching its own mail)
*** Bug 238861 has been marked as a duplicate of this bug. ***
*** Bug 187278 has been marked as a duplicate of this bug. ***
For an excellent example of how to recreate this bug behaviour. Look at bug
#210614 ! I have the same issue (Linux - Mozilla 1.7 AND Thunderbird 0.7.1).

Hope this gets fixed.
I see this bug twice a day when starting Thunderbird version 0.7+ (20040827). I
have one pop account which filters private messages into the inbox of another
pop account. I get the failure notice when both accounts have new mails which
are received simultaneously. At this moment no inbox is compacted. In that case
bug 139215 isn't releated for me. Messages are still laying in the second
accounts inbox - so no dataloss occured. 
*** Bug 235122 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
*** Bug 215349 has been marked as a duplicate of this bug. ***
I get this bug every time that I check my email (I always select "Get all new messages"). It stops all email downloading (which is annoying over dialup) until I acknowledge the message. Then I have to run the mail filters to move my email into it's proper place.

Not sure what product the original bug was filed under, but this occurs for me with Thunderbird 1.5.0.5. OS is Linux.

I believe this started happening for me when I added a new IMAP account.

I do not compact my folders.
Hello,

I experience the same problems with Seamonkey 1.1.4 on a Vista 32-bit box. I've got 5 IMAP mailboxes (on 3 different mailservers/providers) and 2 POP3 mailboxes at a fourth server/providers. When I try to move mails from one of these two POP3 boxes to my primary IMAP inbox SM seems to do nothing. When I move the same mail(s) to the Junk folder and not the inbox of my primary mailbox they are moved. I've also a filter for each of the two POP3 mailboxes which should move all mails to my primary mailboxes INBOX, this filter doesn`t to anything. If I try to run it by explicitly starting it, SM does not do anything (as far as I can see in the UI).
I`ve actived for all my mailboxed that they are fetched at startup and every 10 minutes for the IMAP mailboxes and every 30 minutes for the POP3 mailboxes.

For generating a log which only holds the nessary information I first disabled the auto fetch at startup and every x minutes for all accounts. After restarting SM with logging enabled everything worked fine, therefor I could move multiple mails from my POP3 mailboxes to the INBOX of my primary IMAP mailbox. My filter for moving all mails from the pop3 inboxes to the primary imap mailbox now works fine, too.

I had this problem in the past with older builds of SM, too. Usually I did some work around like trying to move directly after starting SM or after some great amount of time and this /sometimes/ worked, therefor no real workaround, but perhaps this with disabling auto fetch might work. For my confusion moving of mails from pop3 to imap now also works after enabling auto fetch again and restarting SM. Don`t know why, I`m tight of when the problem will reappear and will try to generate some logs then.
Hello,

I got a good hint from Bug 324777. I just increased the max cached connections setting in my pref.js to 10 (which is the number of accounts I have (7) plus some more space). Now everything works fine. Perhaps this will help others who have problems with moving mails from POP to IMAP boxes, like I had, too.
Assignee: naving → nobody
QA Contact: laurel → filters
Hello again,

I have to undo my last comment. The increase of max connection did not help.
I still have the same problem, that its very hard to move mails to my primary account (I assume its very often busy).

I had new related problem to this. I`ve a imap account which should move all mails from it to my primary mailbox. These messages cannot be moved (thats old) but now they are not displayed in the old mailbox as long as the filter is enabled. I only see the "fetching headers from mail x" in the status bar. If I disable the filter and fetch mail again, they are displayed. I assume this will be resolved as soon the major problem, that the mails can`t be moved is solved.
Product: Core → MailNews Core
is the key to the issue really bug 139215?  (which has no progress and less activity than this bug)

what I am actually interested in is progress for bug 324777 and the like.
Flags: wanted-thunderbird3?
Severity: normal → major
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.10pre) Gecko/20100413 SeaMonkey/2.0.5pre - Build ID: 20100413000559

I'm seeing this too, e.g. when marking an email as "Not junk" (which should move it out of Junk and back to Inbox, but gives an error instead if mail is currently being fetched). According to comment #18 I'm also not the only Linux user who sees it.
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [also mozilla-1.9.1]
Duplicate of this bug: 513919
Depends on: 288896
Duplicate of this bug: 528810
I have this problem not only with Junk folder but with any folder to which I use a filter to which I redirect mail on another account. I have 3 pop accounts at the same server. When TB 5.0 comes up and it tries to download messages from multiple accounts, some messages coming in to Account B or C are redirected by filters to the inbox or another folder on account A.

The fix would seem to download only one account at a time. Would 
network.http.max-connections-per-server set to 1 do this?
(In reply to John Pezzano from comment #26)

> The fix would seem to download only one account at a time. Would 
> network.http.max-connections-per-server set to 1 do this?

Not with http.
(In reply to Ludovic Hirlimann [:Usul] from comment #27)
> (In reply to John Pezzano from comment #26)
> 
> > The fix would seem to download only one account at a time. Would 
> > network.http.max-connections-per-server set to 1 do this?
> 
> Not with http.

Duh! What was I thinking? I just looked at the "max connections" w/o thinking "this is pop"!
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
Flags: wanted-thunderbird3?
I have filters to move received IMAP messages to the Local Folders.

Every time I have new messages on several accounts simultaneously (usually at start of the day), I'm getting this alert. The messages are received but not moved.

I have resigned to living with it (hey, 15-year-old bug) but it's really annoying.
Duplicate of this bug: 1428300
(In reply to vlakoff from comment #30)
> I have resigned to living with it (hey, 15-year-old bug) but it's really
> annoying.
Old bugs are typically hard to fix. The Thunderbird project is open source and is carried by volunteers. Nothing stops you to fix the bug yourself or hire someone to do it for you.
Duplicate of this bug: 1205525
Severity: major → normal
Blocks: 1534153
Depends on: 707933
You need to log in before you can comment on or make changes to this bug.