Closed Bug 1691576 Opened 10 months ago Closed 7 months ago

Fix and re-enable devtools/client/framework/test/browser_toolbox_window_title_changes.js test for Fission

Categories

(DevTools :: Framework, task, P3)

task

Tracking

(Fission Milestone:M7a, firefox90 fixed)

RESOLVED FIXED
90 Branch
Fission Milestone M7a
Tracking Status
firefox90 --- fixed

People

(Reporter: cpeterson, Assigned: nchevobbe)

References

(Blocks 2 open bugs)

Details

(Whiteboard: dt-fission-m3-mvp)

Attachments

(1 file, 2 obsolete files)

This test was disabled for Fission in bug 1566182.

https://searchfox.org/mozilla-central/rev/7067bbd8194f4346ec59d77c33cd88f06763e090/devtools/client/framework/test/browser.ini#153-154

[browser_toolbox_window_title_changes.js]
skip-if = fission
Blocks: 1644911
Blocks: 1566182
No longer blocks: 1644911
Blocks: 1601891
Fission Milestone: ? → M8
Whiteboard: dt-fission-triage → dt-fission-m3-mvp

The test is failing on fission because the devtools window title (when undocked), isn't updated when a target switch occurs.
We do update the title when we receive the navigate event for a given target (https://searchfox.org/mozilla-central/rev/7067bbd8194f4346ec59d77c33cd88f06763e090/devtools/client/framework/toolbox.js#701), but in the case of a target switch, we don't receive it, and as a result we don't change the title.

Note that we'll probably have to switch from the navigate event to listen for DOCUMENT_EVENT resource

Type: defect → task
Priority: -- → P3

Tracking DevTools Post-M8 bugs for Fission MVP milestone. They don't block the Fission Release channel experiment, but we would like them to be completed before we roll out Fission by default.

Fission Milestone: M8 → MVP
See Also: → 1704458
No longer blocks: fission-tests
Duplicate of this bug: 1707883

This helps fix browser_toolbox_window_title_changes.js

Nicolas, do not hesitate to fold this patch into yours. The test cleanup are valuable!
It is better to rely on DOCUMENT_EVENT instead of onTargetAvailable as the title won't always be already defined when the target just started loading.
And using DOCUMENT_EVENT also aligns well with the other patch I submitted to bug 1704458.

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Attachment #9202056 - Attachment description: Bug 1691576 - [devtools] Update devtools window title on target switch. → WIP: Bug 1691576 - [devtools] Update devtools window title on target switch.
Attachment #9202056 - Attachment description: WIP: Bug 1691576 - [devtools] Update devtools window title on target switch. → Bug 1691576 - [devtools] Update DevTools window title on DOCUMENT_EVENT resource. r=ochameau.
Attachment #9220812 - Attachment description: Bug 1691576 - Update targetFront url and title on DOCUMENT_EVENT resource. r=ochameau,jdescottes. → Bug 1691576 - [devtools] Update targetFront url and title on DOCUMENT_EVENT resource. r=ochameau,jdescottes.

Comment on attachment 9220812 [details]
Bug 1691576 - [devtools] Update targetFront url and title on DOCUMENT_EVENT resource. r=ochameau,jdescottes.

Revision D114601 was moved to bug 1704458. Setting attachment 9220812 [details] to obsolete.

Attachment #9220812 - Attachment is obsolete: true
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d4be8b7f7783
[devtools] Update DevTools window title on DOCUMENT_EVENT resource. r=ochameau.
Fission Milestone: MVP → M7a
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Attachment #9220550 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.