Closed Bug 1695292 Opened 9 months ago Closed 8 months ago

update tabstrip scroll buttons hover state to be consistent with Proton design

Categories

(Firefox :: Theme, enhancement, P3)

Firefox 88
enhancement
Points:
3

Tracking

()

VERIFIED FIXED
89 Branch
Iteration:
89.2 - Apr 5 - Apr 18
Tracking Status
firefox89 --- verified

People

(Reporter: billdillensrevenge, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: helpwanted, Whiteboard: [proton-tabs-bar])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

Hover cursor over tabstrip scroll buttons and observe it isn't consistent with the rest of tabstrip hover states design, it's too tall and the corners aren't rounded. See attached screenshot

The Bugbug bot thinks this bug should belong to the 'Firefox::Theme' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Theme
Component: Theme → Tabbed Browser
Whiteboard: [proton-tabs-bar]
Flags: needinfo?(kcaldwell)

From Katie, "like a ghost button - background square with rounded corners". The button should look similar to the New Tab and All Tabs buttons, which are tracked by bug 1696535.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kcaldwell)
Keywords: helpwanted
Severity: -- → S4
Priority: -- → P3

I'm going to update the spec in Figma because the the chevron-right should be not full square width on hover (like a ghost) but custom in width (...and with rounded corners). Jared, I'll comment at you in Figma to take a look... when it's mocked up and ready. :)

This is still waiting on a spec from UX.

Flags: needinfo?(kcaldwell)

please see Figma file and attached sreenshot.
Notes:
• Same buttons states as other ghost buttons
• Same corner radius

Flags: needinfo?(kcaldwell)
Points: --- → 3
Duplicate of this bug: 1698868

gentle reminder :)

Component: Tabbed Browser → Theme
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 89.2 - Apr 5 - Apr 18
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/48c2e15e0472
update tabstrip scroll buttons hover state to be consistent with Proton design. r=jaws

Backed out 2 changesets (Bug 1695292, Bug 1696438) for causing xpcshell failures in test_trr_cancel.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/20cda15a5e4a486d289a4fcfc5ab0997789fd48c
Push with failures, failure log.

Flags: needinfo?(dao+bmo)
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/494b00f94236
update tabstrip scroll buttons hover state to be consistent with Proton design. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Blocks: 1703500

Verified as fixed on Firefox Nightly 89.0a1 (2021-04-15) on Windows 10 x64, Ubuntu 20.04 x64 and on macOS 10.15.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.