Closed Bug 1700957 Opened 6 months ago Closed 4 months ago

Graduate the panels to the main proton pref

Categories

(Firefox :: Messaging System, task, P3)

task

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mconley, Assigned: emalysz)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [proton-door-hangers])

Attachments

(1 obsolete file)

Once bug 1700105, this should be a relatively mechanical find/replace of browser.proton.doorhangers.enabled to browser.proton.enabled.

Once the remaining P1's are closed, is it okay to graduate, or are there other blocking issues before we graduate behind browser.proton.enabled?

Flags: needinfo?(rtestard)

Actually, going to redirect that needinfo to tduzan who's been running point on many panels for Product.

Flags: needinfo?(tduzan)

Just a quick update on this, I am working my way through reviews of the current state of the experience across several platforms. I expect to have a clear answer on this soon. I will ping mconley in Slack with any questions.

Flags: needinfo?(rtestard)
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Attachment #9212261 - Attachment description: WIP: Bug 1700957, graduate browser.proton.doorhangers.enabled pref to main proton pref → Bug 1700957, graduate browser.proton.doorhangers.enabled pref to main proton pref
Depends on: 1703149
Depends on: 1703014
No longer depends on: 1703014
Depends on: 1700101
Depends on: 1703014
Depends on: 1703012
Depends on: 1703635
Depends on: 1703476
Depends on: 1696500
Depends on: 1700941
Depends on: 1701057

Hey tduzan, since the Proton panels are enabled by default in Nightly, can I presume this bug no longer needs to be P1? "Graduation" at this point is kind of meaningless, at least from an engineering point of view. I suggest downgrading this to a P3.

Flags: needinfo?(tduzan)
Priority: P1 → P3

I believe that we could graduate this subpref at this point, as well. The issues that previously prevented that have been resolved.

Flags: needinfo?(mconley)

True, this can be done, though I don't think it's critical at this point given that the preference is on by default. I think the P3 priority makes sense.

Flags: needinfo?(mconley)
Attachment #9212261 - Attachment description: Bug 1700957, graduate browser.proton.doorhangers.enabled pref to main proton pref → WIP: Bug 1700957, graduate browser.proton.doorhangers.enabled pref to main proton pref
Attachment #9212261 - Attachment description: WIP: Bug 1700957, graduate browser.proton.doorhangers.enabled pref to main proton pref → Bug 1700957, graduate browser.proton.doorhangers.enabled pref to main proton pref
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1c362512f27b
graduate browser.proton.doorhangers.enabled pref to main proton pref r=mconley
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e01ec8694924
graduate browser.proton.doorhangers.enabled pref to main proton pref r=mconley
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Blocks: 1708161

There are still several references to browser.proton.doorhangers.enabled:
https://searchfox.org/mozilla-central/search?q=browser.proton.doorhangers.enabled&case=true&path=

(In reply to Sören Hentzschel from comment #12)

There are still several references to browser.proton.doorhangers.enabled:
https://searchfox.org/mozilla-central/search?q=browser.proton.doorhangers.enabled&case=true&path=

searchfox is just slow to update - compare that list with the patch linked in comment #11

I didn't check all files but at least StaticPrefList.yaml was not touched at all in the patch and you can also check in about:config that browser.proton.doorhangers.enabled still exists (the patch should be included in the tested Nightly build since setting browser.proton.doorhangers.enabled to false no longer adds the arrow to the panels).

All files have removed browser.proton.doorhangers.enabled other than StaticPrefList.yaml. I will create a follow up bug for that and the typo Emilio pointed out in https://phabricator.services.mozilla.com/D110135#3688994

Flags: needinfo?(emalysz)
Regressions: 1708207

Hey folks,

I've requested the sheriffs to back this out for a few reasons:

  1. It looks like there's still a bit left to do (see comment 14)
  2. This is lower priority cleanup work that spans a lot of files which might make crafting upliftable patches more difficult, unless this patch gets uplifted (which it probably shouldn't).

It's even unclear if we need to do this work at this point - the panels have effectively graduated by being enabled. It'll probably just be easier to remove all of the branching when we decide to stop supporting the non-Proton variant.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Regressions: 1708217
Backout by malexandru@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/1005c275ed0f
Backed out changeset e01ec8694924 as requested. CLOSED TREE
Target Milestone: 90 Branch → ---

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:emalysz, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mconley)
Flags: needinfo?(emalysz)

Given the timeline, plus given bug 1709425 (which aims to remove all of the branching anyways), I think we can WONTFIX this.

Status: REOPENED → RESOLVED
Closed: 5 months ago4 months ago
Flags: needinfo?(mconley)
Flags: needinfo?(emalysz)
Resolution: --- → WONTFIX
Attachment #9212261 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.