Closed Bug 1703874 Opened 2 months ago Closed 2 months ago

Nudge Existing Users to Set as Default Using Infobar

Categories

(Firefox :: Messaging System, enhancement, P1)

All
Unspecified
enhancement

Tracking

()

RESOLVED FIXED
89 Branch
Iteration:
89.2 - Apr 5 - Apr 18

People

(Reporter: alex, Assigned: andreio)

References

Details

We recently ran an experiment to test out using an infobar to ask users to set Firefox as default. We felt it was a less invasive way to ask than the existing modal prompt. Unfortunately, it did not perform anywhere near as well as our existing modal prompt displayed as of first startup and until permanently dismissed but we agreed that the infobar can still play an important role at reaching out to our existing users in a respectful way.

Spec:

  • Display a similar infobar as the one from our past experiment (https://jira.mozilla.com/browse/UJET-66)
  • Display the infobar every 5 weeks to existing users if they have not set Firefox as default yet.
  • Do a 1-click on Win 10 at the same time as setting to default
  • Only display to users who dismissed the modal prompt
  • Avoid collision with existing user onboarding (MR1)
  • Display on content pages (though initially it may be easier on New Tab to start)

Strings
Body[1]: Make Firefox your primary browser? Put Protection, privacy and speed on autopilot.
Button[2]: Make Firefox my primary browser

This is a minimal change to the body. The button is to align with other touchpoints that will be using this language.

[1] There's only one change vs our experiment copy. Replace default with primary.
[2] Instead of set as default.

Why 5 weeks?

  • It's often enough that it may have impact on browser usage.
  • It's not often enough that it will annoy users.

Following discussions with Andrei:
Getting something out quickly is really important. If it is easier and more importantly faster, this work can be split into parts:
1- Deploying the existing infobar with set to default and pin functionality and existing strings at a frequency of 5 week intervals
2- And then, change the strings and display on content pages. (not just new tab)

Assignee: nobody → andrei.br92

This is an offtrain change going to be deployed in release Fx87

Severity: -- → S3
Iteration: --- → 89.2 - Apr 5 - Apr 18
Priority: -- → P1
Depends on: 1705191

I hope this is either a bug, or misunderstanding: this apparent change does not respect the Always check if Firefox is your default browser setting.

If this is intentional, people who use Firefox for a reason will be nudged to abandon it for software that doesn't act like it knows better than the (power) user.

See Also: → 1690518

This should be turned off for linux and limit profileAge to 5 weeks before displaying infobar. This will be offtrain change by updating targeting in RS prod

(In reply to giydifirdi from comment #2)

I hope this is either a bug, or misunderstanding: this apparent change does not respect the "Always check if Firefox is your default browser" setting.

We absolutely continue to respect that check box. We won't always check at startup if Firefox is your default browser. When that box is left checked, you get a modal/prompt at every single startup. It literally always checks if Firefox is your default.

In contrast, the work resulting from this bug is just checking every 5 weeks and we happen to not be default, we'll ask with a more gentle infobar. We won't display the more disruptive modal/prompt.

Additional context: Our research over the years has shown that users often want to try Firefox before setting it as default. It makes sense to want to try before committing. They also want to dismiss that modal/prompt so that it doesn't always show up at startup while they are trying Firefox (with good reason). We've judged that re-asking every 5 weeks is an appropriate reminder interval. Based on feedback, we might make adjustments but we're starting here.

I hope this clarifies.

Yes, it makes sense literally, but in practice, IMO a reasonable user would expect this setting to suppress any prompts like this (as is probably the case in other browsers - maybe you already checked).

To put things into perspective, the message bar is one more layer to the (unfortunate but actual) state of the web filled with consent popups and cookie warnings. Some conversion numbers may go up, but at the cost of brand reputation - and I'd be curious if you measure that (think ordering employees to nag customers to buy more, and measuring how much money is spent, but not how many customers will avoid that shop in the future).

You may as well unilaterally determine that search engine X is better for privacy, speed, etc. and argue that asking users every 5 weeks is rare enough to not be a big deal. It's worth noting there's only one default browser on a system, so the current behavior is more aggressive (and the OS may show choice prompts before opening links on its own).

If you really believe people will think no, but thank you for asking with appreciation when dismissing the tenth modal/prompt/infobar (regardless which layer it belongs to), I suggest at least adding an about:config flag to easily disable this.

See Also: → 1681130

Just bringing this over from Slack so it's part of this ticket, glad this got figured out.

On April 16, when I started up Firefox 87 (stable) on my Ubuntu laptop, it popped up a prompt asking if I want to set Firefox as my default browser. Firefox is already my default browser.

Ubuntu updates Firefox as an OS package (instead of Firefox updating itself) and I've not gotten an update for Firefox since March (so I don't think this was caused by a new version of Firefox).

It sounds like this experiment doesn't work well with Linux and is now disabled for Linux

It's not often enough that it will annoy users.

Is there any evidence to support this claim?

For me, the first request will be annoying and subsequent requests will be even more annoying. For those that use firefox rarely, for testing etc, this "every 5 weeks" could effectively become "every time the user starts firefox".

How can one vote against this "enhancement"?

Anyone who uses multiple browsers on their computer either has Firefox as their default, or doesn't, and declines to do so for a reason. There's no reason to make the experience more annoying. Don't do this.

This just appeared for me in Firefox Developer Edition 89.0b6 (64-bit) on macOS 10.14.6 (18G8022). There are no updates showing as available, so I'm not sure if the "RESOLVED FIXED" status means I shouldn't be seeing it in this version or not. But to address the "it's not often enough that it will annoy users" comment — I'm a user, and I'm beyond annoyed, I'm angry:

"Always check if Firefox Developer Edition is your default browser" is set to OFF. Apparently that just means "sometimes check" rather than "never check".

Firefox is not my default browser — Choosy is, which routes URL open requests to the correct browser depending on a set of rules. This is my choice.

Whether Firefox is the default browser or not is my business, not Firefox's business.

Once I have set the check to "off", Firefox should prompt me to set it as the default browser precisely zero more times from then on. The infobar doesn't even have the decency to have a "never ask this again" button. There doesn't even seem to be a setting in about:config to change this.

I have made my choice.

Firefox should respect my choice.

Firefox should respect my time.

Firefox should respect me.

If I say "no" — **that means "no". **Permanently. Not "nag me again every five weeks" — "no" until I say otherwise.

I dropped Google as a search engine because it kept nagging me to install Chrome. I'm quite happy to drop Firefox as a browser if it would rather prioritise its metrics over me, the user.

Firefox is a guest on my machine, and it's here at my invitation. It doesn't get to rearrange my settings to suit itself, and it doesn't get to keep hassling me to do so. It gets to sit down, shut up, and browse the web. That's all. If it wants to turn into nagware — I can switch to Vivaldi.

In short — please either:

  • change the existing setting so that turning it off means "never check",
  • change it to a three-way setting: "always", "periodically", and "never",
  • when the user dismisses the initial modal, ask them if they are OK with being reminded in five weeks time — and then fully respect an answer of "no",
  • add a separate setting to disable this prompt bar, with a button to do so in the prompt bar, next to the existing preferences and not buried under browser.bewareOfTheLeopard in about: config, or
  • just remove the prompt bar altogether and show a bit of respect for users

But I will not put up with being nagged by software running on my machine.

See Also: → 1709115

Message definition was updated to not show to user profiles >= 15 weeks and additionally you can turn it off if you flip uncheck the Recommend features as you browser option in Preferences.

That setting doesn't seem to have worked properly, as I have had it turned off right from the start — unless you meant that the check had just been added, of course.

But it's good to know the 15 week limit is in there now. That seems a good balance, although I'd still prefer the initial prompt to be a choice between "always check", "check periodically" (what this seems to be trying to do) and "never check or remind me about it".

See Also: → 1699852
You need to log in before you can comment on or make changes to this bug.