Closed Bug 1705447 Opened 4 months ago Closed 4 months ago

Various menu buttons use system accent color, not theme color

Categories

(Firefox :: Messaging System, defect, P2)

defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: jheavener, Assigned: jaws)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [foxfooding][internal] [proton-foxfooding] [priority:2a] [proton-door-hangers])

Attachments

(3 files)

steps to reproduce/what did you do?

  • Attempt to install an Extension or Theme, the menu to confirm the installation displays an Add button
  • Open the Bookmark browser action , the menu to save the bookmark displays a Save button

expected behavior/ what did you think will happen?

  • Confirmation button uses browser theme color

actual behavior/ what actually happened?

  • Confirmation button uses system accent color
Whiteboard: [foxfooding]
Priority: -- → P2
Whiteboard: [foxfooding] → [foxfooding] [proton-modals] [priority:2a] [proton-door-hangers]]

This is a macOS issue, Jared, is that a theming problem where we should draw over the system color?

Flags: needinfo?(jaws)
See Also: → 1704817

None of the examples here are modals, this should be tracked under panels/d---hangers.

Blocks: proton-door-hangers
No longer blocks: proton-modals
Whiteboard: [foxfooding] [proton-modals] [priority:2a] [proton-door-hangers]] → [foxfooding] [priority:2a] [proton-door-hangers]]
Whiteboard: [foxfooding] [priority:2a] [proton-door-hangers]] → [foxfooding] [priority:2a] [proton-door-hangers]
Keywords: regression
Regressed by: 1697947
Type: enhancement → defect
Component: Foxfooding → Messaging System
Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
No longer blocks: 1705792
See Also: → 1705792
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90b1d5c24595
Set button primary colors in the default-dark and dark themes. r=desktop-theme-reviewers,harry
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Duplicate of this bug: 1703007
Whiteboard: [foxfooding] [priority:2a] [proton-door-hangers] → [foxfooding][internal] [proton-foxfooding] [priority:2a] [proton-door-hangers]
Flags: qe-verify+

Verified the fix using Firefox 89.0b4 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.15. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.