Closed Bug 1728430 Opened 3 months ago Closed 3 months ago

Updates to the preferences UI for Firefox Suggest

Categories

(Firefox :: Address Bar, task, P1)

task
Points:
3

Tracking

()

VERIFIED FIXED
94 Branch
Iteration:
93.2 - Aug 23 - Sep 5
Tracking Status
firefox92 --- verified
firefox93 --- verified
firefox94 --- verified

People

(Reporter: adw, Assigned: adw)

References

(Blocks 1 open bug, )

Details

Attachments

(8 files)

[Tracking Requested - why for this release]: This is required for the Firefox Suggest feature on 92.

The Jira ticket (link in the bug) calls for two separate checkboxes for Firefox
Suggest results: a main checkbox plus a sponsored-suggestions checkbox. The
sponsored-suggestions checkbox is subordinate to the main checkbox, i.e., the
main checkbox has to be checked to turn on sponsored suggestions. This will
allow users to toggle sponsored suggestions separately from non-sponsored
suggestions. It's a change from the current situation where we have only one
pref and checkbox that control both sponsored and non-sponsored suggestions.

So part 1 of fixing this bug is to add a new pref for sponsored suggestions.
This revision keeps the current suggest.quicksuggest pref as the main pref and
adds a new suggest.quicksuggest.sponsored pref. I confirmed with Natalie that
we want to enable both prefs when the user opts in through the onboarding
dialog.

We currently record a telemetry event when suggest.quicksuggest is toggled. We
also want a similar event for the new pref, so this adds one.

The pref situation for Firefox Suggest is confusing but in summary:

  • browser.urlbar.quicksuggest.enabled: The global toggle for the entire
    Firefox Suggest rollout involving sponsored and non-sponsored suggestions, the
    related telemetry and preferences UI, etc. This pref can be overridden by the
    quickSuggestEnabled Nimbus variable. If false, neither sponsored nor
    non-sponsored suggestions will be shown. If true, then we look at the
    individual suggest.quicksuggest and suggest.quicksuggest.sponsored prefs.
  • browser.urlbar.suggest.quicksuggest: Whether any Firefox Suggest results are
    shown. This must be true to show both non-sponsored and sponsored results.
  • browser.urlbar.suggest.quicksuggest.sponsored: Whether sponsored Firefox
    Suggest results are shown. Both this pref and suggest.quicksuggest must be
    true to show sponsored results.
Attached file request.md
Attachment #9239098 - Flags: data-review?(teon)

This implements the spec in https://mozilla-hub.atlassian.net/browse/SNT-26, but
Natalie and I have made some tweaks over Slack that aren't reflected in that
ticket.

We want to move the Firefox Suggest preferences from the Search pane to the
Address Bar section of the Privacy pane. There are now two Firefox Suggest
checkboxes instead of one: a main one that enables Firefox Suggest suggestions
and another one that enables sponsored suggestions separately. If the main one
is checked but the sponsored one isn't, then the user will see only
non-sponsored suggestions.

I renamed and modified the browser_searchQuickSuggest.js test I added in
D105701, but a lot of the test changed and it's probably not helpful to look at
the diff against the old version.

Previously strings were hardcoded in search.js. I've added the new ones to the
new preview Fluent file for Firefox Suggest.

Depends on D124300

something to note: we should file a data engineering bug to get these preferences adding both to clients_daily and to urlbar_clients_daily as they will not appear there once this ticket is landed.

Comment on attachment 9239098 [details]
request.md

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is Telemetry so is documented in its definitions file Events.yaml and the Probe Dictionary.

Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, :adw is responsible.

Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, Interaction.

Is the data collection request for default-on or default-off?

Default on for all channels.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does there need to be a check-in in the future to determine whether to renew the data?

No. This collection is permanent.


Result: datareview+

Attachment #9239098 - Flags: data-review?(teon) → data-review+
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7477b503e4d0
Part 1: Add a separate pref for sponsored Firefox Suggest results. r=mak
https://hg.mozilla.org/integration/autoland/rev/04e64eeedc05
Part 2: Update the Firefox Suggest preferences UI. r=mak
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: qe-verify+
Flags: in-testsuite+
Attached image screenshot

STR for QA

  1. Set browser.urlbar.quicksuggest.enabled = true
  2. Set browser.urlbar.quicksuggest.shouldShowOnboardingDialog = false
  3. Open about:preferences#privacy and verify that the address bar section looks like the attached screenshot
  4. Click the "Learn more" link and verify that https://support.mozilla.org/en-US/kb/navigate-web-faster-firefox-suggest?as=u&utm_source=inproduct loads (your URL may be slightly different, I'm not sure, but the page title is "Navigate the Web faster with Firefox Suggest")
  5. Restart [Please skip this step if you're testing a build with all fixes per comment 20; do not restart]
  6. In the address bar, type "ebay" and verify that no sponsored Firefox Suggest result appears in the address bar panel
  7. Type "wikipedia" and verify that no non-sponsored Firefox Suggest result appears in the address bar panel (i.e., there's no result with a help button; you should see only search suggestions on a new profile)
  8. In about:preferences#privacy, click the "Personalized search suggestions" checkbox
  9. Restart [Please skip this step if you're testing a build with all fixes per comment 20; do not restart]
  10. Type "ebay" and verify that no sponsored Firefox Suggest result appears in the address bar panel
  11. Type "wikipedia" and verify that a Wikipedia non-sponsored Firefox Suggest result appears in the address bar panel (it should have a help button and appear last in the panel)
  12. In about:preferences#privacy, click the "Show sponsored suggestions" checkbox
  13. Type "ebay" and verify that an eBay sponsored Firefox Suggest result appears in the address bar panel (it should have a help button and appear last in the panel)
  14. Type "wikipedia" and verify that a Wikipedia non-sponsored Firefox Suggest result appears in the address bar panel
  15. Click the "Personalized search suggestions" checkbox again, verify that the "Show sponsored suggestions" checkbox becomes disabled and unchecked
  16. Type "ebay" and "wikipedia" and verify that the sponsored/non-sponsored Firefox Suggest results do not appear
  17. Open about:telemetry#events-tab and verify the following events appear:
    a. category=contextservices.quicksuggest method=enable_toggled object=enabled
    b. category=contextservices.quicksuggest method=sponsored_toggled object=enabled
    c. category=contextservices.quicksuggest method=enable_toggled object=disabled
  18. Set browser.urlbar.quicksuggest.enabled = false
  19. Refresh/re-open about:preferences#privacy and verify that the address bar section goes back to normal (the two checkboxes should not appear)
Blocks: 1729587
  • I have verified this issue using the latest Nightly 94.0a1 build (Build ID: 20210907214756) on Windows 10 x64, macOS 11.4, and Ubuntu 20.04 x64.
  • The "Personalized search suggestions" and "Show sponsored suggestions" checkboxes from the "about:preferences" page work as expected, displaying the correct suggestions if selected, as stated in comment 12. When the checkboxes are not selected, the default behavior is displayed, without any suggestion results in the Address Bar.
  • The "Personalized search suggestions" and "Show sponsored suggestions" checkboxes from the "about:preferences" page are no longer displayed after switching the browser.urlbar.quicksuggest.enabled preference to false.
Status: RESOLVED → VERIFIED
Depends on: 1727907

Approval Request Comment
[Feature/Bug causing the regression]: Firefox Suggest offline/online rollouts
[User impact if declined]: Needed for important rollouts on 93 and 92
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]:
[List of other uplifts needed for the feature/fix]: See uplift coordination spreadsheet
[Is the change risky?]: Low risk relative to other uplifts needed in the patch stack
[Why is the change risky/not risky?]: This particular patch affects only the Firefox Suggest feature
[String changes made/needed]:

Attachment #9240388 - Flags: approval-mozilla-beta?

Approval Request Comment
[Feature/Bug causing the regression]: Firefox Suggest offline/online rollouts
[User impact if declined]: Needed for important rollouts on 93 and 92
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]:
[List of other uplifts needed for the feature/fix]: See uplift coordination spreadsheet
[Is the change risky?]: Moderate risk relative to other uplifts needed in the patch stack
[Why is the change risky/not risky?]: This particular patch affects the preferences UI, but no changes to the UI are visible when Firefox Suggest is not enabled. Has automated test and QA coverage.
[String changes made/needed]:

Attachment #9240389 - Flags: approval-mozilla-beta?

Comment on attachment 9240388 [details] [diff] [review]
Part 1 patch for 93

Needed for experiments targeting Fx92. Approved for 93.0b3.

Attachment #9240388 - Attachment is patch: true
Attachment #9240388 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9240389 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Moving tracking the metabug for this work.

  • I have verified this issue using the Beta 93.0b3 build (Build ID: 20210909185859) on Windows 10 x64, macOS 11.5.1, and Ubuntu 20.04 x64.
  • The "Personalized search suggestions" and "Show sponsored suggestions" checkboxes from the "about:preferences" page work as expected, displaying the correct suggestions if selected, as stated in comment 12. When the checkboxes are not selected, the default behavior is displayed, without any suggestion results in the Address Bar.
  • The "Personalized search suggestions" and "Show sponsored suggestions" checkboxes from the "about:preferences" page are no longer displayed after switching the browser.urlbar.quicksuggest.enabled preference to false.

Carmen, in the remaining verification work, please note that the fix for bug 1729587 changed this UI slightly. So when you're testing final builds with all the fixes in them, you should see what the offline screenshot in bug 1729587 shows, not what the one here shows. (Might be obvious but just want to make sure!)

As for the STR, they are basically the same as in comment 12, so please follow them. However, please note the two changes listed below. To reiterate, this applies when you're testing builds with all the fixes.

  • If you are testing with the US region and an en locale, then the offline scenario will be enabled by default. So please set the following prefs, restart, and follow the STR starting from step 3:
browser.urlbar.suggest.quicksuggest=false
browser.urlbar.suggest.quicksuggest.sponsored=false

If you are testing with a non-US region or non-en locale, then the offline scenario is not enabled by default and you can follow the STR starting from step 1. I'm not sure how your region testing works, but I added some info in bug 1729776 comment 3 for switching regions if you need it.

  • Regardless of region and locale, please skip the Restart steps in the STR (steps 5 and 9). I've update the STR to mention this.

Approval Request Comment
[Feature/Bug causing the regression]: Firefox Suggest offline/online rollouts
[User impact if declined]: Needed for important rollouts on 93 and 92
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Please verify part 1 and part 2 together, no need to verify them separately. Please see comment 12 and comment 20 for STR
[List of other uplifts needed for the feature/fix]: See uplift coordination spreadsheet
[Is the change risky?]: Low risk relative to other uplifts needed in the patch stack
[Why is the change risky/not risky?]: This patch adds a new pref that controls sponsored Firefox Suggest suggestions. No visible changes, comes with tests.
[String changes made/needed]:

Attachment #9240789 - Flags: approval-mozilla-release?

Approval Request Comment
[Feature/Bug causing the regression]: Firefox Suggest offline/online rollouts
[User impact if declined]: Needed for important rollouts on 93 and 92
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Please verify part 1 and part 2 together, no need to verify them separately. Please see comment 12 and comment 20 for STR
[List of other uplifts needed for the feature/fix]: See uplift coordination spreadsheet
[Is the change risky?]: Low risk relative to other uplifts needed in the patch stack
[Why is the change risky/not risky?]: This patch adds two checkboxes to the prefs UI. Comes with tests.
[String changes made/needed]:

Attachment #9240790 - Flags: approval-mozilla-release?
QA Whiteboard: [qa-triaged]
Depends on: 1730580

Comment on attachment 9240789 [details] [diff] [review]
92/mozilla-release part 1 patch

Approved for 92.0.1.

Attachment #9240789 - Flags: approval-mozilla-release? → approval-mozilla-release+
Attachment #9240790 - Flags: approval-mozilla-release? → approval-mozilla-release+
  • I have verified this issue using the Candidate 92.0.1 build (Build ID: 20210920202613) on Windows 10 x64, macOS 10.15.7 and Linux Ubuntu 20.04 x64.

  • After enabling the Offline scenario by setting the browser.search.region to US, I have verified that the new UI from bug 1729587 is displayed in the about:preferences#privacy page.

  • I have verified that the Contextual suggestions and Include occasional sponsored suggestions checkboxes work as expected, displaying the correct suggestions if selected, as stated in comment 12. When the checkboxes are not selected, the default behavior is displayed, without any suggestion results in the Address Bar.

  • I have verified that the following events appear:
    a. category=contextservices.quicksuggest method=enable_toggled object=enabled
    b. category=contextservices.quicksuggest method=sponsored_toggled object=enabled
    c. category=contextservices.quicksuggest method=enable_toggled object=disabled

  • The Firefox Suggest checkboxes from the "about:preferences#privacy" page are no longer displayed after switching the browser.urlbar.quicksuggest.enabled preference to false.

Flags: qe-verify+
See Also: → 1730886
You need to log in before you can comment on or make changes to this bug.