Closed Bug 1730692 Opened 1 year ago Closed 10 months ago

The Firefox Suggest onboarding dialog/modal is cut off when a larger system font size is set while the dialog is open

Categories

(Firefox :: Address Bar, defect, P3)

Desktop
Windows
defect
Points:
3

Tracking

()

VERIFIED FIXED
96 Branch
Tracking Status
firefox93 --- wontfix
firefox94 --- wontfix
firefox95 --- wontfix
firefox96 --- verified

People

(Reporter: mheres, Assigned: daisuke)

References

Details

(Keywords: access, Whiteboard: [access-s2])

Attachments

(2 files)

Attached image larger system text.gif

[Affected Versions]:

  • Firefox Beta 93.0b4 (Build ID: 20210912185727)
  • Firefox Nightly 94.0a1 (Build ID: 20210913213224)

[Affected Platforms]:

  • Windows 10

[Prerequisites]:

  • Have Firefox installed and opened.
  • Have the following preferences set:
    • browser.urlbar.quicksuggest.enabled = true
  • browser.urlbar.quicksuggest.scenario = online
  • browser.urlbar.quicksuggest.shouldShowOnboardingDialog = true
  • browser.urlbar.suggest.quicksuggest = false
  • browser.urlbar.suggest.quicksuggest.sponsored = false

[Steps to reproduce]:

  1. Restart the browser after setting prerequisite preferences.
  2. Dismiss the Make Firefox default message if it is displayed to trigger the Suggestions modal.
  3. Open System Settings > Ease of Access > Display.
  4. Set the “Make text bigger” slider to a larger value (e.g. 135% ).
  5. Observe the modal.

[Expected result]:

  • The text and buttons of the modal are still readable/clickable with a larger system text.

[Actual result]:

  • The text and buttons are cut off when a larger system text is set and are unreachable.

[Notes]:

  • The issue does not seem reproducible for the accessibility options of the tested Linux Mint and macOS devices (“Scale” and “Large text”).
  • Attached is a screen recording of the issue.

Dao, do you have time to look at this? Of the three onboarding bugs QA filed today (bug 1730702, bug 1730691, this one), this seems like the worst one. Can the dialog grow with the text and/or scroll? Or maybe just force a fixed text size for now.

Flags: needinfo?(dao+bmo)
Component: Disability Access → Address Bar
Keywords: access
Whiteboard: [access-s2]
Group: mozilla-employee-confidential
Points: --- → 3
Priority: -- → P1

Do you see the same issue when changing display settings before the modal comes up? Changing settings while the modal is open seems like an edge case.

Flags: needinfo?(dao+bmo) → needinfo?(mheres)

I checked and it seems that the modal is correctly displayed if the setting is changed before it is triggered. The buttons are accessible.

Severity: S3 → S4
Flags: needinfo?(mheres)

Great question. In that case, I think it's safe to say this doesn't need to block the offline/online rollouts. Might even be a wontfix, but ideally it would be fixed I guess.

No longer blocks: fx-suggest-93, fx-suggest-92
Priority: P1 → P3
Summary: The Firefox Suggest modal is cut off when a larger system font size is set → The Firefox Suggest onboarding dialog/modal is cut off when a larger system font size is set while the dialog is open
Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Flags: qe-verify+
Flags: in-testsuite-
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3fa76d9dc3dd
Make dialog be appropriate size when the system font size changes on windows. r=adw
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

No need to fix this on 95, marking wontfix

I have verified that the issue is no longer reproducible. All the text and buttons of the modal are now visible if the user changes the text settings to a larger size while the prompt is displayed. Tested using Firefox Nightly 96.0a1 (Build ID: 20211201214955) on Windows 10.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.