Closed Bug 1732358 Opened 1 year ago Closed 10 months ago

Enable Fission pref by default in Firefox 97

Categories

(Core :: DOM: Content Processes, task, P2)

task

Tracking

()

RESOLVED FIXED
97 Branch
Tracking Status
firefox-esr78 --- wontfix
firefox-esr91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- wontfix
firefox95 --- wontfix
firefox96 --- wontfix
firefox97 --- fixed

People

(Reporter: cpeterson, Assigned: nika)

References

(Blocks 1 open bug, Regressed 6 open bugs, )

Details

(Whiteboard: [fission:m96] [fission:m97])

Attachments

(5 files)

The Fission rollout will enroll Firefox 94 and 95 users. We will pref on Fission by default in Firefox 96.

The rollout sets the fission.experiment.enrollmentStatus pref = 4. This bug needs to:

  1. Set the default pref fission.autostart = true.
  2. Remove the now-unneeded experiment prefs fission.experiment.enrollmentStatus and fission.experiment.startupEnrollmentStatus and supporting code.
  3. Remove Fission from the Settings' Nightly Experiments: about:preferences#experimental. This was added in https://hg.mozilla.org/mozilla-central/rev/b6766d19d621 by bug 1652134.
  4. Add our rollout slug (bug-1732206-rollout-fission-release-rollout-release-94-95) to this list of graduated rollouts (GRADUATION_SET) here (because we're using different prefs for the rollout and enabling by default):

https://searchfox.org/mozilla-central/rev/f62d42b1d98e67dc3da05d586f71103df02b8c4a/toolkit/components/normandy/lib/PreferenceRollouts.jsm#128-137

The rollout slug will need to stay in the graduation set forever. If a user gets enrolled in the rollout in Firefox 95, stops using it for a while, and then starts using the browser again in a version > 96, then we want to make sure that the Normandy instruction to graduate from the rollout is still present in versions > 96.

See Also: → 1652134

Hsin-Yi and I realized this will need to block on bug 1736859. It's on Releng's expedite track and we're hoping to have it done before the 96 merge day.

Blocks: 1742869
Depends on: 1743714

The current plan is to enable the fission.autostart pref early in the Nightly 97 cycle.

I'm tentatively assigning this bug to Nika to give her the honor of flipping the pref. :)

Assignee: nobody → nika
Summary: Enable Fission pref by default in Firefox 96 → Enable Fission pref by default in Firefox 97
No longer depends on: 1743714

Unfortunately we currently always configure the "fission.autostart" pref when
running tests, meaning that the test_fission_autostart.py test is always being
skipped on all platforms. This change force-disables the required pref when
running the test, rather than skipping the test if it is set.

It would be nice to handle this in a less hacky way, but this was the first way
I could think of.

This is required to replace the existing MOZ_FORCE_ENABLE_FISSION environment
variables in environments which use that. In the future we'll want to stop
passing any environment variable when not passing a flag to ./mach run
however that will require changes to the default test behaviour in bug 1744091.

Depends on D133005

Fission will be enabled by default in the next part, and no longer needs to be
listed as an experimental feature.

Depends on D133006

This requires changing the behaviour of test_fission_autostart.js to handle the
new default value.

Depends on D133007

Fission Milestone: Future → ---
Whiteboard: [fission:m96] → [fission:m96] [fission:m97]
See Also: → 1744581

Nika, you also need to add the Fission Release rollout slug to Normandy's graduation set. Ask r=mythmon for code review. Later we will need to add the Fission Beta 96 rollout slug (bug 1745237) to the graduation set.

  1. Add our rollout slug (bug-1732206-rollout-fission-release-rollout-release-94-95) to this list of graduated rollouts (GRADUATION_SET) here (because we're using different prefs for the rollout and enabling by default):

https://searchfox.org/mozilla-central/rev/f62d42b1d98e67dc3da05d586f71103df02b8c4a/toolkit/components/normandy/lib/PreferenceRollouts.jsm#128-137

The rollout slug will need to stay in the graduation set forever. If a user gets enrolled in the rollout in Firefox 95, stops using it for a while, and then starts using the browser again in a version > 96, then we want to make sure that the Normandy instruction to graduate from the rollout is still present in versions > 96.

Flags: needinfo?(nika)
See Also: → 1745237
See Also: → 1745249

I've pushed a new patch which adds that item to the set.

Flags: needinfo?(nika)
Blocks: 1744581
See Also: 1744581
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f341c2c8bbee
Part 1: Override required_prefs in test_fission_autostart.py, r=whimboo,mccr8
https://hg.mozilla.org/integration/autoland/rev/6a8175e7c32b
Part 2: Add the ability to force-disable fission with an environment variable, r=ahal,fluent-reviewers,flod,mccr8
https://hg.mozilla.org/integration/autoland/rev/abc668080c89
Part 3: Remove fission from the experimental features pane in about:preferences, r=cpeterson,preferences-reviewers
https://hg.mozilla.org/integration/autoland/rev/bcf5711345c0
Part 4: Enable fission by default on non-android platforms, r=annyG,peterv,pbone,cpeterson
https://hg.mozilla.org/integration/autoland/rev/d6e8528f0a93
Part 5: Add the fission rollout slug to the GRADUATION_SET, r=mythmon
Depends on: 1745963
No longer depends on: 1745963
Regressions: 1745963
See Also: → 1671548
Regressions: 1746866
Regressions: 1750026
No longer regressions: 1747019
Regressions: 1751961
Regressions: 1753352
Regressions: 1753366
Regressions: 1758161
Regressions: 1752250
Regressions: 1759092
Regressions: 1759496
Regressions: 1763900
No longer regressions: 1751961
No longer regressions: 1750026
Regressions: 1764891
Regressions: 1765248
Regressions: 1782216
You need to log in before you can comment on or make changes to this bug.