Closed Bug 1762085 Opened 2 months ago Closed 2 months ago

Add PiP Video-Adapter for handling Funimation Subtitles

Categories

(Toolkit :: Picture-in-Picture, enhancement)

Firefox 100
enhancement

Tracking

()

VERIFIED FIXED
101 Branch
Tracking Status
firefox101 --- verified
firefox102 --- verified

People

(Reporter: admin, Assigned: admin)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

  1. Went of funimation.com
  2. Select a video (some can be played without an account)
  3. Enable subtitles on built-in video player
  4. Click on PiP button
  5. Subtitles do not appear in PiP, only appear in built-in video player

Actual results:

Subtitles did not properly work on funimation.com

Expected results:

Subtitles should appear in PiP

Since encountering this issue, I have added support for funimation on my local instance of FF Nightly.

The Bugbug bot thinks this bug should belong to the 'Toolkit::Video/Audio Controls' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit
Component: Video/Audio Controls → Picture-in-Picture
Assignee: nobody → admin
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: 1751505
Severity: -- → N/A
Pushed by kpatenio@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1236a6f789f2
Add video wrapper with subtitle support for funimation.com. r=niklas,kpatenio
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch
See Also: → 1765604
Blocks: 1765604
See Also: 1765604

This fix was verified on Nightly v102.0a1 and Beta v101.0b3 (20220504181604) on Windows 10, Ubuntu 20.04.4 LTS, Windows 7 and Mac OS 11.
The subtitles are now displaying correctly while on Release v100, they don't show at all.

Status: RESOLVED → VERIFIED
Severity: N/A → S3
You need to log in before you can comment on or make changes to this bug.