Last Comment Bug 180623 - Add Date & Time for started (or added) download
: Add Date & Time for started (or added) download
Status: VERIFIED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Download & File Handling (show other bugs)
: Trunk
: All All
: -- enhancement with 5 votes (vote)
: seamonkey2.0b2
Assigned To: Jens Hatlak (:InvisibleSmiley)
:
Mentors:
: 148650 193374 207598 209156 212812 213579 213697 402739 (view as bug list)
Depends on: 472001
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-17 13:26 PST by Nicolas Miceli
Modified: 2009-11-12 02:17 PST (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed patch (7.51 KB, patch)
2009-08-16 08:31 PDT, Jens Hatlak (:InvisibleSmiley)
neil: review+
neil: superreview+
Details | Diff | Review
patch v2 (9.67 KB, patch)
2009-08-17 13:05 PDT, Jens Hatlak (:InvisibleSmiley)
jh: review+
jh: superreview+
Details | Diff | Review

Description Nicolas Miceli 2002-11-17 13:26:44 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021115
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021115

Following bug 148650, Mozilla should record date and time a download has been
started, and have a corresponding column in Download Manager for better
organizing downloads.


Reproducible: Always

Steps to Reproduce:
Comment 1 Pham 2003-03-30 05:54:24 PST
Would be good, but we already have time elapsed/past and if you knew math you
could figure out when you started.

I wouldn''t even care when I started.
Comment 2 Nicolas Miceli 2003-03-30 11:42:34 PST
This is not about math. Pham.

It would give a the user a clue about when he downloaded what.

Time elapsed is a totally different thing. Try sorting all your downloads with
that column, a you have nothing usefull in your hands.
Comment 3 Ian Neal 2003-05-23 15:31:09 PDT
*** Bug 193374 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Versen [:Matti] 2003-05-30 02:38:17 PDT
*** Bug 207598 has been marked as a duplicate of this bug. ***
Comment 5 Patrick 2003-06-12 07:22:12 PDT
*** Bug 209156 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Versen [:Matti] 2003-07-15 18:49:26 PDT
*** Bug 212812 has been marked as a duplicate of this bug. ***
Comment 7 Boris Zbarsky [:bz] 2003-07-23 19:29:47 PDT
*** Bug 213579 has been marked as a duplicate of this bug. ***
Comment 8 Matthias Versen [:Matti] 2003-07-24 05:19:20 PDT
*** Bug 213697 has been marked as a duplicate of this bug. ***
Comment 9 Andy Gerweck 2003-07-25 12:45:32 PDT
I've just added my vote for this bug.  I'm tempted to call it a bug instead of
an enhancement since it really is a core part of what makes a download manager
useful.  Adding "Time Started" and "Time Finished" columns should be pretty easy.

I'd suggest including the start time by default as well.  This would really be
useful as I have a list of about a hundred downloads and I'm curious when they
went off.
Comment 10 Prognathous 2003-11-21 03:47:44 PST
Since some of the dupes included the word "column" it would probably be better
to rename the summary of this bug to "Add Date & Time columns for started (or
added) download". This would make it easier for users to find this bug and would
help prevent additional dupes.

Prog.
Comment 11 David E. Ross 2005-03-07 08:17:54 PST
I have voted for both this and bug 148650 in hope that one of them is
implemented.  For any log, the date and time of the log entry should always be
part of the entry.  
Comment 12 sturges 2006-03-09 00:03:04 PST
Given that this [simple to resolve] bug/omission has been around for several years with repetitive requests for resolution could someone please address the issue.

Mozilla do a lot of good work but if no one addresses annoying issues it tends to indicate that Open Source does not work so well when it comes to support.

Thanks
Comment 13 Frank Wein [:mcsmurf] 2007-11-15 01:48:17 PST
*** Bug 402739 has been marked as a duplicate of this bug. ***
Comment 14 Robert Kaiser (not working on stability any more) 2009-08-06 15:46:43 PDT
*** Bug 148650 has been marked as a duplicate of this bug. ***
Comment 15 Robert Kaiser (not working on stability any more) 2009-08-06 15:47:27 PDT
The new download manager UI introduced by bug 472001 is now aware of that data (both start and end timestamps), as the toolkit download manager records it. We do not expose it in UI yet and have no immediate plans for it, but we possibly would take a patch that adds it in the optional non-default set of available columns.
Comment 16 Jens Hatlak (:InvisibleSmiley) 2009-08-16 08:31:07 PDT
Created attachment 394723 [details] [diff] [review]
proposed patch
Comment 17 neil@parkwaycc.co.uk 2009-08-16 14:28:01 PDT
Comment on attachment 394723 [details] [diff] [review]
proposed patch

>       <treecol id="TimeElapsed" hidden="true"
>                label="&col.timeelapsed.label;"
>                tooltiptext="&col.timeelapsed.tooltip;"
>                class="sortDirectionIndicator" flex="1"
>                persist="width hidden ordinal sortActive sortDirection"/>
>       <splitter class="tree-splitter"/>
>+      <treecol id="StartTime" hidden="true"
>+               label="&col.starttime.label;"
>+               tooltiptext="&col.starttime.tooltip;"
>+               class="sortDirectionIndicator" flex="1"
>+               persist="width hidden ordinal sortActive sortDirection"/>
>+      <splitter class="tree-splitter"/>
>+      <treecol id="EndTime" hidden="true"
>+               label="&col.endtime.label;"
>+               tooltiptext="&col.endtime.tooltip;"
>+               class="sortDirectionIndicator" flex="1"
>+               persist="width hidden ordinal sortActive sortDirection"/>
>+      <splitter class="tree-splitter"/>
>       <treecol id="Source" hidden="true"
>                label="&col.source.label;"
>                tooltiptext="&col.source.tooltip;"
>                class="sortDirectionIndicator" flex="1"
>                persist="width hidden ordinal sortActive sortDirection"/>
[Strange that this list is in a slightly different order to the other three...]
Comment 18 neil@parkwaycc.co.uk 2009-08-17 01:22:08 PDT
Comment on attachment 394723 [details] [diff] [review]
proposed patch

[I wonder whether any of our columns should be right-aligned?]

>+      case "StartTime":
>+        if (dl.startTime)
>+          return new Date(dl.startTime).toLocaleString();
>+        return "";
>+      case "EndTime":
>+        if (dl.endTime)
>+          return new Date(dl.endTime).toLocaleString();
>+        return "";
I've just remembered that we don't use toLocaleString on dates. Instead I'd do something similar to what we do for History. sr=me with that fixed.
Comment 19 Closed Account 2009-08-17 03:04:25 PDT
(In reply to comment #18)
> (From update of attachment 394723 [details] [diff] [review])
> [I wonder whether any of our columns should be right-aligned?]

You could have to columns left aligned by default but when a user right clicks on the columns they can select left or right alignment.
Comment 20 Jens Hatlak (:InvisibleSmiley) 2009-08-17 13:05:28 PDT
Created attachment 394868 [details] [diff] [review]
patch v2

(In reply to comment #18)
> (From update of attachment 394723 [details] [diff] [review])
> [I wonder whether any of our columns should be right-aligned?]
> 
> >+      case "StartTime":
> >+        if (dl.startTime)
> >+          return new Date(dl.startTime).toLocaleString();
> >+        return "";
> >+      case "EndTime":
> >+        if (dl.endTime)
> >+          return new Date(dl.endTime).toLocaleString();
> >+        return "";
> I've just remembered that we don't use toLocaleString on dates.

Counter example (not saying it's better): abCardViewOverlay.js

> Instead I'd do something similar to what we do for History.

Probably a good idea.

(In reply to comment #19)
> (In reply to comment #18)
> > (From update of attachment 394723 [details] [diff] [review] [details])
> > [I wonder whether any of our columns should be right-aligned?]
> 
> You could have to columns left aligned by default but when a user right clicks
> on the columns they can select left or right alignment.

I guess Neil was referring to the default, static settings. Adding the ability to switch alignments seems a bit excessive to me. ;-)

Anyway, IMHO that discussion should be taken to a new bug - if anyone really cares about it.
Comment 21 Frank Wein [:mcsmurf] 2009-08-18 13:57:00 PDT
Pushed to comm-central http://hg.mozilla.org/comm-central/rev/2870eb8a8beb

Note You need to log in before you can comment on or make changes to this bug.