Closed Bug 1815096 Opened 1 year ago Closed 1 year ago

imap mark-as-deleted: doesn't advance to next on delete, if focus in message reader

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 111
defect

Tracking

(thunderbird114 fixed)

RESOLVED FIXED
115 Branch
Tracking Status
thunderbird114 --- fixed

People

(Reporter: mkmelin, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

See also bug 1815027.

With imap "just mark as deleted" deletion no longer advances to next message.

See Also: → 1815027
Whiteboard: [Supernova]
Blocks: 1823186

Oddly, I'm no longer seeing this, in the last few Daily builds.

For me, Delete is now advancing to the next msg. I'm using mark-as-deleted.

[MacOS Ventura 13.2.1]

I still see this on 112.0b5 Linux. Actually a couple of times I did get an advance which surprised me. But thats a couple of times out of 100s of deletes which didn't. I'm also mark-as-deleted.

Whiteboard: [Supernova] → [Supernova3p]

It started mostly working around the time of comment 1.
What the next message will be is however not always correct. Especially after archive it can jump to random position. In normal delete I haven't any problems.

I note that it seems to be dependent on where the focus is: if the focus is in the message list, it does advance. If the focus is in the message content reader, it does not advance.

But that may be intentional? I find it annoying (the lack of advance if I've clicked in the message reader area, and thus moved the focus).

115.0a1 (2023-05-09) (64-bit); MacOS Ventura 13.3.1 (a)

I hadn't noticed, but I can confirm that is indeed the case. (I don't think it's intentional)

Blocks: 1832471
Summary: imap mark-as-deleted: doesn't advance to next on delete → imap mark-as-deleted: doesn't advance to next on delete, if focus in message reader
Assignee: nobody → geoff
Status: NEW → ASSIGNED

If the command is run in about:message, the containing about:3pane doesn't know where to move selection do, so it does nothing.

Target Milestone: --- → 115 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/4bbdd8b29f95
Run archive/delete commands in about:3pane where possible. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Looks good; working for me now on 115.0a1 (2023-05-17). thanks very much!

Attachment #9333559 - Flags: approval-comm-beta?

Comment on attachment 9333559 [details]
Bug 1815096 - Run archive/delete commands in about:3pane where possible. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9333559 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: