Closed Bug 1823186 Opened 1 year ago Closed 9 months ago

No Advance and delayed marking in Inbox after message delete in Beta 112.0b1, with mark as deleted

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird112 affected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird112 --- affected

People

(Reporter: km, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/113.0.0.0 Safari/537.36

Steps to reproduce:

While reading through the INBOX delete a message

Actual results:

I can only speak to my situation with the "just mark it as deleted" setting. Nothing happens, no cross out no advance. If I do a manual advance by clicking on the next message it advances the cross out appears.

Expected results:

The cross out should be immediate, and it should advance to the next message.

Not advancing is bug 1815096. If it's not crossed over immediately, maybe you're in a filtered view? (There' s bug for that I think). It normally works for me.

Keywords: regression
Whiteboard: [Supernova]

I have more information to add after reading the suggestion that this is filter related

A newly opened INBOX in the main tab does correctly cross out messages when deleted. If I then filter, the now displayed messages, if a message is deleted, does not show the cross out until advanced to another message. That much is a regression since on the prebeta version they do show cross outs immediately within a filter.

However, thats not all. If I delete the filter resuming the full INBOX in the main tab, the same delayed cross out behavior persists. I have to load some irrelevant folder in the main tab, and then reload the INBOX in the main tab to get the cross out behavior back to working at time of delete.

Confirmed the above no-cross-out behaviour exactly as described: stops working in QFB and on return to INBOX, comes back after change to another folder then back to INBOX.

IMAP mark-as-deleted.

113.0a1 (2023-03-20) (64-bit); MacOS Ventura 13.2.1

Status: UNCONFIRMED → NEW
Ever confirmed: true

To clarify my last comment: the problem appears both in QFB, and after returning from it to INBOX:

INBOX: cross-out on delete is fine
QFB some selection: cross-out doesn't appear until manual advance
Esc-Esc INBOX: cross-out doesn't appear until manual advance
select Drafts folder
select INBOX: cross-out on delete is fine again

Please update the bug report after updating to 112.0b3.

There is also pre-supernova Bug 1659331 - FolderView \ Unified \ Issue with Deleting Mail if ServerSetting "just mark as deleted"

Depends on: 1815096
Summary: No Advance and delayed marking in Inbox after Message Delete in Beta 112.0b1 → No Advance and delayed marking in Inbox after message delete in Beta 112.0b1, with mark as deleted
Flags: needinfo?(km)

No change in 112.0b3

Flags: needinfo?(km)
Component: Untriaged → Folder and Message Lists
Blocks: sn-msglist
No longer blocks: sn-quickfilter
Whiteboard: [Supernova] → [Supernova3p]

I think this should be working properly in 114.0b1.

Depends on: 1832471

Can you still reproduce this with the latest beta or daily?

Flags: needinfo?(km)

It is pretty much fixed. The one caveat is that the advance is to the next message in list which may itself be a deleted message. It should really advance to the next undeleted message. This will be largely mute once the "view not deleted" view is available again. There is a separate bug for that Bug 1823182

Flags: needinfo?(km)
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.