Closed Bug 1817915 Opened 1 year ago Closed 1 year ago

Add context menu to "Get Messages" folder pane header button

Categories

(Thunderbird :: Folder and Message Lists, task)

Tracking

(thunderbird114? fixed)

RESOLVED FIXED
115 Branch
Tracking Status
thunderbird114 ? fixed

People

(Reporter: aleca, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(2 files)

We should implement a right click context menu on the "Get Messages" folder pane header button.
The context menu should list all currently available accounts and clicking on one of them should trigger the fetching of message for only that account.

Basically, identical behaviour of what we have in 102 with the Get Messages spin button.
This was the old toolbar button.

This uses the folder-menupopup class, which is a bit overkill for what we need, but some aspects of it are needed.
https://searchfox.org/comm-esr102/rev/68a40ae7eec56b5c562209fba62b80e7c9c18ffe/mailnews/base/content/folder-menupopup.js#1073
Let's sync up on this to find a good approach.

Add [Supernova] to Whiteboard 20230222_1327

Whiteboard: [Supernova]
Status: NEW → ASSIGNED

So the buttons with the drop-down menu are a thing of the past? The user now needs to "discover" the context menu? It's the same issue as for the Back/Forward buttons which now have a context menu with the history instead of a drop-down menu.

We will re-implement those spin buttons in pure HTML, but those are very very tricky.
They're not properly keyboard accessible, they don't communicate to screen readers the existence of a menupopup, and they don't allow triggering extra options via contextmenu keys, so they're a bit of a nightmare.
We need more time to properly build a semantically correct and fully accessible HTML spin button, so in the meantime we're adding the extra options that might be needed inside context menus.

Thanks for the explanation. Would a custom element work?

Duplicate of this bug: 1826406
Whiteboard: [Supernova] → [Supernova3p]
Assignee: elizabeth → nobody
Status: ASSIGNED → NEW
Duplicate of this bug: 1828352
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Target Milestone: --- → 115 Branch

Pushed by solange@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/83bd374aa2da
Add context menu to Get Messages folder pane button to fetch all messages or per account. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

The migration script that landed has an error. Follow-up patch to follow.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/58b2fd42f331
Follow-up: Fix error in string migration script. r=aleca

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED

Comment on attachment 9334586 [details]
Bug 1817915 - Follow-up: Fix error in string migration script. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9334586 - Flags: approval-comm-beta+

Comment on attachment 9333005 [details]
Bug 1817915 - Add context menu to Get Messages folder pane button to fetch all messages or per account. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9333005 - Flags: approval-comm-beta+
See Also: → 1837152
Duplicate of this bug: 1848153
See Also: → 281417
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: