Offline browse To-Do List

RESOLVED DUPLICATE of bug 91832

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 91832
18 years ago
9 years ago

People

(Reporter: Zac Spitzer, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Among the features I would like to see very much is a to-do browse list.

When browsing offline and I click on a URL which isn't in the cache, mozilla
could pop up a message saying "<b>You are currently offline. Would you like to
store this URL in a to-do list?</b>"

The to do list could be incorporated as a side bar panel. This panel should be
editable, ie add and delete entries manually. It would nice to be able to have
one click access to open all to-do links in new browser window.

It has been suggested to combine pre loading with this feature, I think that is
overkill.
Summary: Offline To-Do List → Offline To-Do List
I often find I want to do this, I think it would be excellent.

Updated

18 years ago
Assignee: leger → don
QA Contact: leger → paulmac

Comment 2

18 years ago
Punting to don to put on his ever growing enhancements list :-)

Updated

18 years ago
Summary: Offline To-Do List → [RFE] Offline To-Do List
Target Milestone: M20

Comment 3

18 years ago
spam: moving qa contact on some bugs from paulmac to sairuh@netscape.com
QA Contact: paulmac → sairuh

Comment 4

18 years ago
Move to "Future" milestone.
Target Milestone: M20 → Future
QA Contact: sairuh → tever
Target Milestone: Future → ---
don, is Future applicable now that Offline features are being implemented now?

Comment 6

18 years ago
In this case I think future is still applicable because this is still nothin' 
more than an enhancement request.  It does seem to be a pretty good idea 
though, I'll play around with implementing it.  Anyone have any suggestions 
about the best way to store this URL list?  perhaps just update or write to a 
local HTML file every time a link is clicked on, and load that HTML file in the 
sidebar?  Also, where deep in networking code might I find out how to determine 
whether a page is stored in the cache or not?

Comment 7

18 years ago
back to MFuture, we can ship without this feature.
If someone wants to go do this, fine, that's what
MFuture is for.
Target Milestone: --- → Future
adding helpwanted kw in response to mcafee's comment. :-)
Keywords: helpwanted

Updated

18 years ago
Depends on: 45611

Comment 9

17 years ago
Don't think you would need to determine whether a page was in the cache or not.
You just need to see whether you get an error loading the URL.Surely if you're
in offline mode, the only possible error you can get is if the page ain't there.
In fact, just do a search for 'Error loading URL'; add a line which says if
you're in offline mode, append the URL out to an html file.

Comment 10

17 years ago
And in fact, there it is: nsBrowserInstance.cpp#1539

Comment 11

17 years ago
Created attachment 12851 [details]
Outline of patch

Comment 12

17 years ago
reassigning to me, I'll take a look when I get back (from the dev meeting!)
Assignee: don → BlakeR1234

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 13

17 years ago
*** Bug 4884548845 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
WTF? 4884548845 was marked as dup?  Is this a bugzilla bug?

Comment 15

17 years ago
*** Bug 48845 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Priority: P3 → P5

Comment 16

17 years ago
Should users be able to sync this to-do list with handhelds (Palm, Visor, etc)?

Comment 17

17 years ago
No time right now.
Assignee: blakeross → ben
Status: ASSIGNED → NEW

Comment 18

17 years ago
There is a package called wwwoffle which seems to do what you want here.
The home page is http://www.gedanken.demon.co.uk/wwwoffle/ .
I think it would be great if this could be incorporated in Mozilla, especially
for Notebook users.

From the description:

While Online:
- Caching of pages that are viewed for later review.
- Conditional fetching to only get pages that have changed.

While Offline:
- Can be configured to use dial-on-demand for pages that are not cached.
- Selection of pages to download next time online
  - Using normal browser to follow links.
  - Command line interface to select pages for downloading.
- Control which pages can be requested when offline.
- Provides non-cached access to intranet servers.

Automated Download:
- Downloading of specified pages non-interactively.
- Options to automatically fetch objects in requested pages
  - Understands various types of pages
    - HTML 4.0, Java classes, VRML (partial), XML (partial).
  - Options to fetch different classes of objects
    - Images, Stylesheets, Frames, Scripts, Java or other objects.
- Automatically follows links for pages that have been moved.
- Can monitor pages at regular intervals to fetch those that have changed.
- Recursive fetching
  - To specified depth.
  - On any host or limited to same server or same directory.
  - Chosen from command line or from browser.
  - Control over which links can be fetched recursively.
OS: Windows NT → All

Comment 19

17 years ago
See also bug 63664, "[RFE] Temporary Bookmarks".

Comment 20

17 years ago
Should the links be in a bookmark list? Why not have the prompt open a File
Bookmarks default to a "To-Do List" folder? That way it can be access via the
bookmark sidebar panel.

Comment 21

17 years ago
I think it would be better to keep the 'to do' sidebar separate. It would need
to load up the list from a file, and then delete entries in the file as they are
browsed. Other than that, it could work the same as the bookmarks sidebar.

In offline mode, if a URL is requested which isn't in the cache it needs to be
appended to the file. This should be controlled by a pref 'when in offline mode,
add entries to the to-do file'.

Comment 22

17 years ago
I would think that a to-do list would be better served if it persisted rather
than automatically removed as one browse. On the other hand it would be handy to
have a way to empty this list when the user wants to. If the bookmark folder can
have a "empty folder" option. Currently this can be done by just deleting the
folder and recreating it.
Status: NEW → ASSIGNED

Comment 23

16 years ago
*** Bug 111141 has been marked as a duplicate of this bug. ***

Comment 24

16 years ago
Now that we have tabbed browser, it would be possible to open up each to-do 
entry in its own tab.

Comment 25

16 years ago
Calendar has it's own concept of a to-do list, and it would be cool if we could
integrate with that idea.  It could solve the problem of where to put the UI,
and allow us to persist the data easily.

Comment 26

16 years ago
Here are some ideas for this feature:

- context menu item for links: "add to list"
- drag and drop link into list
- button for "add all links on this page to list"
- possibility to "add list to history" to enable the use of back/forward buttons
to go through the list
- "mail list", opens a mail compose window with the list of urls in it
- file list as bookmarks
- save/open list
- open list in composer - creates an unordered list with links

Updated

16 years ago
Depends on: 113591

Comment 27

16 years ago
With all these suggestions, it sounds as if some kind of 'links manager' 
feature might be useful. You could then have a switch 'Follow links normally | 
add links I click on to links manager'. In offline mode, links could be added 
to the links manager automatically.

From the links manager, you could have options like 'save links to an html 
file, clear all links, open all links in browser, add all links from this page'.

The first time the links manager would be opened after starting Moz, it would 
contain all of the links from the previous session. This could be achieved by 
saving a 'links-manager.html' when you shut down, and reloading it when started.

What does everyone else think of this idea ?

Comment 28

16 years ago
gabriel,

Please read bug 91832.  I think this may be what you are after.

Comment 29

16 years ago
remove self

Comment 30

16 years ago
This bug is related to bug 45421.
As this is really a bells-and-whistle specialisation of 45421, maybe it should
depend on 45421.

Comment 31

16 years ago
*** Bug 157060 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: [RFE] Offline To-Do List → Offline To-Do List

Comment 32

14 years ago
<a href="http://www.wysigot.com/">Wysigot</a> (formerly ecatch) has provided
this feature in a very ergonomic manner for about 4 years. I think it is
somewhat based on MSIE. So maybe this "offline todo list" feature could be
provided as an extension ?

Anyway, I mark this bug as dependent on <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=229741">the bug #229741 I just
entered in bugzilla</a> since in order to build the offline todo list UI, a
persistent (offline) repository for content would be needed. And such a
repository would be useful for more than the offline todo list feature.

Updated

14 years ago
Depends on: 229741
Product: Browser → Seamonkey

Comment 33

12 years ago
[wow, it has a patch outline.]

should this bug 91832 be duped to or block by this bug?

Bug 63664
Assignee: bugs → general
Status: ASSIGNED → NEW
QA Contact: tever → general
Summary: Offline To-Do List → Offline browse To-Do List
Priority: P5 → --
Target Milestone: Future → ---

Comment 34

9 years ago
bug 91832 is broader but includes this idea.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 91832
You need to log in before you can comment on or make changes to this bug.