Closed Bug 1839006 Opened 8 months ago Closed 7 months ago

Zoom does not work in the multi-message view

Categories

(Thunderbird :: Mail Window Front End, defect, P1)

Thunderbird 115

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115+ fixed, thunderbird116? fixed)

RESOLVED FIXED
117 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 + fixed
thunderbird116 ? fixed

People

(Reporter: standard8, Assigned: babolivier)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

Zoom no longer works in the mulit-message view in the latest nightly/beta builds. This works in 102.

It looks like the options are not available.

This is an accessibility issue and is also likely to affect the Conversations add-on.

mulit-message view

Do you mean message summary? (multi-select)

Flags: needinfo?(standard8)
Version: unspecified → Thunderbird 115

(In reply to Wayne Mery (:wsmwk) from comment #1)

mulit-message view

Do you mean message summary? (multi-select)

Yes, it is called multi-message behind the scenes :)

Flags: needinfo?(standard8)

xref bug 1825627 (where it was fixed for other cases)

Whiteboard: [Supernova3p]
Assignee: nobody → brendan
Status: NEW → ASSIGNED

Setting this high priority and severity because it might impact readability and accessibility of the multi message view

Severity: -- → S2
Priority: -- → P1
Attachment #9341982 - Attachment description: WIP: Bug 1839006 - Fix zoom on multi-message view. r=#thunderbird-reviewers → Bug 1839006 - Fix zoom on multi-message view. r=#thunderbird-reviewers
Blocks: sn-msglist
Target Milestone: --- → 117 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c78419409aed
Fix zoom on multi-message view. r=aleca,freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

Comment on attachment 9341982 [details]
Bug 1839006 - Fix zoom on multi-message view. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): Difficult to pinpoint to a specific bug as this was caused during the refactoring work around the 3 panes view.
User impact if declined: Updating the zoom using keyboard shortcuts on the multi-message view does not work, possibly causing issues for accessibility.
Testing completed (on c-c, etc.): On c-c
Risk to taking this patch (and alternatives if risky): Low risk, the patch does update the signature of existing functions used elsewhere in the code but does so in a backwards-compatible way.

Attachment #9341982 - Flags: approval-comm-esr115?
Attachment #9341982 - Flags: approval-comm-beta?

Comment on attachment 9341982 [details]
Bug 1839006 - Fix zoom on multi-message view. r=#thunderbird-reviewers

[Triage Comment]
approved for beta

thanks for the tests

Attachment #9341982 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9341982 [details]
Bug 1839006 - Fix zoom on multi-message view. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9341982 - Flags: approval-comm-esr115? → approval-comm-esr115+
See Also: → 1853442
See Also: → 1850586
You need to log in before you can comment on or make changes to this bug.