Closed Bug 1856218 Opened 8 months ago Closed 4 months ago

Support highlighting images of text in addition of text

Categories

(Firefox :: PDF Viewer, enhancement)

Firefox 118
enhancement

Tracking

()

VERIFIED FIXED
124 Branch
Tracking Status
firefox-esr115 --- disabled
firefox122 --- disabled
firefox123 --- disabled
firefox124 --- verified

People

(Reporter: thekarananand, Assigned: calixte)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Steps to reproduce:

Just open a PDF File made of Images of Text in Firefox.

Actual results:

I am Requesting for the Ablility to Highlight text, as well as freely Highlighting on an Image PDFs. Look at the attached Image. This feature is not these in Firefox

Expected results:

Firefox should be able to freely highlight on a PDF File made of Images of Text

The Bugbug bot thinks this bug should belong to the 'Firefox::PDF Viewer' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → PDF Viewer

Thanks for the suggestions, we were actually thinking of implementing highlight (bug 1846098).
Being able to freely highlight any part of the PDF (and not "just" text) might be something we support as part of the highlighting feature.

Blocks: 1846098
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Requesting Enhance PDF Highlighting Feature → Consider supporting highlighting images of text in addition of text

It

Summary: Consider supporting highlighting images of text in addition of text → Support highlighting images of text in addition of text
Duplicate of this bug: 1868755
Assignee: nobody → cdenizet
Status: NEW → ASSIGNED
No longer depends on: 1876341
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch

This issue is Verified as fixed in our latest Nightly build 124.0a1 (2024-01-30). We can Now highlight freely in a pdf file.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: