Closed Bug 1867513 Opened 6 months ago Closed 23 days ago

Enable highlighting in a PDF in Release

Categories

(Firefox :: PDF Viewer, task)

task

Tracking

()

RESOLVED FIXED
127 Branch
Tracking Status
relnote-firefox --- 125+
firefox124 --- wontfix
firefox125 --- wontfix
firefox126 + fixed
firefox127 --- fixed

People

(Reporter: marco, Assigned: calixte)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Once we are ready to ship, we should turn the pref on in Release.

Release Note Request (optional, but appreciated)
[Why is this notable]: A new user visible feature in the PDF viewer.
[Affects Firefox for Android]: No.
[Suggested wording]: It is now possible to highlight information in the Firefox PDF viewer.
[Links (documentation, blog post, etc)]: N/A

See Also: → 1867830
Depends on: 1877426

Hi :marco! is this still being targeted for Fx124?

Flags: needinfo?(mcastelluccio)

Yes, we are planning to land a couple more fixes before the soft freeze, and potentially uplift telemetry (if we don't manage to get it in time for the soft freeze), but we should be ready for 124.

Flags: needinfo?(mcastelluccio)
Assignee: nobody → cdenizet
Status: NEW → ASSIGNED
See Also: → 1867512

We should enable this by default in 125, and keep it disabled in 124 as we will control the pref there through Nimbus.

will 124+ relnote flag when final release notes draft is available where we will mention gradual rollout
Relnote Image has already been uploaded

(In reply to Dianna Smith [:diannaS] from comment #4)

will 124+ relnote flag when final release notes draft is available where we will mention gradual rollout
Relnote Image has already been uploaded

This image refers to "add an image", which we released a while ago.
We should build another image for highlighting.

We have decided to release the feature in 125 instead because of bug 1881743 and bug 1881746.
We will release it through an experiment, so we can turn the pref on by default in 126.

[Tracking Requested - why for this release]: We are releasing through Nimbus on 125, and by default in 126.

:marco since we are tracking this for Fx126, will a patch be attached to this bug to enable it by default?

Flags: needinfo?(mcastelluccio)

Yes, Calixte will build and land the patch.

Flags: needinfo?(mcastelluccio) → needinfo?(cdenizet)

Next week is the final week of beta for Fx126, last chance to uplift a patch for this

Attachment #9398488 - Flags: approval-mozilla-beta?

beta Uplift Approval Request

  • User impact if declined: They won't be able to highlight in a pdf
  • Code covered by automated testing: yes
  • Fix verified in Nightly: yes
  • Needs manual QE test: no
  • Steps to reproduce for manual QE testing:
  • Risk associated with taking this patch: Low
  • Explanation of risk level: It's a new feature which is behind a pref
  • String changes made/needed: No
  • Is Android affected?: no
Pushed by cdenizet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cffa531d3b2e
Enable highlighting in a PDF in beta 126 r=marco
Status: ASSIGNED → RESOLVED
Closed: 23 days ago
Resolution: --- → FIXED
Target Milestone: --- → 127 Branch
Attachment #9398488 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(cdenizet)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: